Results 1 to 4 of 4

Thread: Catalyst 11.1, 6870 still unsupported?

  1. #1
    Join Date
    Jan 2011
    Posts
    2

    Default Catalyst 11.1, 6870 still unsupported?

    Just installed the 11.1 drivers using AUR for ArchLinux, and I'm still getting the Unsupported Hardware watermark with my 6870. Can somebody else with Barts (6850/6870) hardware confirm this behaviour? Things seem to be working alright for the most part, I just want to know if I should be modifying the driver (per some scripts floating around out there) or reinstalling.

    Thanks

  2. #2
    Join Date
    Jan 2011
    Posts
    1

    Default

    i confirm this behavior, Ubuntu 10.10 x64 , installed directly running driver file.

    this script helped remove the watermark:

    Code:
    #!/bin/sh
     DRIVER=/usr/lib/xorg/modules/drivers/fglrx_drv.so
     for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
     sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER
     done
    i just installed it a few minutes ago, seems ok for desktop use, will later test 3d game
    CCCLE running without problem

  3. #3
    Join Date
    May 2009
    Posts
    5

    Default

    Yup, still displays the unsupported watermark (removed with Kano's script), and still have to use a certain minimal xorg.conf to get it work. Ubuntu 10.10 x64, ASUS 6870, and FGLRX 11.1.

  4. #4
    Join Date
    Dec 2008
    Posts
    1

    Default Suse 11.3 results 6870

    Well the 11.1 got rid of the "unsupported" on SuSE 11.3 x64 but the tearing is worse now than with the older driver.

    Either with or without the setting makes no difference there is a definite "jerkiness" to moving of stuff around whereas it was nice and smooth before.

    kwin though not tried compiz yet.

    Ah well you win some you lose some.

    HTH

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •