Results 1 to 5 of 5

Thread: VT screen corruption

  1. #1
    Join Date
    Aug 2006
    Posts
    3

    Default VT screen corruption

    When I switch to a virtual terminal using "CTRL+ALT+F1-F6" i'm getting screen corruption.

    My Specs:
    X800XL
    Ubuntu 6.10 Edgy Eft
    X Window System Version 7.1.1
    ATI FGLRX 8.29.6

    I see yellow lines all over the screen.

    Anyone else having this problem?

    Thanks.

  2. #2

    Default

    If I recall correctly, this is a known issue with the fglrx display drivers. Not sure off hand if anyone has figured a work-around -- you may want to check the BugZilla.

  3. #3
    Join Date
    Jun 2006
    Location
    Austria
    Posts
    115

    Default

    I'm in no way familiar with this bug, but you may want to try enabling or disabling - depending on whether you're using it at the moment or not - the framebuffer console for your VTs.

    Apart from that, there's always the free drivers. They should even provide hardware-accelerated GLX for your graphics adapter by now.

  4. #4
    Join Date
    Aug 2006
    Posts
    3

    Default

    Quote Originally Posted by colo View Post
    I'm in no way familiar with this bug, but you may want to try enabling or disabling - depending on whether you're using it at the moment or not - the framebuffer console for your VTs.

    Apart from that, there's always the free drivers. They should even provide hardware-accelerated GLX for your graphics adapter by now.
    I tried using the "ati" driver that comes with edgy and it reports "no screens found". With the "radeon" driver I get the same screen corruption. This makes be think that this is an Xorg 7.1 issue, or a config issue on my side.

    Anyone else have any insight??

  5. #5
    Join Date
    Feb 2007
    Posts
    2

    Default

    I already had this problem on 2 Ubuntu installations (both 32 and 64 bit) and from what I found, this error is related to the boot/GRUB/Splash screen resolution with the ATI drivers installed.
    You should try and change this resolution to get your virtual terminal work again.

    See here http://www.ubuntuforums.org/showthread.php?p=1541970 for a very well explained post on how to change this.
    Basically you need to test different vga= options on the #defoptions line of your /boot/grub/menu.lst file.

    I have no exact and always working solution because... it depends even on the same hardware !
    For me the resolution that solved the problem is 1280x1024x24 in Ubuntu 32-bit :
    Code:
    # defoptions=quiet splash vga=795
    And with the exact same machine, I need to stay in 640x480 to avoid virtual terminal corruption in Ubuntu 64-bit.

    (All this is with ATI's latest 8.33.6 drivers installed.)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •