Page 5 of 7 FirstFirst ... 34567 LastLast
Results 41 to 50 of 61

Thread: AMD 8.37.6 -- The no R600 or AIGLX Support Version

  1. #41
    Join Date
    Jun 2007
    Posts
    2

    Default

    Quote Originally Posted by d2kx View Post
    curzondax, this is because the new OpenGL driver isn't integrated yet.
    wait, what? where is that info? any approximate dates on it?

  2. #42
    Join Date
    Apr 2007
    Posts
    29

    Default

    Quote Originally Posted by Huenengrab View Post
    I'm not even going to try the new drivers. Its basically all the same with fglrx. When ATI/AMD releases their hopefully better OpenGL-Driver, I'll give it a shot, as long as it happens this year. As soon as UT3/Quake Wars gets released, I'm planning on building a new machine, that'll be as linux-compatible as possible. If ATI/AMD didn't improve anything until then, ATI-graphics are dead for me.
    Why the "if"? ATI/AMD has proven themselves to be completely untrustworthy for anything related to Linux. Save yourself the trouble and buy nvidia (or maybe intel if what they come up with is fast enough), even if ATI magically fixes their driver problems.

  3. #43
    Join Date
    Oct 2006
    Posts
    42

    Default

    Quote Originally Posted by Michael View Post
    The AMD/ATI fglrx 8.37.6 driver is now available... It contains X server 1.3 naming fix, AMDCCCLE v1.0 (adds translations and the 3D page), RHEL5 support, and some random fixes.

    https://a248.e.akamai.net/f/674/9206...ux_8.37.6.html



    http://www.phoronix.com/vr.php?view=10069


    FEDORA USERS, READ THIS
    Okay, here's the scoop on Fedora 7. WIth AMD fixing the X 1.3 problem, the drivers will build. However, when you install the RPMs for Fedora 7, aticonfig will crash and will remove your xorg.conf (though the original is renamed). If you manually update your xorg.conf and then restart X, fglrx will fail to load and you'll find a backtrace in your Xorg.0.log. So if you need the fglrx drivers to survive, don't upgrade to Fedora 7 just yet. Stay tuned to the forums for more information. This issue with 8.37 should not cause problems with Fedora Core 6 or previous versions.
    This is indeed bad news for the F7 adopters with ATI cards who who want 3D. Looks like they have to settle for the open source driver.

    Michael, I posted your statement above to the FedoraForum.

    Partha
    www.partha.com

  4. #44
    Join Date
    Jun 2007
    Posts
    37

    Default

    You're completely right gfxdrone.ATI or AMD had enough time,don't care for merging.It's their tradition,lousy linux support.They already had their punch with detonators and this wake them up from dreams for making catalyst drivers.First of all, I don't even like name of drivers "frgl" (it reminds me of fireGL and Quadro line).Second, on their driver page, on linux driver's, Radeon X1950 (pro)is not listed, unlike on Windows tm's driver page.Again no AIGLX and,yes Michael no Xorg 7.2 support
    50.9MB 8.37.6 May 31, 2007 Automated installer and Display Drivers for XFree86 4.3 and X.Org 6.7, 6.8, 6.9, 7.0, 7.1
    .I already try it.I will install FC7.Now I will sell my X1950pro and buy some nVIDIA instead (it seems now,no use of my 975XBX2 crossfire support ),maybe some 7100,7200 or something turbocache(no hypermemory warp speed) crap.At least I will have AIGLX and 3D support.I can run beryl on my noFX5200(Dawn)-64 MB card.So what is use of my powerful RV570? Only on XP,Vista? No thanks.Maybe improvement around folding@home, nice job ATi or maybe AMD, M$ is proud of you.
    And by the way nVIDIA drivers are some 13 MB's comparing to whoping 50 ATI's.So what's the problem CLI kind of driving.No problem for me.

  5. #45
    Join Date
    May 2007
    Posts
    17

    Default

    I'm seeing much higher temps at times with 8.37 than with Feisty's stock 8.34 on my T60. Is anyone else seeing symptoms like that?

    Temperature occasionally jumps up 15 degrees for no apparent reason which makes the fans go crazy, then slowly goes down.

    See also http://www.phoronix.net/forums/showthread.php?t=2890 which I eventually solved by going back to stock Ubuntu drivers...

    The following is the output of the thinkpad fan control script. The fourth integer in the bracketed list gives GPU temperature, which jumps up at times for no reason (see the 3rd line, fan didnt run at all before, then it jumps up 11 degrees which make it run full speed):

    L=0->0 EC=00 RPM= 0 T=(48 34 35 61 30 _ 28 _ , 35 46 45 , _ ) Z=0+00000_0_,000,_
    L=0->0 EC=00 RPM= 0 T=(48 34 34 61 30 _ 28 _ , 35 46 45 , _ ) Z=0+00000_0_,000,_
    L=0->7 EC=00 RPM= 0 T=(48 34 35 70 30 _ 28 _ , 36 46 45 , _ ) Z=0+00060_0_,000,_
    > Changing fan level: 0->7 (temps: 48 34 35 70 30 _ 28 _ , 36 46 45 , _ )
    L=7->7 EC=07 RPM=2561 T=(48 34 35 69 30 _ 28 _ , 36 46 45 , _ ) Z=6+00060_0_,000,_
    L=7->7 EC=07 RPM=2561 T=(48 34 35 71 30 _ 28 _ , 36 46 45 , _ ) Z=6+00060_0_,000,_
    L=7->7 EC=07 RPM=2561 T=(48 34 35 74 30 _ 28 _ , 36 46 45 , _ ) Z=6+00060_0_,000,_
    L=7->7 EC=07 RPM=4287 T=(48 34 35 72 30 _ 28 _ , 35 46 45 , _ ) Z=6+00060_0_,000,_
    L=7->7 EC=07 RPM=3916 T=(48 34 35 72 30 _ 28 _ , 35 46 45 , _ ) Z=6+00060_0_,000,_
    L=7->7 EC=07 RPM=3916 T=(48 34 35 71 30 _ 28 _ , 35 46 45 , _ ) Z=6+00060_0_,000,_
    L=7->7 EC=07 RPM=3967 T=(47 34 35 71 30 _ 28 _ , 35 46 45 , _ ) Z=6+00060_0_,000,_
    L=7->7 EC=07 RPM=3967 T=(47 34 35 70 30 _ 28 _ , 35 46 45 , _ ) Z=6+00060_0_,000,_
    L=7->7 EC=07 RPM=3967 T=(47 34 35 71 30 _ 28 _ , 35 46 45 , _ ) Z=6+00060_0_,000,_
    L=7->4 EC=07 RPM=3980 T=(47 33 35 64 30 _ 28 _ , 35 46 45 , _ ) Z=4+00020_0_,000,_
    Last edited by bimbo; 06-02-2007 at 05:00 AM.

  6. #46
    Join Date
    May 2007
    Posts
    17

    Default

    So since I can't seem to fix that temperature jump issue, has anyone got a patch for 8.35 to get the kernel module build on 2.6.21.3 (no it's not the paravirt ops issue)?

  7. #47

    Default

    Quote Originally Posted by bimbo View Post
    So since I can't seem to fix that temperature jump issue, has anyone got a patch for 8.35 to get the kernel module build on 2.6.21.3 (no it's not the paravirt ops issue)?
    You should be able to replace the 8.35 firegl_public code with the 8.37 firegl_public code and it should build against 2.6.21 or 2.6.22.

  8. #48
    Join Date
    Apr 2007
    Location
    Paderborn
    Posts
    40

    Default

    Quote Originally Posted by DirtyHairy View Post
    Just for the notes, things have improved for me a bit on a Tinkpad T60 (X1400, Gentoo stable with xorg-server 1.2.0) with 8.37 . While xv simply was gone with 8.36, it has reappeared for me with 8.37. It is still broken though, I get colored stripes, the xv window isn't properly hidden by other windows, and when maximized, I get an odd "hanging" effect in playback with the video stopping every second and jumping back a frame (looks like double buffering issue). On the other hand, vsync with opengl now works for me, which it never did before making opengl finally an emergency replacement for xv (which it wasn't before since I find tearing in playback very annoying).

    Still, I switched back to 8.35 which is the best-working version for me so far.
    First I thought XVideo is running now fine.
    Now I saw, I've got the same issue. Mplayer has this one, xine is crashing with XV, so they didn't fix it!!!

  9. #49
    Join Date
    May 2007
    Posts
    17

    Default

    Currently, I'm mulling over importing a T61 with GMA X3100 from the US (I live in Switzerland, Lenovo doesnt sell those here) and ebay my 1 month old T60...

  10. #50
    Join Date
    Apr 2007
    Location
    Salvador - Bahia - Brazil
    Posts
    79

    Default

    I have a new installation of Ubuntu feisty and this message on var/log/Xorg.0.log

    (II) fglrx(0): driver needs X.org 7.1.x.y with x.y >= 0.0
    (II) fglrx(0): detected X.org 7.1.0.0
    (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed! *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO) *
    (WW) fglrx(0): * no 3D acceleration available *
    (WW) fglrx(0): ********************************************* *

    i googled for this and found nothing useful.

    fglrx does not seems to load, even if manually forced.

    i'm really stuck right there.

    I followed, as always did, the instruction on this wiki.

    http://wiki.cchtml.com/index.php/Ubu...river_Manually

    With my previous feisty installation and 8.36.5 driver at least was working.

    Anyone?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •