Results 1 to 4 of 4

Thread: AMD 8.37.6 Display Driver

  1. #1
    Join Date
    Jan 2007
    Posts
    14,321

    Default AMD 8.37.6 Display Driver

    Phoronix: AMD 8.37.6 Display Driver

    It was a year ago that AMD/ATI had delivered the fglrx 8.25.18 display driver, which corrected a bug causing issues with the Radeon X1000 512MB video cards, added new product support, and squashed a variety of other bugs. Well, today AMD delivered the 8.37.6 Linux display driver. Affecting this driver the most is support for X server version 1.3 and appended several other fixes along with a slight upgrade to the AMD Catalyst Control Center Linux Edition. While no AIGLX support was added or no new features introduced, the upgrade should be worth the time.

    http://www.phoronix.com/vr.php?view=10069

  2. #2
    Join Date
    Jun 2007
    Posts
    37

    Default

    the upgrade should be worth the time
    Of course

    Here is what I get:
    *** glibc detected *** aticonfig: munmap_chunk(): invalid pointer: 0xbff73b14 ***
    ======= Backtrace: =========
    /lib/libc.so.6(cfree+0x1bb)[0x7176ab]
    aticonfig[0x805c5c7]
    aticonfig[0x805c875]
    aticonfig[0x8054528]
    aticonfig[0x804985e]
    aticonfig[0x80496cb]
    /lib/libc.so.6(__libc_start_main+0xe0)[0x6c1f70]
    aticonfig[0x8049601]
    ======= Memory map: ========
    00110000-0020e000 r-xp 00000000 08:09 83698 /usr/lib/libX11.so.6.2.0
    0020e000-00212000 rwxp 000fe000 08:09 83698 /usr/lib/libX11.so.6.2.0
    00212000-00217000 r-xp 00000000 08:09 83630 /usr/lib/libXdmcp.so.6.0.0
    00217000-00218000 rwxp 00004000 08:09 83630 /usr/lib/libXdmcp.so.6.0.0
    00218000-0021b000 r-xp 00000000 08:09 376863 /lib/libdl-2.6.so
    0021b000-0021c000 r-xp 00002000 08:09 376863 /lib/libdl-2.6.so
    0021c000-0021d000 rwxp 00003000 08:09 376863 /lib/libdl-2.6.so
    0036c000-0036d000 r-xp 0036c000 00:00 0 [vdso]
    0050c000-0050e000 r-xp 00000000 08:09 83441 /usr/lib/libXau.so.6.0.0
    0050e000-0050f000 rwxp 00001000 08:09 83441 /usr/lib/libXau.so.6.0.0
    0065e000-00685000 r-xp 00000000 08:09 376865 /lib/libm-2.6.so
    00685000-00686000 r-xp 00026000 08:09 376865 /lib/libm-2.6.so
    00686000-00687000 rwxp 00027000 08:09 376865 /lib/libm-2.6.so
    006ac000-007fa000 r-xp 00000000 08:09 376857 /lib/libc-2.6.so
    007fa000-007fc000 r-xp 0014e000 08:09 376857 /lib/libc-2.6.so
    007fc000-007fd000 rwxp 00150000 08:09 376857 /lib/libc-2.6.so
    007fd000-00800000 rwxp 007fd000 00:00 0
    0084c000-00852000 r-xp 00000000 08:09 83706 /usr/lib/libXrandr.so.2.1.0
    00852000-00853000 rwxp 00005000 08:09 83706 /usr/lib/libXrandr.so.2.1.0
    009ec000-009f4000 r-xp 00000000 08:09 83702 /usr/lib/libXrender.so.1.3.0
    009f4000-009f5000 rwxp 00007000 08:09 83702 /usr/lib/libXrender.so.1.3.0
    00b59000-00b74000 r-xp 00000000 08:09 376850 /lib/ld-2.6.so
    00b74000-00b75000 r-xp 0001a000 08:09 376850 /lib/ld-2.6.so
    00b75000-00b76000 rwxp 0001b000 08:09 376850 /lib/ld-2.6.so
    00dc0000-00dcb000 r-xp 00000000 08:09 376834 /lib/libgcc_s-4.1.2-20070503.so.1
    00dcb000-00dcc000 rwxp 0000a000 08:09 376834 /lib/libgcc_s-4.1.2-20070503.so.1
    00f9c000-00fab000 r-xp 00000000 08:09 83700 /usr/lib/libXext.so.6.4.0
    00fab000-00fac000 rwxp 0000e000 08:09 83700 /usr/lib/libXext.so.6.4.0
    08048000-08067000 r-xp 00000000 08:09 93431 /usr/bin/aticonfig
    08067000-0806a000 rw-p 0001e000 08:09 93431 /usr/bin/aticonfig
    084f6000-08517000 rw-p 084f6000 00:00 0
    b7f63000-b7f66000 rw-p b7f63000 00:00 0
    b7f74000-b7f75000 rw-p b7f74000 00:00 0
    bff5f000-bff75000 rw-p bff5f000 00:00 0 [stack]
    Aborted
    It's ok, I have ATI CCC installed,but no frgl.

    Next card will be nVDA.Thats all what I know.

  3. #3
    Join Date
    Mar 2007
    Location
    West Australia
    Posts
    356

    Default

    My ATi card seems to work fine now. I can switch back to the console, I've only had one hang so far and I think that's due to my poor quality motherboard. I have had a reduction in frame rate and video playback is no longer as fast as it was. I can't play 720p video's at full rate anymore. But I'm not too worried about that. At least now I no longer get garbage pixels on the screen, even though it looked funky.

    I might still get a x1950 to replace my x1600 pro, regardless of what all the other sheep say about ATi. AMD still seem to be pretty well off now that things are under way. Hopefully the next generation of video products really shine.

    Here are some of my results:


    10:33:17 ~$ fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: Radeon X1600 Series
    OpenGL version string: 2.0.6473 (8.37.6)

    10:57:42 ~$ fgl_glxgears
    Using GLX_SGIX_pbuffer
    2481 frames in 5.0 seconds = 496.200 FPS
    2488 frames in 5.0 seconds = 497.600 FPS
    2489 frames in 5.0 seconds = 497.800 FPS

    10:58:06 ~$ glxgears
    9565 frames in 5.0 seconds = 1912.981 FPS
    9720 frames in 5.0 seconds = 1943.833 FPS
    9717 frames in 5.0 seconds = 1943.255 FPS

    11:02:57 ~$ uname -a
    Linux Starship.Enterprize.C 2.6.21.3 #1 PREEMPT Wed Jun 6 17:07:50 WST 2007 i686 AMD Athlon(tm) XP 2100+ AuthenticAMD GNU/Linux

    I also have about 1GB of ram and run on a very simple fvwm desktop.
    Last edited by b15hop; 06-12-2007 at 10:55 PM.

  4. #4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •