To my great surprise, after battling with getting the AMD APP (OpenCL) SDK to work in Maverick with fglrx, and actually stopping up and reading the System Requirements, I notice that my graphics card isn't supported. It seems the 4xxx series isn't even properly supported (beta level), so I fear that my card will never be.

Am I not being fair expecting a ~3 year old graphics card to be supported by new technologies? Are there any technical difficulties in implementing OpenCL on older GPUs because of different hardware? Or will support come for the 3xxx series at some point?

I feel like I bought that card yesterday... Maybe I'm just getting old (too)?