Results 1 to 2 of 2

Thread: Clone monitor with ATI's fglrx

  1. #1
    Join Date
    Jun 2007
    Posts
    20

    Default Clone monitor with ATI's fglrx

    I'm running ATI's latest driver (May 31 2007) on linux 2.6.20 with an ATI X1600 video card.

    I am trying to clone the two video outputs, but can only get side-by-side (extended desktop) to work. My xorg.conf is below. Can someone see anything that should be changed to enable cloning?

    Thanks,
    Michelle

    --------------------

    Section "ServerLayout"
    Identifier "Multihead layout"
    Screen 0 "aticonfig-Screen[0]" 0 0
    Screen 1 "aticonfig-Screen[1]" RightOf "aticonfig-Screen[0]"
    InputDevice "Keyboard0" "CoreKeyboard"
    Option "Xinerama" "off"
    Option "Clone" "on"
    EndSection

    Section "ServerLayout"
    Identifier "Clone"
    Screen 0 "aticonfig-Screen[0]" 0 0
    # Screen 1 "aticonfig-Screen[1]" RightOf "aticonfig-Screen[0]"
    InputDevice "Keyboard0" "CoreKeyboard"
    Option "Xinerama" "off"
    Option "Clone" "on"
    EndSection

    Section "Files"
    ModulePath "/usr/lib/xorg/modules"
    EndSection

    Section "Module"
    Load "dbe" # Double buffering
    Load "vnc"
    Load "extmod"
    # Next line is for ATI proprietary driver
    # Load "glx"
    # Next line is for open source ati driver
    Load "dri"
    EndSection

    # Test - do I need this?
    Section "DRI"
    Group 0
    Mode 0666
    EndSection

    # ATI does not support composite, so disable
    Section "Extensions"
    # Option "Composite" "disable"
    EndSection

    Section "ServerFlags"
    # Next line is to prevent error AIGLX error: dlsym for __driCreateNewScreen_20050727 failed
    Option "AIGLX" "off"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]"
    # Option "VendorName" "ATI Proprietary Driver"
    # Option "ModelName" "Generic Autodetecting Monitor"
    Option "VendorName" "Sony"
    Option "ModelName" "VPL-HS51"
    Option "DPMS" "true"
    Modeline "1280x720_75" 74.48 1280 1336 1472 1664 720 721 724 746 +hsync
    Modeline "1280x720_60" 60.46 1280 1328 1456 1632 720 721 724 741 +hsync
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[1]"
    # Option "VendorName" "ATI Proprietary Driver"
    # Option "ModelName" "Generic Autodetecting Monitor"
    Option "VendorName" "SilverstoneTek"
    Option "ModelName" "Internal Monitor"
    Option "DPMS" "true"
    Modeline "1280x720_75" 74.48 1280 1336 1472 1664 720 721 724 746 +hsync
    Modeline "1280x720_60" 60.46 1280 1328 1456 1632 720 721 724 741 +hsync
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    BusID "PCI:6:0:0"
    Option "OverlayOnCRTC2" "1"
    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "off"
    Option "DesktopSetup" "horizontal"
    Option "TexturedVideo" "on"
    Option "TexturedVideoSync" "off"
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[1]"
    Driver "fglrx"
    BusID "PCI:6:0:0"
    Screen 1
    Option "OverlayOnCRTC2" "1"
    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "off"
    Option "DesktopSetup" "horizontal"
    Option "TexturedVideo" "on"
    Option "TexturedVideoSync" "off"
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device "aticonfig-Device[0]"
    Monitor "aticonfig-Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1280x720_75" "1280x720_60"
    EndSubSection
    Option "PasswordFile" "/home/mythtv/.vnc/passwd"
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[1]"
    Device "aticonfig-Device[1]"
    Monitor "aticonfig-Monitor[1]"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1280x720_75" "1280x720_60"
    EndSubSection
    Option "PasswordFile" "/home/mythtv/.vnc/passwd"
    EndSection

  2. #2
    Join Date
    Jun 2007
    Location
    .ro/.ca
    Posts
    232

    Default

    Quote Originally Posted by ocgltd
    Section "ServerLayout"
    Identifier "Multihead layout"
    Screen 0 "aticonfig-Screen[0]" 0 0
    Screen 1 "aticonfig-Screen[1]" RightOf "aticonfig-Screen[0]"
    InputDevice "Keyboard0" "CoreKeyboard"
    Option "Xinerama" "off"
    Option "Clone" "on"
    EndSection

    Section "ServerLayout"
    Identifier "Clone"
    Screen 0 "aticonfig-Screen[0]" 0 0
    # Screen 1 "aticonfig-Screen[1]" RightOf "aticonfig-Screen[0]"
    InputDevice "Keyboard0" "CoreKeyboard"
    Option "Xinerama" "off"
    Option "Clone" "on"
    EndSection
    Why you have two ServerLayout sections is beyond me. Besides, did you notice how it says "Screen 1 "aticonfig-Screen[1]" RightOf "aticonfig-Screen[0]"" ? I'd assume it has something to do with the "extended desktop" you talk about. The RightOf is a dead give-away for me...

    If you have only one screen section (not to mention one ServerLayout), then Clone mode should be on by default (just restart your x server).

    Try amdcccle next time. It has nice, click-able interface.
    And you're posting in the wrong section.
    Last edited by Xipeos; 06-06-2007 at 05:30 PM. Reason: extended

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •