Page 3 of 10 FirstFirst 12345 ... LastLast
Results 21 to 30 of 97

Thread: fireglcontrolpanel + FC6

  1. #21
    Join Date
    Oct 2006
    Posts
    3

    Default

    I might try to reinstall and see what happens. I tried creating the link and it didn't work. I am wondering if I am having a conflict with the 32bit stuff it needs that I think I have installed plus the 64 bit stuff I have installed.

    As ati mentions on thier page.

    The following 32 bit packages must be installed in order for 64 bit drivers to install and work properly:
    XFree86-Mesa-libGL
    libstdc++
    libgcc
    XFree86-libs
    fontconfig
    expat
    freetype
    zlib

    At this link.

    https://support.ati.com/ics/support/...e&folderID=300

    Do you know if the 8.30 drivers allow the desktop effects?

    take care,
    Bob

  2. #22
    Join Date
    Oct 2006
    Posts
    12

    Default

    Quote Originally Posted by bobgun04 View Post
    I might try to reinstall and see what happens. I tried creating the link and it didn't work. I am wondering if I am having a conflict with the 32bit stuff it needs that I think I have installed plus the 64 bit stuff I have installed.

    As ati mentions on thier page.

    The following 32 bit packages must be installed in order for 64 bit drivers to install and work properly:
    XFree86-Mesa-libGL
    libstdc++
    libgcc
    XFree86-libs
    fontconfig
    expat
    freetype
    zlib

    At this link.

    https://support.ati.com/ics/support/...e&folderID=300

    Do you know if the 8.30 drivers allow the desktop effects?

    take care,
    Bob
    8.30 drivers do not allow desktop effects.
    One of the things I did to get it to work (as I described earlier with linking some off .so files) is try to compile the control panel as stated earlier in this thread. You might notice /usr/bin/ld reporting a few missing libraries (like -lqt not found) and you might try symbolically linking the .so lib files like I described earlier.

  3. #23
    Join Date
    Nov 2006
    Posts
    1

    Default

    Quote Originally Posted by bobgun04 View Post
    I might try to reinstall and see what happens. I tried creating the link and it didn't work. I am wondering if I am having a conflict with the 32bit stuff it needs that I think I have installed plus the 64 bit stuff I have installed.
    I successfully compiled and installed the 8.30.3 drivers on an AMD64 machine. the only thing I did to get rid of the control panel problems was to create the following link:

    ln -s /usr/lib64/qt-3.3/lib/ /usr/lib64/qt-3.3/lib64

    as root.

  4. #24
    Join Date
    Oct 2006
    Posts
    11

    Default

    I have followed the instructions in this post.

    and made the following symlink

    Code:
    ln -sf /usr/lib64/qt-3.3/lib64 /usr/lib/qt-3.3/lib
    I am now getting the following error

    Code:
    [root@dh7c8rb1 ati]# make
    g++ FGLRXExtensions.o ATITVOExtensions.o  main.o Sheet.o Page.o InfoPage.o DualScreenPage.o AdjustPage.o TVoutAdjustPage.o BoardInfo.o  moc_Sheet.o moc_Page.o moc_InfoPage.o moc_DualScreenPage.o moc_AdjustPage.o moc_TVoutAdjustPage.o    -o fireglcontrol.qt3.gcc4.1.1  -L/usr/lib/qt-3.3/lib -L/usr/X11R6/lib -lqt -lGLU -lGL -lXmu -lICE -lSM -ldl -lXext -lX11 -lm -lXinerama -lXrender -lfreetype -lXxf86vm -L/usr/X11R6/lib -lXft
    /usr/bin/ld: cannot find -lqt
    collect2: ld returned 1 exit status
    make: *** [fireglcontrol.qt3.gcc4.1.1] Error 1

  5. #25
    Join Date
    Oct 2006
    Posts
    3

    Default

    Thanks Michael and cardinal

    As soon as I added the proper link is compiled perfectly with no errors. So thanks again. I was almost going to install ubuntu but I prefer Fedora.

    Take care,
    Bob

  6. #26
    Join Date
    Jun 2006
    Posts
    1

    Default

    Strange... I was getting this:
    [root@am64 ati]# make
    g++ FGLRXExtensions.o ATITVOExtensions.o main.o Sheet.o Page.o InfoPage.o DualScreenPage.o AdjustPage.o TVoutAdjustPage.o BoardInfo.o moc_Sheet.o moc_Page.o moc_InfoPage.o moc_DualScreenPage.o moc_AdjustPage.o moc_TVoutAdjustPage.o -o fireglcontrol.qt3.gcc4.1.1 -L/usr/lib64/qt-3.3/lib64 -L/usr/X11R6/lib64 -lqt-mt -lGLU -lGL -lXmu -lICE -lSM -ldl -lXext -lX11 -lm -lXinerama -lXrender -lfreetype -lXxf86vm -L/usr/X11R6/lib64 -lXft
    /usr/bin/ld: cannot find -lGL
    collect2: ld returned 1 exit status
    make: *** [fireglcontrol.qt3.gcc4.1.1] Error 1

    And this fixed it:

    [root@am64 ati]# ln -s /usr/lib64/fglrx/libGL.so /usr/lib

  7. #27
    Join Date
    Oct 2006
    Posts
    11

    Default

    I have tried both symlinks with no success , i am borderline getting ready to start from scratch, not that I think that will help.

  8. #28

    Default

    Quote Originally Posted by hookooekoo View Post
    I have tried both symlinks with no success , i am borderline getting ready to start from scratch, not that I think that will help.
    Are you running into the same error or what?

  9. #29
    Join Date
    Oct 2006
    Posts
    11

    Default

    yeah the same one as posted above.

  10. #30

    Default

    If you wanted, you could throw fireglcontrolpanel out of the RPM build process. If you need help with that just let me know.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •