Results 1 to 6 of 6

Thread: How do I disable DRI ?

  1. #1
    Join Date
    Oct 2010
    Posts
    25

    Default How do I disable DRI ?

    Hi, it's a stupid question but I wonder how do I disable Radeon DRI? I have a AMD 760G integrated
    graphics, Ubuntu 10.10 with all the stock drivers.

    I tried

    Option "noDRI"
    Option "DRI" "false"

    and commented out

    Load "dri2"
    Load "dri"
    Load "glx"

    from xorg.conf and restarted. I check Xorg.0.log and DRI is still enabled, glx, dri, dri2 are still loaded.
    Some relevant sections from Xorg.0.log:

    [ 429.225]
    X.Org X Server 1.9.0
    Release Date: 2010-08-20
    [ 429.226] X Protocol Version 11, Revision 0
    [ 429.226] Build Operating System: Linux 2.6.24-28-server x86_64 Ubuntu
    [ 429.226] Current Operating System: Linux HomeDesktop 2.6.37 #5 SMP Sat Jan 29 11:40:50 EST 2011 x86_64
    [ 429.226] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.37 root=UUID=8b558104-bb9a-4775-bc96-2fad195b0528 ro
    [ 429.226] Build Date: 09 January 2011 12:14:27PM
    [ 429.226] xorg-server 2:1.9.0-0ubuntu7.3 (For technical support please see http://www.ubuntu.com/support)
    [ 429.226] Current version of pixman: 0.18.4
    [ 429.226] Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    [ 429.226] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [ 429.226] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Jan 29 11:51:18 2011
    [ 429.226] (==) Using config file: "/etc/X11/xorg.conf"

    ...
    [ 429.244] (II) Module ABI versions:
    [ 429.244] X.Org ANSI C Emulation: 0.4
    [ 429.244] X.Org Video Driver: 8.0
    [ 429.244] X.Org XInput driver : 11.0
    [ 429.244] X.Org Server Extension : 4.0
    [ 429.244] (--) PCI:*(0:1:5:0) 1002:9616:1002:0000 rev 0, Mem @ 0xd0000000/268435456, 0xfeaf0000/65536, 0xfe900000/104
    8576, I/O @ 0x0000d000/256
    [ 429.245] (II) Open ACPI successful (/var/run/acpid.socket)
    [ 429.245] (II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
    [ 429.245] (II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
    [ 429.245] (II) "glx" will be loaded by default.
    [ 429.245] (II) "record" will be loaded. This was enabled by default and also specified in the config file.
    [ 429.245] (II) "dri" will be loaded by default.
    [ 429.245] (II) "dri2" will be loaded by default.
    [ 429.245] (II) LoadModule: "extmod"
    [ 429.245] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
    [ 429.245] (II) Module extmod: vendor="X.Org Foundation"
    ...
    [ 429.299] (II) [KMS] Kernel modesetting enabled.
    [ 429.299] (==) RADEON(0): Depth 24, (--) framebuffer bpp 32
    [ 429.299] (II) RADEON(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
    [ 429.299] (==) RADEON(0): Default visual is TrueColor
    [ 429.299] (**) RADEON(0): Option "DRI" "false"
    [ 429.299] (==) RADEON(0): RGB weight 888
    [ 429.299] (II) RADEON(0): Using 8 bits per RGB (8 bit DAC)
    [ 429.299] (--) RADEON(0): Chipset: "ATI Radeon 3000 Graphics" (ChipID = 0x9616)
    [ 429.299] (II) RADEON(0): PCI card detected
    [ 429.299] (WW) RADEON(0): Color tiling is not yet supported on R600/R700
    [ 429.299] (II) RADEON(0): KMS Color Tiling: disabled
    [ 429.299] drmOpenDevice: node name is /dev/dri/card0
    [ 429.299] drmOpenDevice: open result is 9, (OK)
    [ 429.299] drmOpenByBusid: Searching for BusID pci:0000:01:05.0
    [ 429.299] drmOpenDevice: node name is /dev/dri/card0
    [ 429.299] drmOpenDevice: open result is 9, (OK)
    [ 429.299] drmOpenByBusid: drmOpenMinor returns 9
    [ 429.299] drmOpenByBusid: drmGetBusid reports pci:0000:01:05.0
    ...
    [ 429.643] (II) RADEON(0): [DRI2] Setup complete
    [ 429.643] (II) RADEON(0): [DRI2] DRI driver: r600
    [ 429.643] (II) RADEON(0): Front buffer size: 7392K
    [ 429.643] (II) RADEON(0): VRAM usage limit set to 222667K
    [ 429.643] (==) RADEON(0): Backing store disabled
    [ 429.643] (II) RADEON(0): Direct rendering enabled
    [ 429.643] (II) RADEON(0): Setting EXA maxPitchBytes
    [ 429.643] (II) EXA(0): Driver allocated offscreen pixmaps
    [ 429.643] (II) EXA(0): Driver registered support for the following operations:
    [ 429.643] (II) Solid
    [ 429.643] (II) Copy
    [ 429.643] (II) Composite (RENDER acceleration)
    [ 429.643] (II) UploadToScreen
    [ 429.643] (II) DownloadFromScreen
    [ 429.644] (II) RADEON(0): Acceleration enabled
    [ 429.644] (**) RADEON(0): DPMS enabled
    [ 429.644] (==) RADEON(0): Silken mouse enabled
    [ 429.644] (II) RADEON(0): Set up textured video
    [ 429.644] (II) RADEON(0): RandR 1.2 enabled, ignore the following RandR disabled message.
    [ 429.644] (--) RandR disabled

    [ 429.653] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
    [ 429.653] (II) AIGLX: enabled GLX_INTEL_swap_event
    [ 429.653] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
    [ 429.653] (II) AIGLX: enabled GLX_SGI_make_current_read
    [ 429.653] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
    [ 429.654] (II) AIGLX: Loaded and initialized /usr/lib/dri/r600_dri.so
    [ 429.654] (II) GLX: Initialized DRI2 GL provider for screen 0

  2. #2
    Join Date
    Dec 2007
    Posts
    2,329

    Default

    With KMS, DRI is always enabled since the drm is always required. You can however disable acceleration with:
    Option "NoAccel" "True"
    in the device section of your xorg.conf.

  3. #3
    Join Date
    Oct 2010
    Posts
    25

    Default

    Thanks. Do you know if I'll get the same powersaving as "noDRI" option if I set "noAccel" to "true" ?

  4. #4
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,386

    Default

    Quote Originally Posted by ntt2010 View Post
    Thanks. Do you know if I'll get the same powersaving as "noDRI" option if I set "noAccel" to "true" ?
    If you are looking for power saving you might do better to put the accelerator into a low power mode. Have you tried something like a "low" profile from :

    http://www.x.org/wiki/RadeonFeature

  5. #5
    Join Date
    Dec 2007
    Posts
    2,329

    Default

    Quote Originally Posted by ntt2010 View Post
    Thanks. Do you know if I'll get the same powersaving as "noDRI" option if I set "noAccel" to "true" ?
    I'm not sure what power saving features you are talking about. Power management features are independent of acceleration. Not using the 3D engine may save some power, but that just means the CPU has to handle acceleration, so I'm not sure it's a win overall.

  6. #6
    Join Date
    Jun 2008
    Posts
    55

    Default What Benefit Is There to Disabling Acceleration?

    Quote Originally Posted by agd5f View Post
    With KMS, DRI is always enabled since the drm is always required. You can however disable acceleration with:
    Option "NoAccel" "True"
    in the device section of your xorg.conf.
    Unless power usage goes up significantly with DRI (or DRI2) active (and there's little to no data indicating that, even at the bottom end), why turn it off if it works?

    Now, there have been reasons *before* to turn DRI/DRI2 off on a case-by-case basis - however, energy savings has never been it. (Typically, the reason has been other issues - such as video playback/interference; not the electric bill.)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •