Results 1 to 5 of 5

Thread: Stutter/jerky DVD playback w/ATI drivers

  1. #1
    Join Date
    Jun 2007
    Posts
    20

    Default Stutter/jerky DVD playback w/ATI drivers

    I have an X1600 running on Linux 2.6.18 FC6, with ATI's latest drivers 8.37.6

    There are no errors in the xorg.0.log file, and ATI's fglrx drivers are reported in fglrxinfo (for regular graphics and OpenGL too). Overall graphics look good.

    The problem is that when I playback a DVD, the video (in MythTV) is jerky / stuttery. I'm stumped....anyone know where to turn?

    Thanks,
    MD

  2. #2
    Join Date
    Jun 2007
    Location
    .ro/.ca
    Posts
    232

    Default

    You are probably not using hardware acceleration with your media player. Try to set your MythVideo to use mplayer and xv like this:

    At the main screen, scroll down to Setup, then Video Settings, then Player Settings. Here you'll see a box which contains the command line MythFrontend will launch your video file with. %s is a variable which corresponds to the file path and name of the file you're going to play. All you need to do is edit this command line to run whatever player you like
    (from http://www.mythtv.org/wiki/index.php/MythVideo )
    Use "mplayer -vo xv" which should work with your ATI card, but don't expect miracles (especially for HD) and prepare yourself for an X server crash from time to time (hint: try to hide your Always on top windows before opening the media).

    I find vidix to be much better (faster, crash-free) than XVideo, but it may not work on your card (it doesn't on my X850 XT PE).
    For vidix use "mplayer -vo xvidix".

    If you don't have mplayer, then use xine as described on the MythTV wiki ("xine -pfhq --no-splash") and change the video driver from the video menu (you may need to increase your "configuration experience level" to see it).

    Hope that helps...
    Last edited by Xipeos; 06-11-2007 at 12:46 PM. Reason: typo

  3. #3
    Join Date
    Jun 2007
    Posts
    20

    Default

    I confirmed that Myth is using mplayer (internal) for viewing my DVD's (which are copied as ISO's onto my hard drive).

    My mplayer configuration file (/etc/mplayer/mplayer.conf) is:
    Code:
    # Default video output is xv, then xvidix, then try others
    vo=xv,xvidix,
    # Default audio output is alsa, then try others
    ao=alsa,alsa1x,
    So I think it is already using xv....and still choppy.

    There is one strange clue: When the DVD first starts to play, motion etc. look great! Then, I select from the DVD menu (usually play movie) and then it becomes choppy. Why would the intro video look great, and then movie look jerky?

    Thanks,
    MD




    Quote Originally Posted by Xipeos View Post
    You are probably not using hardware acceleration with your media player. Try to set your MythVideo to use mplayer and xv like this:


    (from http://www.mythtv.org/wiki/index.php/MythVideo )
    Use "mplayer -vo xv" which should work with your ATI card, but don't expect miracles (especially for HD) and prepare yourself for an X server crash from time to time (hint: try to hide your Always on top windows before opening the media).

    I find vidix to be much better (faster, crash-free) than XVideo, but it may not work on your card (it doesn't on my X850 XT PE).
    For vidix use "mplayer -vo xvidix".

    If you don't have mplayer, then use xine as described on the MythTV wiki ("xine -pfhq --no-splash") and change the video driver from the video menu (you may need to increase your "configuration experience level" to see it).

    Hope that helps...

  4. #4
    Join Date
    Jun 2007
    Location
    .ro/.ca
    Posts
    232

    Default

    Can you try playing it directly with mplayer?
    Code:
    mplayer dvd:// -dvd-device </path/to/dvd>
    or with xine?
    Code:
    xine dvd://
    I confirmed that Myth is using mplayer (internal)
    the "internal" part doesn't sound quite right...
    Also, depending on how mplayer was installed, it may look for mplayer.conf in /usr/etc and not /etc .

  5. #5
    Join Date
    Jun 2007
    Posts
    20

    Default

    Ok - we're making progress!! No matter what I do, mplayer will always play the ISO as jerky (even with the -vo xv parameter). However, it plays back perfectly under xine. (I can't explain why)

    I switched mythtv over to play ISO's using xine and that seems to have worked. (perhaps an mplayer bug?) By the way, is "internal" them same as "mplayer" in mythtv (player type)?

    Next, I tried to playback recorded tv shows in mythtv. Again they are choppy. Is there a way to force TV show playback to use xine? Although these are supposed to be mpg files, when I try to play them directly from xine they appear a mess...

    Thanks,
    Md


    Quote Originally Posted by Xipeos View Post
    Can you try playing it directly with mplayer?
    Code:
    mplayer dvd:// -dvd-device </path/to/dvd>
    or with xine?
    Code:
    xine dvd://

    the "internal" part doesn't sound quite right...
    Also, depending on how mplayer was installed, it may look for mplayer.conf in /usr/etc and not /etc .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •