Hi,

I desperately try to have linux working on my new PC

Whatever the distro, kernel version, intel driver version I get a black screen at boot, and the only way to have a display is to boot with the nomodeset option, the result is a very low resolution.

I suspect a screen issue, as if the driver doesn't succeed to ged EDID info from the panel, which is an HP 1920x1080 LCD display.

If someone could help me it would be great because I'm running out of ideas and I'm tired to browse the forums

Here are some relevant informations :

PC : HP All in One 200-5130 "WX099EA"

result of lspci is here :
http://susepaste.org/82014885

CPU : core i3 + HD graphics

Distro : Opensuse 11.3 but I tried Ubuntu 10.10, Fedora 14, Debian 6 all in X64 version with the same result.

Kernel : 2.6.36, 2.6.37, 2.6.38

Graphics package : Intel driver 2.13 and 2.14
Mesa 7.10
X server 1.9

Here is the Xorg log with kernel 2.6.37 and all the latest graphics packages

http://susepaste.org/84915419

As I said, it looks like the driver is unable to detect a screen.
Yet the VESA driver succeeds in this task :

http://www.susepaste.org/47473683

But the VESA driver is unable to set a 1920x1080 resolution!

Of course I tried different tweak as Xorg -configure, tune the xorg.conf.d/50-screen.conf, but without success.

Thank you to spend some time on my issue that drives me crazy!