Results 1 to 2 of 2

Thread: Installing HD 4890 drivers

  1. #1
    Join Date
    Feb 2011
    Posts
    6

    Default Installing HD 4890 drivers

    I have been trying to get my 4890 working in Ubuntu 10.10 but haven't been able to get it working. The easiest way seems to be to use through System->Administration->Additional Drivers. When I try that, I see an ATI FireGL driver not the one with "fglrx" in it.

    When I try to install with the .run file from the ATI website, it looks like it works but I get segfault when I run fglrxinfo. I have read a lot of guides about how to do this but nothing seems to work so far. Is there a specific set of packages or setting I need to do before I run the installer or try to install the restricted drivers from Ubuntu?

  2. #2
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by spaceghost View Post
    I have been trying to get my 4890 working in Ubuntu 10.10 but haven't been able to get it working. The easiest way seems to be to use through System->Administration->Additional Drivers. When I try that, I see an ATI FireGL driver not the one with "fglrx" in it.
    When I try to install with the .run file from the ATI website, it looks like it works but I get segfault when I run fglrxinfo. I have read a lot of guides about how to do this but nothing seems to work so far. Is there a specific set of packages or setting I need to do before I run the installer or try to install the restricted drivers from Ubuntu?
    the catalyst in the 10.10 ubuntu rep is obsolete if you load the run from amd.com you get the 11.1 this one is much better.

    in my testings cat 10.10 in ubuntu 10.10 only wins in wine support because 11.1 do not show textures in battlefild1942 and crash in oblivion.

    but for desktop use 11.1 is much better.

    i personalty do not have success by installing the catalyst with the installer but kano's install skript work most of the time if the normal installer fails.

    maybe you should try kano's install skript. it helps me more than 1 time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •