Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: OpenGL not working with ATI, FC6?

  1. #11
    Join Date
    Nov 2006
    Posts
    11

    Default

    yeah I just checked, Composite is Disabled in the Extensions section...

  2. #12

    Default

    Don't use the graphical installer... that's your problem right there. From the terminal run sh ati-driver-installer-8.30.3.run --buildpkg Fedora/FC6

  3. #13
    Join Date
    Nov 2006
    Posts
    11

    Default

    Quote Originally Posted by Michael View Post
    Don't use the graphical installer... that's your problem right there. From the terminal run sh ati-driver-installer-8.30.3.run --buildpkg Fedora/FC6
    ok... I'll do that and I'll let you know!

    Thanks.

  4. #14
    Join Date
    Nov 2006
    Posts
    11

    Default

    hmm... it says that it can't find the kernel-devel package... but it is installed... is there anything else that needs to be installed?

    Also, I don't have anything in the /usr/src/linux directory... do I need to create a link from it to somewhere?!

  5. #15

    Default

    Install kernel-headers

  6. #16
    Join Date
    Nov 2006
    Posts
    5

    Default can not disable composite w/o DRI crashing & hard freeze (it seems)

    I have a problem similar to this. Here is my Xorg.0.log towards the end (last 300 lines) where I start to get statements about a process, drmopendevice, getting errors.

    (I had to make this two posts)

    Code:
    (II) fglrx(0): blueX: 0.155 blueY: 0.155   whiteX: 0.313 whiteY: 0.329
    (II) fglrx(0): Manufacturer's mask: 0
    (II) fglrx(0): Supported additional Video Mode:
    (II) fglrx(0): clock: 68.9 MHz   Image Size:  331 x 207 mm
    (II) fglrx(0): h_active: 1280  h_sync: 1296  h_sync_end 1344 h_blank_end 1408 h_border: 0
    (II) fglrx(0): v_active: 800  v_sync: 801  v_sync_end 804 v_blanking: 816 v_border: 0
    (II) fglrx(0):  SAMSUNG
    (II) fglrx(0):  LTN154X3-L01
    (II) fglrx(0): End of Display1 EDID data --------------------
    (II) fglrx(0): Primary Controller - LCD on internal LVDS
    (II) fglrx(0): Internal Desktop Setting: 0x00000008
    (II) fglrx(0): POWERplay version 3.  1 power state available:
    (II) fglrx(0):   1. 301/250MHz @ 60Hz [enable load balancing]
    (==) fglrx(0): Qbs disabled
    (==) fglrx(0): FAST_SWAP disabled
    (==) fglrx(0):  PseudoColor visuals disabled
    (==) fglrx(0): Using gamma correction (1.0, 1.0, 1.0)
    (==) fglrx(0): Center Mode is disabled 
    (==) fglrx(0): TMDS coherent mode is enabled 
    (II) fglrx(0): Total of 13 modes found for primary display.
    (--) fglrx(0): Virtual size is 1280x800 (pitch 0)
    (**) fglrx(0): *Mode "1280x800": 68.9 MHz (scaled from 0.0 MHz), 49.0 kHz, 60.0 Hz
    (II) fglrx(0): Modeline "1280x800"   68.94  1280 1296 1344 1408  800 801 804 816
    (II) Loading sub module "fb"
    (II) LoadModule: "fb"
    (II) Loading /usr/lib/xorg/modules/libfb.so
    (II) Module fb: vendor="X.Org Foundation"
            compiled for 7.1.1, module version = 1.0.0
            ABI class: X.Org ANSI C Emulation, version 0.3
    (II) Loading sub module "ramdac"
    (II) LoadModule: "ramdac"
    (II) Loading /usr/lib/xorg/modules/libramdac.so
    (II) Module ramdac: vendor="X.Org Foundation"
            compiled for 7.1.1, module version = 0.1.0
            ABI class: X.Org Video Driver, version 1.0
    (==) fglrx(0): NoAccel = NO
    (II) Loading sub module "xaa"
    (II) LoadModule: "xaa"
    (II) Loading /usr/lib/xorg/modules/libxaa.so
    (II) Module xaa: vendor="X.Org Foundation"
            compiled for 7.1.1, module version = 1.2.0
            ABI class: X.Org Video Driver, version 1.0
    (==) fglrx(0): HPV inactive
    (==) fglrx(0): FSAA enabled: NO
    (==) fglrx(0): FSAA Gamma enabled
    (==) fglrx(0): FSAA Multisample Position is fix
    (==) fglrx(0): NoDRI = NO
    (II) Loading sub module "fglrxdrm"
    (II) LoadModule: "fglrxdrm"
    (II) Reloading /usr/lib/xorg/modules/linux/libfglrxdrm.so
    (II) fglrx(0): Depth moves disabled by default
    (==) fglrx(0): Capabilities: 0x00000000
    (==) fglrx(0): CapabilitiesEx: 0x00000000
    (==) fglrx(0): cpuFlags: 0x4000001f
    (==) fglrx(0): OpenGL ClientDriverName: "fglrx_dri.so"
    (**) fglrx(0): ATI GART size: 128 MB
    (==) fglrx(0): UseFastTLS=0
    (==) fglrx(0): BlockSignalsOnLock=1
    (==) fglrx(0): EnablePrivateBackZ = NO
    (--) Depth 24 pixmap format is 32 bpp
    (II) do I need RAC?  No, I don't.

  7. #17
    Join Date
    Nov 2006
    Posts
    5

    Default

    Code:
    (II) resource ranges after preInit:
            [0] 0   0       0xb0100000 - 0xb010ffff (0x10000) MX[B]
            [1] 0   0       0xc0000000 - 0xcfffffff (0x10000000) MX[B]
            [2] -1  0       0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
            [3] -1  0       0x000f0000 - 0x000fffff (0x10000) MX[B]
            [4] -1  0       0x000c0000 - 0x000effff (0x30000) MX[B]
            [5] -1  0       0x00000000 - 0x0009ffff (0xa0000) MX[B]
            [6] -1  0       0xb020a400 - 0xb020a4ff (0x100) MX[B]
            [7] -1  0       0xb0208800 - 0xb02088ff (0x100) MX[B]
            [8] -1  0       0xb0208c00 - 0xb0208cff (0x100) MX[B]
            [9] -1  0       0xb020a000 - 0xb020a0ff (0x100) MX[B]
            [10] -1 0       0xb0206000 - 0xb0207fff (0x2000) MX[B]
            [11] -1 0       0xb0204000 - 0xb0205fff (0x2000) MX[B]
            [12] -1 0       0xb0200000 - 0xb0203fff (0x4000) MX[B]
            [13] -1 0       0xb0208000 - 0xb02087ff (0x800) MX[B]
            [14] -1 0       0xb0003800 - 0xb00038ff (0x100) MX[B]
            [15] -1 0       0xb0003400 - 0xb00034ff (0x100) MX[B]
            [16] -1 0       0xb0003000 - 0xb00033ff (0x400) MX[B]
            [17] -1 0       0xb0002000 - 0xb0002fff (0x1000) MX[B]
            [18] -1 0       0xb0001000 - 0xb0001fff (0x1000) MX[B]
            [19] -1 0       0xb0000000 - 0xb0000fff (0x1000) MX[B]
            [20] -1 0       0xb0100000 - 0xb010ffff (0x10000) MX[B](B)
            [21] -1 0       0xc0000000 - 0xcfffffff (0x10000000) MX[B](B)
            [22] 0  0       0x000a0000 - 0x000affff (0x10000) MS[B](OprU)
            [23] 0  0       0x000b0000 - 0x000b7fff (0x8000) MS[B](OprU)
            [24] 0  0       0x000b8000 - 0x000bffff (0x8000) MS[B](OprU)
            [25] 0  0       0x00009000 - 0x000090ff (0x100) IX[B]
            [26] -1 0       0x0000ffff - 0x0000ffff (0x1) IX[B]
            [27] -1 0       0x00000000 - 0x000000ff (0x100) IX[B]
            [28] -1 0       0x0000a000 - 0x0000a0ff (0x100) IX[B]
            [29] -1 0       0x00008410 - 0x0000841f (0x10) IX[B]
            [30] -1 0       0x00000374 - 0x00000374 (0x1) IX[B]
            [31] -1 0       0x00000170 - 0x00000170 (0x1) IX[B]
            [32] -1 0       0x000003f4 - 0x000003f4 (0x1) IX[B]
            [33] -1 0       0x000001f0 - 0x000001f0 (0x1) IX[B]
            [34] -1 0       0x00008400 - 0x0000840f (0x10) IX[B]
            [35] -1 0       0x00009000 - 0x000090ff (0x100) IX[B](B)
            [36] 0  0       0x000003b0 - 0x000003bb (0xc) IS[B](OprU)
            [37] 0  0       0x000003c0 - 0x000003df (0x20) IS[B](OprU)
    (II) fglrx(0): UMM Bus area: 0xc05e9000 (size=0x079f7000)
    (II) fglrx(0): UMM area:     0x605e9000 (size=0x079f7000)
    (II) fglrx(0): driver needs X.org 7.1.x.y with x.y >= 0.0
    (II) fglrx(0): detected X.org 7.1.1.0
    (II) Loading extension ATIFGLRXDRI
    (II) fglrx(0): doing DRIScreenInit
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 7, (OK)
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 7, (OK)
    drmOpenByBusid: Searching for BusID PCI:1:5:0
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 7, (OK)
    drmOpenByBusid: drmOpenMinor returns 7
    drmOpenByBusid: drmGetBusid reports 
    drmOpenDevice: node name is /dev/dri/card1
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card2
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card3
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card4
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card5
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card6
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card7
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card8
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card9
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card10
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card11
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card12
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card13
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card14
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 7, (OK)
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 7, (OK)
    drmGetBusid returned ''
    (II) fglrx(0): [drm] DRM interface version 1.0
    (II) fglrx(0): [drm] created "fglrx" driver at busid "PCI:1:5:0"
    (II) fglrx(0): [drm] added 8192 byte SAREA at 0x2000
    (II) fglrx(0): [drm] mapped SAREA 0x2000 to 0xb6e9c000
    (II) fglrx(0): [drm] framebuffer handle = 0x3000
    (II) fglrx(0): [drm] added 1 reserved context for kernel
    (II) fglrx(0): DRIScreenInit done
    (II) fglrx(0): Kernel Module Version Information:
    (II) fglrx(0):     Name: fglrx
    (II) fglrx(0):     Version: 8.31.5
    (II) fglrx(0):     Date: Nov  9 2006
    (II) fglrx(0):     Desc: ATI FireGL DRM kernel module
    (II) fglrx(0): Kernel Module version matches driver.
    (II) fglrx(0): Kernel Module Build Time Information:
    (II) fglrx(0):     Build-Kernel UTS_RELEASE:        2.6.17-10-generic
    (II) fglrx(0):     Build-Kernel MODVERSIONS:        no
    (II) fglrx(0):     Build-Kernel __SMP__:            no
    (II) fglrx(0):     Build-Kernel PAGE_SIZE:          0x1000
    (II) fglrx(0): [drm] register handle = 0x00004000
    (II) fglrx(0): [pcie] 131072 kB allocated with handle 0xdeadbeef
    (II) fglrx(0): [drm] ringbuffer size = 0x00100000 bytes
    (II) fglrx(0): [drm] DRM buffer queue setup: nbufs = 100 bufsize = 65536
    (II) fglrx(0): [drm] texture shared area handle = 0x00008000
    (II) fglrx(0): shared FSAAScale=1
    (II) fglrx(0): DRI initialization successfull!
    (II) fglrx(0): FBADPhys: 0x60000000 FBMappedSize: 0x005e9000
    (II) fglrx(0): Splitting WC range: base: 0xc0000000, size: 0x5e9000
    (II) fglrx(0): Splitting WC range: base: 0xc0400000, size: 0x1e9000
    (II) fglrx(0): Splitting WC range: base: 0xc0500000, size: 0xe9000
    (II) fglrx(0): Splitting WC range: base: 0xc0580000, size: 0x69000
    (II) fglrx(0): Splitting WC range: base: 0xc05c0000, size: 0x29000
    (II) fglrx(0): Splitting WC range: base: 0xc05e0000, size: 0x9000
    (==) fglrx(0): Write-combining range (0xc05e8000,0x1000)
    (==) fglrx(0): Write-combining range (0xc05e0000,0x9000)
    (==) fglrx(0): Write-combining range (0xc05c0000,0x29000)
    (==) fglrx(0): Write-combining range (0xc0580000,0x69000)
    (==) fglrx(0): Write-combining range (0xc0500000,0xe9000)
    (==) fglrx(0): Write-combining range (0xc0400000,0x1e9000)
    (==) fglrx(0): Write-combining range (0xc0000000,0x5e9000)
    (II) fglrx(0): FBMM initialized for area (0,0)-(1280,1210)
    (II) fglrx(0): FBMM auto alloc for area (0,0)-(1280,800) (front color buffer - assumption)
    (==) fglrx(0): Backing store disabled
    (==) fglrx(0): Silken mouse enabled
    (**) fglrx(0): DPMS enabled
    (WW) fglrx(0): Option "UseFBDev" is not used
    (II) fglrx(0): Using XFree86 Acceleration Architecture (XAA)
            Screen to screen bit blits
            Solid filled rectangles
            8x8 mono pattern filled rectangles
            Solid Lines
            Dashed Lines
            Offscreen Pixmaps
            Setting up tile and stipple cache:
                    30 128x128 slots
    (II) fglrx(0): Acceleration enabled
    (II) fglrx(0): X context handle = 0x1
    (II) fglrx(0): [DRI] installation complete
    To help summarize, I have the disable composite statement in my xorg.conf file. DRI attempts to log, and as you can see, the log stops abruptly right there. The comp hard crashes right there, and I have to comment out the disable composite statements in order to get X to start. Does anyone know what may be causing this and how to fix it?

    I notice I get a warning in there, "(WW) fglrx(0): Option "UseFBDev" is not used". Is this a problem?

  8. #18

    Default

    blario,

    Composite needs to be disabled in order for fglrx to function. What graphics card are you using? if AGP based try adding Option "UseInternalAGPGART" "on" to your xorg.conf, or adjusting other options in there.

  9. #19
    Join Date
    Nov 2006
    Posts
    5

    Default Thank you for any and all replies!

    Quote Originally Posted by Michael View Post
    blario,

    Composite needs to be disabled in order for fglrx to function. What graphics card are you using? if AGP based try adding Option "UseInternalAGPGART" "on" to your xorg.conf, or adjusting other options in there.
    >lspci
    01:05.0 VGA compatible controller: ATI Technologies Inc ATI Radeon XPRESS 200M 5955 (PCIE)

    It's PCIE. Like I said, everytime I uncomment the disable composite lines, and try to start X, the comp hard crashes. I will try the AGP line right now for the hell of it. This is really driving me up a wall cause it seems like no one else has this problem. Here's the important parts of my xorg.conf for the hell of it as well. Thanks very much for the help!

    Code:
    Section "Module"
            Load    "bitmap"
            Load    "ddc"
            Load    "dri"
            Load    "extmod"
            Load    "freetype"
            Load    "glx"
            Load    "int10"
            Load    "type1"
            Load    "vbe"
            Load    "GLcore"
            SubSection "extmod"
                    Option "omit xfree86-dga"
            EndSubSection
    EndSection
    
    .....  InputDevices ........
    
    Section "Device"
            Identifier      "ATI RADEON 200M"
            Driver          "fglrx"
    
            # === Video Overlay for the Xv extension ===
            Option "VideoOverlay" "on"
    
            # === OpenGL Overlay ===
            # Note: When OpenGL Overlay is enabled, Video Overlay
            #       will be disabled automatically
            Option "OpenGLOverlay" "off"
    
            # === Use internal AGP GART support? ===
            # If OpenGL acceleration doesn't work, try using "yes" here
            # and disable the kernel agpgart driver.
            Option "UseInternalAGPGART" "no"
    
            BusID           "PCI:1:5:0"
            Option          "UseFBDev"              "true"
    EndSection
    
    Section "Screen"
            Identifier      "Default Screen"
            Device          "ATI RADEON 200M"
            Monitor         "Generic Monitor"
            DefaultDepth    24
            SubSection "Display"
                    Depth           24
                    Modes           "1280x800" "1024x768" "800x600" "640x480"
            EndSubSection
    EndSection
    
    Section "ServerLayout"
            Identifier      "Default Layout"
            Screen          "Default Screen"
            InputDevice     "Generic Keyboard"
            InputDevice     "Configured Mouse"
            InputDevice     "stylus" "SendCoreEvents"
            InputDevice     "cursor" "SendCoreEvents"
            InputDevice     "eraser" "SendCoreEvents"
            InputDevice     "Synaptics Touchpad"
    EndSection
    
    Section "DRI"
            Mode    0666
    EndSection
    
    #Section "Extensions"
    #Option  "Composite" "false" 
    #EndSection

  10. #20

    Default

    Had you tried removing (or commenting out) some of the options in the xorg.conf so you have a very basic config, and then see if it works? Though the Xpress 200 is very notorious with the ATI drivers, so you may want to check on the BugZilla.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •