Page 4 of 4 FirstFirst ... 234
Results 31 to 33 of 33

Thread: The Open-Source ATI R500 Driver

  1. #31
    Join Date
    Aug 2007

    Default BadAlloc Error

    I'm not sure what's suppose to work right now but on trying to run compiz or beryl, I get the following BadAlloc error:

    atippett@actlap:~$ compiz --replace
    X Error of failed request: BadAlloc (insufficient resources for operation)
    Major opcode of failed request: 143 (GLX)
    Minor opcode of failed request: 3 (X_GLXCreateContext)
    Serial number of failed request: 16
    Current serial number in output stream: 17
    /usr/bin/compiz.real: No GLXFBConfig for default depth, this isn't going to work.
    /usr/bin/compiz.real: Failed to manage screen: 0
    /usr/bin/compiz.real: No manageable screens found on display :0.0

  2. #32
    Join Date
    Sep 2006


    there's no 3d support yet. there's even little 2d acceleration yet.

    don't try anything involving 3d yet.

    well, it might work if you use mesa for 3d, but i can't guarantee it.

  3. #33
    Join Date
    Aug 2007


    Well, I fetched, compiled libpciaccess, avivo...
    It works! Well, sort of. The refresh rate is set by default to 58 Hz no matter what I can think of doing in xorg.conf, and causes a very jittery screen. Using the KDE option panel, changing the refresh rate to 75 Hz fixes the problem. There's also a light blue box right in the middle of the screen; it's 64 pixels by 64 pixels. It's semi-transparent, I can see the stuff behind it, but not very much. I'd say about 70% opaque.
    Oh, and my resolution is 1280x1024.
    Anybody have any idea as to what's causing the blue box? (And the vertical refresh, too )

    EDIT: Switching from 2.6.22-ck1 to 2.6.22-gentoo-r5 (and having tons of troubles with 2.6.22-suspend2-r1 in between ) fixes the blue box. Weird. Still, I need to manually set the refresh rate. Does anybody know how to force this in xorg.conf?
    Last edited by goffrie; 08-24-2007 at 08:48 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts