Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27

Thread: HELP!!! FGLRX causing screen hardlocks

  1. #21
    Join Date
    Jun 2007
    Posts
    69

    Default

    http://ati.cchtml.com/show_bug.cgi?id=567

    I believe that a similar problem has already been filed on ATI bugzilla and is open since long.

  2. #22

    Default

    Wow... The first complaint was at Jan2007. We are now in mid June2007. It is still not fix yet...

    That just shows of how good is ATI supporting Linux...

  3. #23
    Join Date
    Jun 2007
    Posts
    69

    Default

    yaa problems started with the jan release, 8.33.6.. no wonder wen ati linux driver team does a major rewrite they often end up screwing something else.. lets jus hope this gets fixed fast.. else all il be waiting for is r520 3d support in the avivo driver.. neways they wont be so finicky about GLX_EXT_from_pixmap also, so i can rather use aiglx.. which i am sure ati wont get around 2 supporting enough.. ATI sux bigtime for linux support

  4. #24

    Default

    I have been thinking, if you can't get it work using latest driver and you really need to run your system with the latest kernel, why not run it in VESA mode? I know it is sluggish performance, but at least you can get something working.

    Just a thought...

  5. #25
    Join Date
    Sep 2006
    Location
    PL
    Posts
    912

    Default

    I have been thinking, if you can't get it work using latest driver and you really need to run your system with the latest kernel, why not run it in VESA mode?
    well, i run it in text mode most of the time so no problems there

  6. #26
    Join Date
    Jun 2007
    Posts
    69

    Default

    if all i wanted 2 do was run it in vesa then i wudnt hav even started this thread m8

  7. #27
    Join Date
    Jun 2007
    Posts
    69

    Default

    solved i think.. loading xvideo is causing x server to segfault.. bug open since long but not resolved yet..

    Section "Module"
    Load "dbe"
    # Load "extmod"
    SubSection "extmod"
    Option "omit XVideo"
    Option "omit XVideo-MotionCompensation"
    Option "omit XFree86-VidModeExtension"
    EndSubSection
    Load "fbdevhw"
    Load "glx"
    Load "record"
    Load "freetype"
    Load "type1"
    Load "dri"
    EndSection

    Just modify xorg.conf to luk like dis..

    Cheers,

    Karthik

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •