Page 6 of 7 FirstFirst ... 4567 LastLast
Results 51 to 60 of 69

Thread: AMD Zacate E-350

  1. #51
    Join Date
    Mar 2011
    Posts
    10

    Default

    Quote Originally Posted by ariel View Post
    Thanks for the quick reply. It seems that on natty there is a packaging problem/conflict between splitted desktop (and also catalyhacks' ppa) version of libva and xbmc.
    It is described in this post:
    http://ubuntuforums.org/showpost.php...8&postcount=20

    Still trying to figure out how to solve this conflict without having xbmc removed...
    You are right! There're some package conflicts between those PPAs. I'm lost at which version I should use. My current version of xbmc gives core dump when playback any video content. I used this PPA:

    https://launchpad.net/~lars-opdenkamp/+archive/xbmc-pvr

    Catalyst 11.5
    xvba-video_0.7.8-1_amd64.deb
    libva1_0.32.0-1+sds2_amd64.deb
    ubuntu 11.04

  2. #52
    Join Date
    Feb 2011
    Posts
    124

    Default

    I got everything working.

    I used the original xbmc from the ppa 10.1 version. I applied the vaapi surface patch and rebuild as an ubuntu package. Also I fetched the libva stuff from splitted desktop and rebuilt it as a 1.0.9 version in order to succeed the installed natty libva version.
    There still is a packaging problem, because these packages overwrite some stuff of libva-x11 and vainfo.

    Just install libva-x11 and vainfo from natty and force the installation of libva from splitted desktop - not a very nice solution, but I did not have time for splitting packages.

    To complete my setup I use fglrx 11.5 patched to work with kernel 2.6.39 and a 2.6.39 kernel. With natty stock kernel I got strange dmesg errors concerning the IRQ - which could not be fixed by using irqpoll.

    Things not 100% correctly working are:
    - Exit of xbmc, whenever I want to exit xbmc the program crashes and gdm has to be restarted
    - Switching between VC-1 movies and H264 movies randomly, pressing stop here play there and so on can crash xvba fglrx (Could not decode surface, returned 2), fixed only by a reboot


    Is there a patch for the xbmc-exit problem? I could integrate this.


    Just thinking where to put these packages in order to get them easily installed, if anyone has webspace with no traffic limit, please contact me.

    Ah and to make it clear:
    I am not a maintainer of anything, just a user who wanted to use xbmc with vaapi, i cannot give support.
    Last edited by fritsch; 06-07-2011 at 02:21 AM.

  3. #53
    Join Date
    Mar 2011
    Posts
    10

    Default It's working now!

    Quote Originally Posted by fritsch View Post
    I got everything working.

    I used the original xbmc from the ppa 10.1 version. I applied the vaapi surface patch and rebuild as an ubuntu package. Also I fetched the libva stuff from splitted desktop and rebuilt it as a 1.0.9 version in order to succeed the installed natty libva version.
    There still is a packaging problem, because these packages overwrite some stuff of libva-x11 and vainfo.

    Just install libva-x11 and vainfo from natty and force the installation of libva from splitted desktop - not a very nice solution, but I did not have time for splitting packages.



    To complete my setup I use fglrx 11.5 patched to work with kernel 2.6.39 and a 2.6.39 kernel. With natty stock kernel I got strange dmesg errors concerning the IRQ - which could not be fixed by using irqpoll.

    Things not 100% correctly working are:
    - Exit of xbmc, whenever I want to exit xbmc the program crashes and gdm has to be restarted
    - Switching between VC-1 movies and H264 movies randomly, pressing stop here play there and so on can crash xvba fglrx (Could not decode surface, returned 2), fixed only by a reboot


    Is there a patch for the xbmc-exit problem? I could integrate this.


    Just thinking where to put these packages in order to get them easily installed, if anyone has webspace with no traffic limit, please contact me.

    Ah and to make it clear:
    I am not a maintainer of anything, just a user who wanted to use xbmc with vaapi, i cannot give support.

    I rollback the system and now it's working with this combination:

    xbmc 10.1 from PPA:

    https://launchpad.net/~lars-opdenkamp/+archive/xbmc-pvr

    Catalyst 11.3
    xvba-video_0.7.8-1_amd64.deb
    libva1_0.32.0-1+sds2_amd64.deb
    ubuntu 11.04

  4. #54
    Join Date
    Oct 2011
    Posts
    4

    Default

    Any news about this? Is kernel 3.* supported? Is there a distro where everything (or almost) works out of the box?

    I'm considering buying a E35M1 Deluxe for a HTPC/NAS build.

    Thank you

  5. #55
    Join Date
    Oct 2009
    Posts
    11

    Default Pop in an Nvidia GT430 and be done with it

    Well, I went through the trouble of testing out the vaapi/fglrx/e-350 route just so I knew whether it was worthwhile or not.
    Since I build all my own packages I was able to get it working about as good as possible on Linux. None of the problems a lot of people here are having. But the bottom line is that even with vaapi/fglrx working as best they can, it still didn't turn out acceptable results for decoding blu-ray rips. I'm talking about 25-30 gig files. Lots of weird artifacting, just not good enough. Pretty much like it couldn't handle the bandwidth required.

    I then popped in a GT-430 and it works as well as my Big Dog (an X6 with a GTX560ti) for decoding blu-ray.

    So I would suggest if you're serious about using an E-350 for video duties, get a GT-430. You can thank me later. An E-350 with a GT-430 can maintain the max FPS setting in AlienArena @1920x1080.

    BTW, the GT-430 adds 5watts to my idle power draw, big whoop.

    Of course I'll be happy to pull the GT-430's out of my systems, if and when the open source drivers can handle accelerated video decoding properly. I'm not holding my breath, but I am crossing my fingers.

  6. #56
    Join Date
    Feb 2011
    Posts
    124

    Default

    A G210 would be enough.
    I bought a crystalhd card in a minipcie pcie adapter. This works fine with xbmc.

    Without saying too much: native xvba support for xbmc is on its way :-)

  7. #57
    Join Date
    Oct 2011
    Posts
    4

    Default

    Really? Get an Nvidia card on a AMD system?

    I wouldn't mind buying a passive G210 though. Is it really enough to handle XBMC and BluRay rips?

    Which one should I choose?
    Asus GeForce PCI-E GT520 Silent 1Gb DDR3 LP
    or
    Asus GeForce PCI-E N210 Silent 1Gb DDR3 LP

    (I need it to be a passive solution)
    Last edited by skit; 10-24-2011 at 04:14 AM.

  8. #58
    Join Date
    Feb 2011
    Posts
    124

    Default

    Yes it is enough: 1080p no Problem, 1080i could be a problem, cause interlacing is done on the cpu i think, so a zacate could be slow.

    If you can wait, I think in approx 2 month native xvba (amd uvd stuff) is supported at least for x264 and vc1 in xbmc, if and only if nothing comes in between.

  9. #59
    Join Date
    Oct 2011
    Posts
    4

    Default

    Thank you.
    I ordered the Asus GeForce PCI-E N210 Silent 1Gb DDR3 LP for now.
    I have an Atom desktop which could use it later on if the supports for XBMC/Hardware acceleration does appear for Zacate.

    But isn't the GT520 a better GPU? Probably higher power consumption but ...

  10. #60
    Join Date
    Feb 2011
    Posts
    124

    Default

    You asked, if a g210 can play 1080p bluray rips.
    I responded with: Yes it can, cause i have one here.

    The G520 can also do this. The power consumption is comparable, sometimes even lower.

    Found only a german site for this:
    http://ht4u.net/reviews/2011/zotac_g...st/index12.php

    In deed after looking more at the details, i would get a gt520, cause even advanced filtering stuff should be possible cause of more shaders.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •