Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Turning green... FC6 + Ati Drivers 8.28.8...

  1. #1
    Join Date
    Nov 2006
    Posts
    8

    Post Turning green... FC6 + Ati Drivers 8.28.8...

    Hi, good folks over here at the phoronix forums...

    I am slowly turning green over here trying to setup/install these darn Ati 8.28.8 drivers onto FC6.
    I have the same problem as jeffk here (at phoronix) except with an Ati 9100 IGP, still all the same, I have to use the 8.28.8 drivers.

    Well, the "story" goes like this, so far...

    1.) If I try to install the drivers just plain and simple by running as root
    Code:
    [root@studio ~]# sh ./ati-driver-installer-8.28.8.run
    the graphic install starts and next, next, next and then progres bars and all looking good and it completes without
    visible errors in the console or anywhere and I go on into xorg.conf and change the device
    driver from "radeon" to "fglrx" and try to start X back up, it won't start up and Xorg.0.log gives me...

    Code:
    (II) LoadModule: "dri"
    (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
    (II) Module dri: vendor="X.Org Foundation"
            compiled for 7.1.1, module version = 1.0.0
            ABI class: X.Org Server Extension, version 0.3
    (II) Loading sub module "drm"
    (II) LoadModule: "drm"
    (II) Loading /usr/lib/xorg/modules/linux/libdrm.so
    (II) Module drm: vendor="X.Org Foundation"
            compiled for 7.1.1, module version = 1.0.0
            ABI class: X.Org Server Extension, version 0.3
    (II) Loading extension XFree86-DRI
    (II) LoadModule: "glx"
    (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
    (II) Module glx: vendor="X.Org Foundation"
            compiled for 7.1.1, module version = 1.0.0
            ABI class: X.Org Server Extension, version 0.3
    (==) AIGLX enabled
    (II) Loading extension GLX
    (II) LoadModule: "fglrx"
    (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
    dlopen: libstdc++.so.5: cannot open shared object file: No such file or directory
    (EE) Failed to load /usr/lib/xorg/modules/drivers/fglrx_drv.so
    (II) UnloadModule: "fglrx"
    (EE) Failed to load module "fglrx" (loader failed, 7)
    2.) Then I tryed to use the --buildpkg=Fedora/FC6 parameter but with no luck.. it first gave me error very much similar to this...
    Code:
    ATI module generator V 2.0
    ==========================
    initializing...
    cat: /lib/modules/2.6.18-1.2798.fc6/build/include/linux/version-*.h: No such file or directory
    Error:
    kernel includes at /lib/modules/2.6.18-1.2798.fc6/build/include do not match current kernel.
    they are versioned as ""
    instead of "2.6.18-1.2798.fc6".
    you might need to adjust your symlinks:
    - /usr/include
    - /usr/src/linux
    and then, I think only after installing qt-devel, qt4 and qt4-devel, it now works for a while and then just gives me...

    Code:
    ==================================================
     ATI Technologies Linux Driver Installer/Packager
    ==================================================
    Generating package: Fedora/FC6
    Package build failed!
    Package build utility output:
    Building target platforms: i386
    Building for target i386
    Executing(%prep): /bin/sh -e /tmp/ATI-fglrx-8.28.8-1-7375-root/tmp/rpm-tmp.53669
    + umask 022
    + cd /tmp/ATI-fglrx-8.28.8-1-7375-root/BUILD
    + LANG=C
    + export LANG
    + unset DISPLAY
    + cd /tmp/ATI-fglrx-8.28.8-1-7375-root/BUILD
    + cd ATI-fglrx-8.28.8
    ++ /usr/bin/id -u
    + '[' 0 = 0 ']'
    + /bin/chown -Rhf root .
    ++ /usr/bin/id -u
    + '[' 0 = 0 ']'
    + /bin/chgrp -Rhf root .
    + /bin/chmod -Rf a+rX,u+w,g-w,o-w .
    + exit 0
    Executing(%build): /bin/sh -e /tmp/ATI-fglrx-8.28.8-1-7375-root/tmp/rpm-tmp.53669
    + umask 022
    + cd /tmp/ATI-fglrx-8.28.8-1-7375-root/BUILD
    + cd ATI-fglrx-8.28.8
    + LANG=C
    + export LANG
    + unset DISPLAY
    + exit 0
    Executing(%install): /bin/sh -e /tmp/ATI-fglrx-8.28.8-1-7375-root/tmp/rpm-tmp.53669
    + umask 022
    + cd /tmp/ATI-fglrx-8.28.8-1-7375-root/BUILD
    + cd ATI-fglrx-8.28.8
    + LANG=C
    + export LANG
    + unset DISPLAY
    + rm -rf /tmp/ATI-fglrx-8.28.8-1-7375-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root
    + '[' -d /etc/ld.so.conf.d ']'
    + mkdir -p /tmp/ATI-fglrx-8.28.8-1-7375-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root/etc/ld.so.conf.d
    + pushd /tmp/ATI-fglrx-8.28.8-1-7375-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root/etc/ld.so.conf.d
    /tmp/ATI-fglrx-8.28.8-1-7375-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root/etc/ld.so.conf.d /tmp/ATI-fglrx-8.28.8-1-7375-root/BUILD/ATI-fglrx-8.28.8
    + cat
    + popd
    /tmp/ATI-fglrx-8.28.8-1-7375-root/BUILD/ATI-fglrx-8.28.8
    + mkdir -p /tmp/ATI-fglrx-8.28.8-1-7375-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root/usr/share/applications
    + pushd /tmp/ATI-fglrx-8.28.8-1-7375-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root/usr/share/applications
    /tmp/ATI-fglrx-8.28.8-1-7375-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root/usr/share/applications /tmp/ATI-fglrx-8.28.8-1-7375-root/BUILD/ATI-fglrx-8.28.8
    + cat
    + popd
    /tmp/ATI-fglrx-8.28.8-1-7375-root/BUILD/ATI-fglrx-8.28.8
    + cp -pR /tmp/ATI-fglrx-8.28.8-1-7375-root/BUILD/ATI-fglrx-8.28.8/etc /tmp/ATI-fglrx-8.28.8-1-7375-root/BUILD/ATI-fglrx-8.28.8/lib /tmp/ATI-fglrx-8.28.8-1-7375-root/BUILD/ATI-fglrx-8.28.8/usr /tmp/ATI-fglrx-8.28.8-1-7375-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root
    + find /tmp/ATI-fglrx-8.28.8-1-7375-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root/usr/share/doc -type f -perm 0555 -exec chmod 0644 '{}' ';'
    + find /tmp/ATI-fglrx-8.28.8-1-7375-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root -type f -perm 0555 -exec chmod 0755 '{}' ';'
    + export AS_USER=y
    + AS_USER=y
    + pushd /tmp/ATI-fglrx-8.28.8-1-7375-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root/lib/modules/fglrx/build_mod
    /tmp/ATI-fglrx-8.28.8-1-7375-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root/lib/modules/fglrx/build_mod /tmp/ATI-fglrx-8.28.8-1-7375-root/BUILD/ATI-fglrx-8.28.8
    + bash make.sh verbose
    ATI module generator V 2.0
    ==========================
    initializing...
    cat: /lib/modules/2.6.18-1.2798.fc6/build/include/linux/version-*.h: No such file or directory
    Error:
    kernel includes at /lib/modules/2.6.18-1.2798.fc6/build/include do not match current kernel.
    they are versioned as ""
    instead of "2.6.18-1.2798.fc6".
    you might need to adjust your symlinks:
    - /usr/include
    - /usr/src/linux
    error: Bad exit status from /tmp/ATI-fglrx-8.28.8-1-7375-root/tmp/rpm-tmp.53669 (%install)
    
    
    RPM build errors:
        Bad exit status from /tmp/ATI-fglrx-8.28.8-1-7375-root/tmp/rpm-tmp.53669 (%install)
    Removing temporary directory: fglrx-install

    3.) Then I came across an answare (from Michael)to a post here on phoronix, by jeffk, the one I linked to earlyer in this post and followed the instructions given there, extract the ati-installer and download some "firegl_public" code (firegl_public-fc6-legacy.tar) and replaced the code in /fglrx-install/common/lib/modules/fglrx/build_mod/ with the one in the .tar file and then I am suposed to run the installer again with the --buildpkg parameter ...but how do I do that?

    I have tried both...

    Code:
    In /fglrx-install/ sh ./make_install.sh
    with this output
    Code:
    *** WARNING ***
    Tailored kernel module for fglrx not present in your system.
    You must go to /lib/modules/fglrx/build_mod subdir
    and execute './make.sh' to build a fully customed kernel module.
    Afterwards go to /lib/modules/fglrx and run './make_install.sh'
    in order to install the module into your kernel's module repository.
    (see readme.txt for more details.)
    
    As of now you can still run your XServer in 2D, but hardware accelerated
    OpenGL will not work and 2D graphics will lack performance.
    
    failed.
    and
    Code:
    In /fglrx-install/common/lib/modules/fglrx/build_mod/  sh ./make.sh
    output:
    Code:
    ATI module generator V 2.0
    ==========================
    initializing...
    cat: /lib/modules/2.6.18-1.2798.fc6/build/include/linux/version-*.h: No such file or directory
    Error: could not resolve matching ip-library.
    This is a bit large post, hope you get through it and manage to understand the sitsuation.

    At this point I have been at this, on and off, for three days and I don't realy know what I am doing anymore *laugh* and would very, very much appreciate any help.

    Thanks in advance...

    phyx!
    *the troubled one*

    Last edited by phyx; 11-04-2006 at 10:19 PM.

  2. #2

    Default

    phyx,

    Have you tried using the open-source Radeon drivers instead of the fglrx drivers? Since you are using an R200 component.

    Also, don't use the graphical installer for the drivers on Fedora... launch the terminal and change to the appropriate directory and then do ./ati-driver-name.run --buildpkg Fedora/FC6 and that will generate some RPMs to use.

    I can throw together a script to automate the Fedora 6 installation process for 8.28.8 drivers so you can use R200 components. I won't have time tonight, but check back tomorrow and I can probably post such a script to make your fglrx life easier.

    If you have any other questions just post.

  3. #3
    Join Date
    Nov 2006
    Posts
    8

    Post Tip of the iceberg?

    Well first of all, thanks for your very quick response Michael

    hmm.. no offence but I'm getting the feeling you didn't quite read through my first post, cause i think that would
    have answared one of your questions but well, well.. nm, here is a brand new, updated answer
    Quote Originally Posted by Michael View Post
    ...change to the appropriate directory and then do ./ati-driver-name.run --buildpkg Fedora/FC6 and that will generate some RPMs to use.
    If I run the it with --buildpkg Fedora/FC6 it returns...

    Code:
    [root@fedora ~]# ./ati-driver-installer-8.28.8.run --buildpkg Fedora/FC6
    Creating directory fglrx-install
    Verifying archive integrity... All good.
    Uncompressing ATI Proprietary Linux Driver-8.28.8.....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
    ==================================================
     ATI Technologies Linux Driver Installer/Packager
    ==================================================
    Generating package: Fedora/FC6
    Package build failed!
    Package build utility output:
    Building target platforms: i386
    Building for target i386
    Executing(%prep): /bin/sh -e /tmp/ATI-fglrx-8.28.8-1-28992-root/tmp/rpm-tmp.45100
    + umask 022
    + cd /tmp/ATI-fglrx-8.28.8-1-28992-root/BUILD
    + LANG=C
    + export LANG
    + unset DISPLAY
    + cd /tmp/ATI-fglrx-8.28.8-1-28992-root/BUILD
    + cd ATI-fglrx-8.28.8
    ++ /usr/bin/id -u
    + '[' 0 = 0 ']'
    + /bin/chown -Rhf root .
    ++ /usr/bin/id -u
    + '[' 0 = 0 ']'
    + /bin/chgrp -Rhf root .
    + /bin/chmod -Rf a+rX,u+w,g-w,o-w .
    + exit 0
    Executing(%build): /bin/sh -e /tmp/ATI-fglrx-8.28.8-1-28992-root/tmp/rpm-tmp.45100
    + umask 022
    + cd /tmp/ATI-fglrx-8.28.8-1-28992-root/BUILD
    + cd ATI-fglrx-8.28.8
    + LANG=C
    + export LANG
    + unset DISPLAY
    + exit 0
    Executing(%install): /bin/sh -e /tmp/ATI-fglrx-8.28.8-1-28992-root/tmp/rpm-tmp.45100
    + umask 022
    + cd /tmp/ATI-fglrx-8.28.8-1-28992-root/BUILD
    + cd ATI-fglrx-8.28.8
    + LANG=C
    + export LANG
    + unset DISPLAY
    + rm -rf /tmp/ATI-fglrx-8.28.8-1-28992-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root
    + '[' -d /etc/ld.so.conf.d ']'
    + mkdir -p /tmp/ATI-fglrx-8.28.8-1-28992-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root/etc/ld.so.conf.d
    + pushd /tmp/ATI-fglrx-8.28.8-1-28992-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root/etc/ld.so.conf.d
    /tmp/ATI-fglrx-8.28.8-1-28992-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root/etc/ld.so.conf.d /tmp/ATI-fglrx-8.28.8-1-28992-root/BUILD/ATI-fglrx-8.28.8
    + cat
    + popd
    /tmp/ATI-fglrx-8.28.8-1-28992-root/BUILD/ATI-fglrx-8.28.8
    + mkdir -p /tmp/ATI-fglrx-8.28.8-1-28992-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root/usr/share/applications
    + pushd /tmp/ATI-fglrx-8.28.8-1-28992-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root/usr/share/applications
    /tmp/ATI-fglrx-8.28.8-1-28992-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root/usr/share/applications /tmp/ATI-fglrx-8.28.8-1-28992-root/BUILD/ATI-fglrx-8.28.8
    + cat
    + popd
    /tmp/ATI-fglrx-8.28.8-1-28992-root/BUILD/ATI-fglrx-8.28.8
    + cp -pR /tmp/ATI-fglrx-8.28.8-1-28992-root/BUILD/ATI-fglrx-8.28.8/etc /tmp/ATI-fglrx-8.28.8-1-28992-root/BUILD/ATI-fglrx-8.28.8/lib /tmp/ATI-fglrx-8.28.8-1-28992-root/BUILD/ATI-fglrx-8.28.8/usr /tmp/ATI-fglrx-8.28.8-1-28992-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root
    + find /tmp/ATI-fglrx-8.28.8-1-28992-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root/usr/share/doc -type f -perm 0555 -exec chmod 0644 '{}' ';'
    + find /tmp/ATI-fglrx-8.28.8-1-28992-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root -type f -perm 0555 -exec chmod 0755 '{}' ';'
    + export AS_USER=y
    + AS_USER=y
    + pushd /tmp/ATI-fglrx-8.28.8-1-28992-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root/lib/modules/fglrx/build_mod
    /tmp/ATI-fglrx-8.28.8-1-28992-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root/lib/modules/fglrx/build_mod /tmp/ATI-fglrx-8.28.8-1-28992-root/BUILD/ATI-fglrx-8.28.8
    + bash make.sh verbose
    ATI module generator V 2.0
    ==========================
    initializing...
    cat: /lib/modules/2.6.18-1.2798.fc6/build/include/linux/version-*.h: No such file or directory
    Error:
    kernel includes at /lib/modules/2.6.18-1.2798.fc6/build/include do not match current kernel.
    they are versioned as ""
    instead of "2.6.18-1.2798.fc6".
    you might need to adjust your symlinks:
    - /usr/include
    - /usr/src/linux
    error: Bad exit status from /tmp/ATI-fglrx-8.28.8-1-28992-root/tmp/rpm-tmp.45100 (%install)
    
    
    RPM build errors:
        Bad exit status from /tmp/ATI-fglrx-8.28.8-1-28992-root/tmp/rpm-tmp.45100 (%install)
    Removing temporary directory: fglrx-install
    [root@fedora ~]#
    wich is pretty much the same as I described in the first post

    I can throw together a script to automate the Fedora 6 installation process for 8.28.8 drivers so you can use R200 components. I won't have time tonight, but check back tomorrow and I can probably post such a script to make your fglrx life easier.
    I think that might be what needs to be done. Though I'am only guessing... but just cause this is just some minor compatability issue between the 'old' 8.28.8 ati driver and the new FC6 and there shouldn't be to much hazzle to fix theese few 'missing links' there...

    And also, I'am not the only one having this particular problem, hence jeffk here on the phoronix ATi forum and then other posts I've seen around the 'net' and none of them has a solution or has just been solved by going out and buying a cheep nVidia card.. (wich btw, I am three steps away from doing myself right now, lol )

    And a wild guess.. but I might think 'we' are only the begining, cause when FC4 FC5 users with theese particular "no longer suported by ATi" cards start upgrading to the spunky new fc6 they start running into exaclty the same, when they want to get direct rendering and more, enabled on their previously (FC1,2,3,4,5) very direct render enabled video cards...

    but thanks again, I hope to get an update from ya' tomorrow

    -phyx.


  4. #4

    Default

    Sure.

    Was just trying to be clear about your part of:

    the graphic install starts and next, next, next and then progres [COLOR=#009900 ! important][COLOR=#009900 ! important]bars[/COLOR][/COLOR] and all looking good and it completes without visible errors in the console or anywhere and I go on into xorg.conf and change the device driver from "radeon" to "fglrx" and try to start X back up, it won't start up and Xorg.0.log gives me...
    I'll start working on a patch now, and hopefully will be done shortly today.

  5. #5

  6. #6
    Join Date
    Nov 2006
    Posts
    8

    Default One step forward, two steps backwards... :)

    well that was awesom, thanks alot.

    I'am now able to build the RPMS but then I run into some dependencies issues when trying to install them, the kernel-module installs smoothly but the other three, the ATi driver, devel and the Ctrl. Panel have dependencies issues and just outputs...

    Code:
    [root@studio new]# rpm -ihv ATI-fglrx-8.28.8-1.fc6.i386.rpm
    error: Failed dependencies:
            libstdc++.so.5 is needed by ATI-fglrx-8.28.8-1.fc6.i386
            libstdc++.so.5(CXXABI_1.2) is needed by ATI-fglrx-8.28.8-1.fc6.i386
            libstdc++.so.5(GLIBCPP_3.2) is needed by ATI-fglrx-8.28.8-1.fc6.i386
    wich, by my best knowledge I already have installed, hence...

    Code:
    [root@studio ~]# yum list libstdc++
    Loading "installonlyn" plugin
    Setting up repositories
    Reading repository metadata in from local files
    Installed Packages
    libstdc++.i386                           4.1.1-30               installed
    [root@studio ~]#
    Any advice?


  7. #7

    Default

    Easy fix.. this is the RPM you need: http://download.fedora.redhat.com/pu....3-61.i386.rpm

    After that you should be all set

  8. #8
    Join Date
    Nov 2006
    Posts
    8

    Post ...doh!

    "Easy fix"... was almost just a overstatement, lol, worked like a charm but that is not quite the end of it... I'm stll in the dark with direct rendering
    I've seen few posts around about similar problems but none with a fix that I seem to be able to apply to my settings...

    include relevant sections from my Xorg.0.log in same order as they apear in the log.

    Xorg.0.log (Part I) :
    Code:
    [...]
    
    (**) Extension "Composite" is disabled
    
    [...]
    
    (II) LoadModule: "dri"
    (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
    (II) Module dri: vendor="X.Org Foundation"
    	compiled for 7.1.1, module version = 1.0.0
    	ABI class: X.Org Server Extension, version 0.3
    (II) Loading sub module "drm"
    (II) LoadModule: "drm"
    (II) Loading /usr/lib/xorg/modules/linux/libdrm.so
    (II) Module drm: vendor="X.Org Foundation"
    	compiled for 7.1.1, module version = 1.0.0
    	ABI class: X.Org Server Extension, version 0.3
    (II) Loading extension XFree86-DRI
    (II) LoadModule: "glx"
    (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
    (II) Module glx: vendor="X.Org Foundation"
    	compiled for 7.1.1, module version = 1.0.0
    	ABI class: X.Org Server Extension, version 0.3
    (==) AIGLX enabled
    (II) Loading extension GLX
    (II) LoadModule: "fglrx"
    (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
    (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
    	compiled for 7.1.0, module version = 8.28.8
    	Module class: X.Org Video Driver
    	ABI class: X.Org Video Driver, version 1.0
    
    [...]
    
    (II) Primary Device is: PCI 01:05:0
    (II) ATI Proprietary Linux Driver Version Identifier:8.28.8
    (II) ATI Proprietary Linux Driver Release Identifier: LGDr8.28g1                           
    (II) ATI Proprietary Linux Driver Build Date: Aug 17 2006 09:28:12
    (II) ATI Proprietary Linux Driver Build Information: autobuild-rel-r6-8.28.1.1.2.3-driver-lnx-x86-x86_64-287161
    (--) Assigning device section with no busID to primary device
    (--) Chipset RADEON 9000/9100 IGP Series (RS300 5834) found
    
    [...]
    
    (II) Loading sub module "drm"
    (II) LoadModule: "drm"
    (II) Reloading /usr/lib/xorg/modules/linux/libdrm.so
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 7, (OK)
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 7, (OK)
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 7, (OK)
    drmGetBusid returned ''
    (II) Loading sub module "fglrxdrm"
    (II) LoadModule: "fglrxdrm"
    (II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
    (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
    	compiled for 7.1.0, module version = 8.28.8
    	ABI class: X.Org Server Extension, version 0.3
    (--) fglrx(0): VideoRAM: 65536 kByte, Type: DDR SGRAM / SDRAM
    (II) fglrx(0): AGP card detected
    (WW) fglrx(0): board is an unknown third party board, chipset is supported
    
    [...]

  9. #9

    Default

    In your log I am not seeing any errors (EE). What is the problem you are specifically asking on?

  10. #10
    Join Date
    Nov 2006
    Posts
    8

    Post ...doh! (part II)

    Xorg.0.log (Part II) :
    Code:
    [...]
    
    (==) fglrx(0): NoAccel = NO
    
    [...]
    
    (==) fglrx(0): HPV inactive
    (==) fglrx(0): FSAA enabled: NO
    (==) fglrx(0): FSAA Gamma enabled
    (==) fglrx(0): FSAA Multisample Position is fix
    (==) fglrx(0): NoDRI = NO
    (II) Loading sub module "fglrxdrm"
    (II) LoadModule: "fglrxdrm"
    (II) Reloading /usr/lib/xorg/modules/linux/libfglrxdrm.so
    (II) fglrx(0): Depth moves disabled by default
    (==) fglrx(0): Capabilities: 0x00000000
    (==) fglrx(0): CapabilitiesEx: 0x00000000
    (==) fglrx(0): cpuFlags: 0x8000001d
    (==) fglrx(0): cpuSpeedMHz: 0x00000ae9
    (WW) fglrx(0): DRI is not supported on Radeon 9000/9100 IGP (RS300/RS350) hardware.
    (==) fglrx(0): OpenGL ClientDriverName: "on_igp9x00_we_do_not_support_dri.so"
    (**) fglrx(0): using built in AGPGART module: no
    (==) fglrx(0): UseFastTLS=0
    (==) fglrx(0): BlockSignalsOnLock=1
    (==) fglrx(0): EnablePrivateBackZ = NO
    (--) Depth 24 pixmap format is 32 bpp
    (II) do I need RAC?  No, I don't.
    
    [...]
    
    (II) fglrx(0): driver needs X.org 7.1.x.y with x.y >= 0.0
    (II) fglrx(0): detected X.org 7.1.1.0
    (II) Loading extension ATIFGLRXDRI
    (II) fglrx(0): doing DRIScreenInit
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 7, (OK)
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 7, (OK)
    drmOpenByBusid: Searching for BusID PCI:1:5:0
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 7, (OK)
    drmOpenByBusid: drmOpenMinor returns 7
    drmOpenByBusid: drmGetBusid reports 
    drmOpenDevice: node name is /dev/dri/card1
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card2
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card3
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card4
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card5
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card6
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card7
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card8
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card9
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card10
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card11
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card12
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card13
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card14
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -19
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 7, (OK)
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 7, (OK)
    drmGetBusid returned ''
    (II) fglrx(0): [drm] DRM interface version 1.0
    (II) fglrx(0): [drm] created "fglrx" driver at busid "PCI:1:5:0"
    (II) fglrx(0): [drm] added 8192 byte SAREA at 0x8000
    (II) fglrx(0): [drm] mapped SAREA 0x8000 to 0xb7ee6000
    (II) fglrx(0): [drm] framebuffer handle = 0x9000
    (II) fglrx(0): [drm] added 1 reserved context for kernel
    (II) fglrx(0): DRIScreenInit done
    (II) fglrx(0): Kernel Module Version Information:
    (II) fglrx(0):     Name: fglrx
    (II) fglrx(0):     Version: 8.28.8
    (II) fglrx(0):     Date: Aug 17 2006
    (II) fglrx(0):     Desc: ATI FireGL DRM kernel module
    (II) fglrx(0): Kernel Module version matches driver.
    (II) fglrx(0): Kernel Module Build Time Information:
    (II) fglrx(0):     Build-Kernel UTS_RELEASE:        2.6.18-1.2798.fc6
    (II) fglrx(0):     Build-Kernel MODVERSIONS:        yes
    (II) fglrx(0):     Build-Kernel __SMP__:            yes
    (II) fglrx(0):     Build-Kernel PAGE_SIZE:          0x1000
    (II) fglrx(0): [drm] register handle = 0x0000a000
    (EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENODEV"
    (EE) fglrx(0): cannot init AGP
    (II) fglrx(0): [drm] removed 1 reserved context for kernel
    (II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0x8000 at 0xb7ee6000
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed!                  *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO)             *
    (WW) fglrx(0): * no 3D acceleration available                *
    (WW) fglrx(0): ********************************************* *
    (II) fglrx(0): FBADPhys: 0x1c000000 FBMappedSize: 0x04000000
    (==) fglrx(0): Write-combining range (0xe8000000,0x4000000)
    (II) fglrx(0): FBMM initialized for area (0,0)-(1024,8191)
    (II) fglrx(0): FBMM auto alloc for area (0,0)-(1024,768) (front color buffer - assumption)
    (==) fglrx(0): Backing store disabled
    (==) fglrx(0): Silken mouse enabled
    (**) fglrx(0): DPMS enabled
    (II) fglrx(0): Using XFree86 Acceleration Architecture (XAA)
    	Screen to screen bit blits
    	Solid filled rectangles
    	Solid Horizontal and Vertical Lines
    	Offscreen Pixmaps
    	Setting up tile and stipple cache:
    		32 128x128 slots
    		32 256x256 slots
    		16 512x512 slots
    (II) fglrx(0): Acceleration enabled
    (II) fglrx(0): Direct rendering disabled
    (==) fglrx(0): Using hardware cursor
    (II) fglrx(0): Largest offscreen area available: 1024 x 7419
    (II) Loading extension FGLRXEXTENSION
    (II) Loading extension ATITVOUT
    (==) RandR enabled
    (II) Initializing built-in extension MIT-SHM
    (II) Initializing built-in extension XInputExtension
    (II) Initializing built-in extension XTEST
    (II) Initializing built-in extension XKEYBOARD
    (II) Initializing built-in extension XC-APPGROUP
    (II) Initializing built-in extension SECURITY
    (II) Initializing built-in extension XINERAMA
    (II) Initializing built-in extension XFIXES
    (II) Initializing built-in extension XFree86-Bigfont
    (II) Initializing built-in extension RENDER
    (II) Initializing built-in extension RANDR
    (II) Initializing built-in extension COMPOSITE
    (II) Initializing built-in extension DAMAGE
    (II) Initializing built-in extension XEVIE
    (EE) AIGLX: Screen 0 is not DRI capable
    (II) Loading local sub module "GLcore"
    (II) LoadModule: "GLcore"
    (II) Loading /usr/lib/xorg/modules/extensions/libGLcore.so
    (II) Module GLcore: vendor="X.Org Foundation"
    	compiled for 7.1.1, module version = 1.0.0
    	ABI class: X.Org Server Extension, version 0.3
    (II) GLX: Initialized MESA-PROXY GL provider for screen 0
    
    [...]
    the [...] mostly just represent some recource listings and such...

    Hope some one out there has been in my sitsuation and got it to work.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •