Results 1 to 4 of 4

Thread: FC7 and ATI 8.38.6 ==> not working?

  1. #1
    Join Date
    Mar 2007
    Posts
    4

    Default FC7 and ATI 8.38.6 ==> not working?

    Hey,
    I just downloaded the new ati drivers and installed them.
    But each time when I try to start X11 with the drivers it crashes.

    here is the Xorg log http://pastebin.ca/590426

    I took a look again on the fglrx-install.log and besides the "normal" compile warnings, I got a warning in the post-compile step...

    here again the log: http://pastebin.ca/590430
    ( the compiler warnings are in german i'm afraid, but the other warning isn't)

    Someoone able to help?
    Thanks

    daarty

  2. #2

    Default

    Fedora 7 and fglrx isn't working right now unless downgrading the X server.

    See: http://phoronix.com/forums/showthread.php?t=3496

  3. #3
    Join Date
    Mar 2007
    Posts
    4

    Default

    I'm sorry, i thought that this had been fixedi n the newest patch.

  4. #4
    Join Date
    Jun 2007
    Posts
    22

    Default Debian's problem appears to be the same as Fedora7

    See unofficial bugzilla bug: 684

    Particularly the last attached Xorg log: Here

    Comparing the backtrace at the bottom of both (also taking into account that your backtrace is from 8.38.6 and the one on that bug is with 8.37.6):

    Quote Originally Posted by Yours
    Backtrace:
    0: /usr/bin/Xorg(xf86SigHandler+0x81) [0x80c2d21]
    1: [0xc2d420]
    2: /usr/lib/xorg/modules/drivers//fglrx_drv.so(atiddxMiscReadPCIConfig+0x16b) [0xfd1f4b]
    3: /usr/lib/xorg/modules/drivers//fglrx_drv.so(swlCailCbGetPciBusData+0x4c) [0xff962c]
    4: /usr/lib/xorg/modules/drivers//fglrx_drv.so(Cail_MCILReadPciCfg+0x199) [0x10235f9]
    5: /usr/lib/xorg/modules/drivers//fglrx_drv.so(CailIsPCIExpressBoard+0x44) [0x1003aa4]
    6: /usr/lib/xorg/modules/drivers//fglrx_drv.so(Cail_PreInit_AsicCaps+0x75) [0x1003d95]
    7: /usr/lib/xorg/modules/drivers//fglrx_drv.so(CAILEarlyASICInit+0x1c2) [0x1001442]
    8: /usr/lib/xorg/modules/drivers//fglrx_drv.so(swlCailLinuxInit+0x205) [0xff7645]
    9: /usr/lib/xorg/modules/drivers//fglrx_drv.so [0xfcb720]
    10: /usr/lib/xorg/modules/drivers//fglrx_drv.so(atiddxPreInit+0x72b) [0xfc642b]
    11: /usr/bin/Xorg(InitOutput+0x9a8) [0x80a35f8]
    12: /usr/bin/Xorg(main+0x27b) [0x807151b]
    13: /lib/libc.so.6(__libc_start_main+0xe0) [0x224f70]
    14: /usr/bin/Xorg(FontFileCompleteXLFD+0x1e9) [0x8070a21]
    Quote Originally Posted by His
    Backtrace:
    0: /usr/bin/X11/X(xf86SigHandler+0x81) [0x80c8591]
    1: [0xffffe420]
    2: /usr/lib/xorg/modules/drivers//fglrx_drv.so [0xb79c4b53]
    3: /usr/lib/xorg/modules/drivers//fglrx_drv.so [0xb79c01a1]
    4: /usr/lib/xorg/modules/drivers//fglrx_drv.so(atiddxPreInit+0x988) [0xb79baa48]
    5: /usr/bin/X11/X(InitOutput+0x9a4) [0x80a82f4]
    6: /usr/bin/X11/X(main+0x27b) [0x8076c6b]
    7: /lib/i686/cmov/libc.so.6(__libc_start_main+0xdc) [0xb7da7ebc]
    8: /usr/bin/X11/X(FontFileCompleteXLFD+0x1e5) [0x80761a1]
    They are similar enough that I'd be willing to bet it's the same bug. So as bad as it is, Fedora is not alone.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •