For a while I have too much GPU resets (~30 times for a day).
Using HD6850 on Vanilla 2.6.38-rc6 @ openSUSE 11.3 x86_64

Code:
radeon 0000:01:00.0: GPU lockup CP stall for more than 10000msec
------------[ cut here ]------------
WARNING: at drivers/gpu/drm/radeon/radeon_fence.c:248 radeon_fence_wait+0x229/0x2c8 [radeon]()
Hardware name: TA790GX A2+
GPU lockup (waiting for 0x0002396B last fence id 0x0002395D)
Modules linked in: usb_storage fuse snd_pcm_oss snd_mixer_oss snd_seq snd_seq_device edd ipv6 cpufreq_userspace cpufreq_powersave powernow_k8 mperf ext3 jbd dm_crypt loop dm_mod tuner tea5767 tda8290 tda18271 tda827x tuner_xc2028 xc5000 tda9887 tuner_simple tuner_types mt20xx tea5761 tvaudio tda7432 msp3400 bttv v4l2_common videodev pl2303 ir_lirc_codec ftdi_sio kvm_amd lirc_dev usbserial joydev v4l2_compat_ioctl32 kvm videobuf_dma_sg ir_sony_decoder ir_jvc_decoder ir_rc6_decoder ir_rc5_decoder videobuf_core ir_nec_decoder btcx_risc rc_core tveeprom sg k10temp i2c_piix4 thermal button processor radeon rtc_cmos rtc_core usbhid hid ohci_hcd ehci_hcd usbcore ttm rtc_lib sd_mod drm_kms_helper
Pid: 4358, comm: cairo-dock Not tainted 2.6.38-rc6-triQuad #1
Call Trace:
 [<ffffffff8103cc00>] ? warn_slowpath_common+0x80/0x98
 [<ffffffff8103ccac>] ? warn_slowpath_fmt+0x41/0x43
 [<ffffffffa02247e8>] ? radeon_fence_wait+0x229/0x2c8 [radeon]
 [<ffffffff810532a3>] ? autoremove_wake_function+0x0/0x34
 [<ffffffff81036148>] ? get_parent_ip+0x11/0x42
 [<ffffffffa0224f58>] ? radeon_sync_obj_wait+0xc/0xe [radeon]
 [<ffffffffa0039860>] ? ttm_bo_wait+0xa7/0x167 [ttm]
 [<ffffffffa003c1a0>] ? ttm_bo_move_accel_cleanup+0x94/0x270 [ttm]
 [<ffffffffa0225083>] ? radeon_move_blit+0x11e/0x13c [radeon]
 [<ffffffffa0225279>] ? radeon_move_ram_vram+0xc1/0xee [radeon]
 [<ffffffffa003a278>] ? ttm_bo_list_ref_sub+0x23/0x25 [ttm]
 [<ffffffffa003e776>] ? ttm_eu_list_ref_sub+0x24/0x3e [ttm]
 [<ffffffffa022538d>] ? radeon_bo_move+0xe7/0x12b [radeon]
 [<ffffffffa003aa73>] ? ttm_bo_handle_move_mem+0x1a5/0x286 [ttm]
 [<ffffffff81036100>] ? thread_group_times+0x5d/0x94
 [<ffffffffa003b7f6>] ? ttm_bo_move_buffer+0xe9/0x121 [ttm]
 [<ffffffffa003a278>] ? ttm_bo_list_ref_sub+0x23/0x25 [ttm]
 [<ffffffffa003e776>] ? ttm_eu_list_ref_sub+0x24/0x3e [ttm]
 [<ffffffffa003b8e0>] ? ttm_bo_validate+0xb2/0xef [ttm]
 [<ffffffffa022627e>] ? radeon_bo_list_validate+0x86/0xd7 [radeon]
 [<ffffffffa0239898>] ? radeon_cs_parser_relocs+0x1a0/0x1fd [radeon]
 [<ffffffffa0239cc5>] ? radeon_cs_ioctl+0xb2/0x1a1 [radeon]
 [<ffffffff8127e78c>] ? drm_ioctl+0x281/0x343
 [<ffffffffa0239c13>] ? radeon_cs_ioctl+0x0/0x1a1 [radeon]
 [<ffffffff813d9005>] ? do_page_fault+0x418/0x457
 [<ffffffff810e7667>] ? do_vfs_ioctl+0x450/0x491
 [<ffffffff810e76f9>] ? sys_ioctl+0x51/0x74
 [<ffffffff8100293b>] ? system_call_fastpath+0x16/0x1b
---[ end trace f8c4abbdffee18e9 ]---
radeon 0000:01:00.0: GPU softreset 
radeon 0000:01:00.0:   GRBM_STATUS=0xF5703828
radeon 0000:01:00.0:   GRBM_STATUS_SE0=0xFC000007
radeon 0000:01:00.0:   GRBM_STATUS_SE1=0xFC000007
radeon 0000:01:00.0:   SRBM_STATUS=0x20000AC0
radeon 0000:01:00.0:   GRBM_SOFT_RESET=0x00007F6B
radeon 0000:01:00.0:   GRBM_STATUS=0x00003828
radeon 0000:01:00.0:   GRBM_STATUS_SE0=0x00000007
radeon 0000:01:00.0:   GRBM_STATUS_SE1=0x00000007
radeon 0000:01:00.0:   SRBM_STATUS=0x200000C0
radeon 0000:01:00.0: GPU reset succeed
radeon 0000:01:00.0: WB enabled
[drm] ring test succeeded in 2 usecs
[drm] ib test succeeded in 3 usecs
Also I needed to make
Code:
sudo su
echo low > /sys/class/drm/card0/device/power_profile
On every start of computer, otherwise I have unbearable fan noise and wasted electricity.
Also "auto > power_profile" or "dynpm > power_method" settings doesn't help.

Those are the most important issues on NI for me.
Thinking on reinstall fgrlx instead of radeon.