Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: FC6 + fglrx 8.30.3-1 + composite disabled = blank screen (Radeon 9500)

  1. #11

    Default

    Does your xorg.conf reveal anything of interest (errors)?

    What graphics card are you using?

  2. #12
    Join Date
    Nov 2006
    Location
    Finland
    Posts
    10

    Default

    Quote Originally Posted by Michael View Post
    Does your xorg.conf reveal anything of interest (errors)?

    What graphics card are you using?
    I'm using a Radeon 9500 Pro.

    I take it you mean Xorg.0.log But no, no errors or even notable warnings there (just that there's no mouse specified etc). The last three lines logged are

    (II) fglrx(0): Acceleration enabled
    (II) fglrx(0): X context handle = 0x1
    (II) fglrx(0): [DRI] installation complete

    and then X hangs and I have to reboot.

    Interestingly enough, when I tried to revert back to the radeon driver (after first building the ATI driver myself, then trying livna.org's version) it didn't work either - it, too, caused X to crash, with

    (**) RADEON(0): MC_FB_LOCATION : 0xc7ffc000
    (**) RADEON(0): MC_AGP_LOCATION : 0xffffffc0
    (**) RADEON(0): Map Changed ! Applying ...

    and then nothing.


    I'm puzzled. I guess either my card is fried (which seems unlikely) or I'm getting an ATI bug here (and my radeon driver is gone?)

    Does ATI's driver, if installed via RPMs built as instructed on Phoronix, overwrite the Xorg/Mesa libGL? Any idea?


    Orioner

  3. #13

    Default

    It sounds like it may be one of the common fglrx driver bugs.

    Have you tried rebuilding the radeon driver? (or reinstalling the RPM?)

  4. #14
    Join Date
    Nov 2006
    Location
    Finland
    Posts
    10

    Default

    Quote Originally Posted by Michael View Post
    It sounds like it may be one of the common fglrx driver bugs.

    Have you tried rebuilding the radeon driver? (or reinstalling the RPM?)
    So it does. I wish they'd fix it

    I tried reinstalling mesa-libGL (+devel), mesa-libGLU (+devel) and xorg-x11-drv-ati but it didn't help. Frankly, I have no idea what to do next.

    This does, however, look too complicated to be good:

    [root@orion 2.6.18-1.2849.fc6]# ls -l /usr/lib/libGL*
    lrwxrwxrwx 1 root root 10 Nov 27 01:35 /usr/lib/libGL.so -> libGL.so.1
    lrwxrwxrwx 1 root root 12 Nov 27 01:35 /usr/lib/libGL.so.1 -> libGL.so.1.2
    -rwxr-xr-x 1 root root 432272 Oct 31 22:07 /usr/lib/libGL.so.1.2
    lrwxrwxrwx 1 root root 11 Nov 27 01:35 /usr/lib/libGLU.so -> libGLU.so.1
    lrwxrwxrwx 1 root root 20 Nov 27 01:35 /usr/lib/libGLU.so.1 -> libGLU.so.1.3.060501
    -rwxr-xr-x 1 root root 524004 Oct 31 22:07 /usr/lib/libGLU.so.1.3.060501

    I don't even want to think what might be wrong here


    Orioner

  5. #15
    Join Date
    Nov 2006
    Location
    Finland
    Posts
    10

    Talking

    Hell, I'll probably never be able to go back to the open source radeon driver, but I'm happy to report that I've solved this problem (the "how exactly" part is a bit unclear, though).


    Software:
    Fedora Core 6, kernel 2.6.18-1.2849.fc6
    ATI fglrx driver 8.31.05 from livna.org

    Hardware:
    ATI Radeon 9500 PRO

    Results:
    [ataimist@orion ~]$ glxinfo | grep direct
    direct rendering: Yes

    [ataimist@orion ~]$ fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: RADEON 9500 Pro Generic
    OpenGL version string: 2.0.6174 (8.31.5)

    [ataimist@orion ~]$ glxgears
    3105 frames in 5.0 seconds = 620.771 FPS
    3512 frames in 5.0 seconds = 702.311 FPS
    5243 frames in 5.0 seconds = 1048.467 FPS

    [ataimist@orion ~]$ fgl_glxgears
    Using GLX_SGIX_pbuffer
    1844 frames in 5.0 seconds = 368.800 FPS
    2355 frames in 5.0 seconds = 471.000 FPS
    2282 frames in 5.0 seconds = 456.400 FPS


    What I did (what exactly did the trick is unknown, though):

    BIOS:
    changed AGP Aperture Size from 128M to 256M

    xorg.conf:
    added into "Monitor" (these are monitor-specific values)
    Option "HSync2" "30-86"
    Option "VRefresh2" "48-150"
    added into "Device"
    Option "VideoOverlay" "off"
    Option "OpenGLOverlay" "on"
    Option "UseInternalAGPGART" "yes"
    added section
    Section "DRI"
    Mode 0666
    EndSection
    added section
    Section "ServerFlags"
    Option "AIGLX" "off"
    EndSection
    This made Xorg start properly for me, but it still gave me Mesa for OpenGL. A little bit of investigation gave this error:
    libGL: XF86DRIGetClientDriverName: 8.31.5 fglrx (screen 0)
    libGL: OpenDriver: trying /usr/lib/dri/fglrx_dri.so
    libGL error: dlopen /usr/lib/dri/fglrx_dri.so failed (/usr/lib/dri/fglrx_dri.so: undefined symbol: __glXFindDRIScreen)
    libGL error: unable to load driver: fglrx_dri.so
    Which was fixed with a bunch of symbolic links (the /usr/lib/libGL.so.1.2 was the Mesa libGL when it should have been the fglrx one from /usr/lib/ati-fglrx/):
    ln -s /usr/lib/dri/fglrx_dri.so /usr/lib/xorg/modules/dri/fglrx_dri.so
    ln -s /usr/lib/ati-fglrx/libGL.so.1.2 /usr/lib/fglrx/libGL.so.1
    ln -s /usr/lib/ati-fglrx/libGL.so.1.2 /usr/lib/libGL.so.1.2
    The first of which I'm not at all certain is needed. Also remember to back up Mesa's libGL.so.1.2 from /usr/lib/, you might need it later.

    Now fglrx works like a charm (and I'll start wondering which of those options I can now remove).


    Thanks for the help, guys!


    Orioner

  6. #16
    Join Date
    Nov 2006
    Location
    Finland
    Posts
    10

    Lightbulb

    Well, what did the trick was either the
    Option "HSync2" "30-86"
    Option "VRefresh2" "48-150"
    part in xorg.conf or AGP Aperture Size in BIOS, and I'd wager it was xorg.conf since I seem to remember changing aperture size before with no effect.

    Removing the UseInternalAGPART part from the conf also (obviously) yields slightly better performance:

    [root@orion ~]# glxgears
    5144 frames in 5.0 seconds = 1028.707 FPS
    4928 frames in 5.0 seconds = 985.535 FPS
    6151 frames in 5.0 seconds = 1230.120 FPS

    [root@orion ~]# fgl_glxgears
    Using GLX_SGIX_pbuffer
    2299 frames in 5.0 seconds = 459.800 FPS
    2579 frames in 5.0 seconds = 515.800 FPS
    2607 frames in 5.0 seconds = 521.400 FPS

    There are still a few problems with MPlayer (no XShape extension and OpenGL behaves a bit strange) but otherwise everything seems to be working OK (at least much better than it was).


    Orioner

  7. #17
    Join Date
    Nov 2006
    Location
    Finland
    Posts
    10

    Smile

    Quote Originally Posted by Orioner View Post
    There are still a few problems with MPlayer (no XShape extension and OpenGL behaves a bit strange) but otherwise everything seems to be working OK (at least much better than it was).
    ...and adding
    Load "extmod"
    to xorg.conf Module section and restarting X fixed those too.

    Now everything works!


    Orioner

  8. #18
    Join Date
    Mar 2007
    Posts
    48

    Default

    Hate to bump an old thread, but do you mind posting your entire xorg.conf?
    I hit the same thing, even though everything was working a few days ago.

  9. #19
    Join Date
    Nov 2006
    Location
    Finland
    Posts
    10

    Red face Uhh. Sorry, no can do.

    Quote Originally Posted by SheeEttin View Post
    Hate to bump an old thread, but do you mind posting your entire xorg.conf?
    I hit the same thing, even though everything was working a few days ago.
    Uh, I would, but I no longer use this configuration, because it only worked for a while for me as well (it stopped working with the next driver update). So I no longer have that configuration file

    Anyhow, I think it was the Phoronix recommended xorg.conf with the modifications I mentioned. There really was nothing fancy in the configuration file. Something just suddenly made it work, and just as suddenly it stopped working.


    Orioner

  10. #20
    Join Date
    Mar 2007
    Posts
    48

    Default

    Thanks anyway--I think I've got it figured out, thanks to you!

    Now I just hope it'll continue working after I boot into the SMP kernel...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •