Results 1 to 7 of 7

Thread: Radeon 9800 PRO, FC6, no transparency(not translucency) at all

  1. #1
    Join Date
    Nov 2006
    Posts
    10

    Default Radeon 9800 PRO, FC6, no transparency(not translucency) at all

    I've been searching google and this forum for some time and wasn't able to find anything on this, if there is a thread already, sorry.

    So I have a Radeon 9800 PRO 128MB, and running FC6. I used the open-source drivers for some time, but I want to switch to the proprietary, I've used them in FC5 and had no problem whatsoever (except the lack of the "Composite" extension, but I don't care that much for eye-candy anyway).

    The thing is that since I've installed them (first 8.29 and now 8.30), I have no transparency (rounded corners for windows have a black background, bubble-like popups and tooltips are rectangular, the bouncing icon cursor has a square black background etc.). If I switch to radeon it works just fine, but I don't get high enough frame-rates in OpenGL apps.

    I get the problem in both KDE&gnome.

    Here is a collection of screenies showing the issue:
    http://amenzix.bro.ro/files/phroronix.html

  2. #2

    Default

    The issues you mentioned are largely problems with fglrx. No known workaround at this time. Sorry the information couldn't be positive, but welcome to the forums.

  3. #3
    Join Date
    Nov 2006
    Posts
    10

    Default

    First, great response time . Well, the weird part is that it worked in FC5. Am I to understand that it's a compatibility issue with Xorg 7.1?

    Thanks!

  4. #4

    Default

    I haven't asked ATI/AMD about this issue directly, but yes, I think it's with Xorg 7.1 (If I recall, I also ran into this issue with Ubuntu Edgy Eft).

  5. #5
    Join Date
    Nov 2006
    Posts
    7

    Default

    Hello!
    I had the same problem after I install the fglrx drivers in FC6. The solution is quite simple, but I found it by chance.

    Add the following in the section "Module" in xorg.conf:

    Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "dri"
    Load "glx"
    EndSection


    after that, you will recover your transparency in the bouncing icons, windows and everything.

  6. #6

    Default

    delaossa,

    Good find! I didn't notice that before. I can confirm it's working here for fglrx on FC6 with transparency.

  7. #7
    Join Date
    Nov 2006
    Posts
    10

    Default

    hey guys, i managed to solve it without doing that. all i had to do was reinstall the drivers, and it works. but it's good to know anyway.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •