Hi,
I've got a 9700pro and I'm running FC6. I've got the 8.30.3 driver installed and fireglcontrolpanel works fine. The only outstanding issue I have is that I can't get direct rendering to work.

>glxinfo|grep direct
direct rendering: No
OpenGL renderer string: Mesa GLX Indirect

After searching through forums, I've triple-checked my xorg.conf file and am still getting these errors in log/Xorg.0.log:

>cat /var/log/Xorg.0.log |grep EE
Code:
       (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENODEV"
(EE) fglrx(0): cannot init AGP
(EE) AIGLX: Screen 0 is not DRI capable
>cat /var/log/Xorg.0.log |grep WW
Code:
       (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) The core pointer device wasn't specified explicitly in the layout.
(WW) fglrx: No matching Device section for instance (BusID PCI:3:0:1) found
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed!                  *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO)             *
(WW) fglrx(0): * no 3D acceleration available                *
(WW) fglrx(0): ********************************************* *
(WW) fglrx(0): Option "XAANoOffscreenPixmaps" is not used
(WW) fglrx(0): Option "VendorName" is not used
(WW) fglrx(0): Option "ModelName" is not used
(WW) <default pointer>: No Device specified, looking for one...
Here's the pertinent parts of xorg.conf:
Code:
Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "aticonfig-Screen[0]" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
EndSection

Section "Module"
        Load  "dri"
        Load  "glx"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]"
        Driver      "fglrx"
        Option      "DesktopSetup" "single"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]"
        Device     "aticonfig-Device[0]"
        Monitor    "aticonfig-Monitor[0]"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

Section "Extensions"
        Option      "Composite" "Disable"
EndSection

Any help?