Hi,
I am new user of Fedora Core 6 and I encountered some problems with ATi Radeon X1300 driver installation. When I installed FC6, my video card was detected correctly. But I can not activate 3D effect. So I followed the Blog "ATI Fedora Core 6 How-To" to install the driver.

After I installed libstdc++.so.5 and qt-devel, ATI-fglrx-8.29.6-1.fc6.i386.rpm, ATI-fglrx-control-panel-8.29.6-1.fc6.i386.rpm, ATI-fglrx-devel-8.29.6-1.fc6.i386.rpm, and kernel-module-ATI-fglrx-KERNEL-VERSION.fc6-8.29.6-1.fc6.i386.rpm can be generated correctly in the working directory. I use the ffollowing command to install these RPMS.

rpm -ivh *.rpm

But when used command "rpm -q *.rpm" to query the installation, the console displayed these RPMS were not installed..


And Mesa is always used after I added the following conten in etc/X11/xorg.conf

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "aticonfig-Screen[0]" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dri"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection



Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
EndSection


Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Disable"
EndSection

The following is the information of ATI Control Panel

Display Adapter
Card Name: Radeon X1300 Series(RV515 7164)
Memory Size: 256M
Bios Version: Unkown
Display Driver
Driver Version 8.29.06
OpenGL:
Vendor: Mesa project www.mesa3d.org
Version: 1.2(Mesa 6.5.1)
Renderer:
Mesa GLX indirect


Thanks for any help!