Page 3 of 10 FirstFirst 12345 ... LastLast
Results 21 to 30 of 93

Thread: ATI fglrx 8.31.5 Display Drivers

  1. #21

    Default

    Quote Originally Posted by afterburntdw View Post
    I only got it because the ASUS P5W DH has Crossfire support. But getting that to work in Linux....I don't think I even want to try.
    The fglrx drivers do not support CrossFire nor will they anytime in the near future.

  2. #22
    Join Date
    Oct 2006
    Posts
    37

    Default

    Thank you for that information. It helps me to make my decision about video cards.

    Just out of curiosity, where do you find the detailed information about the changes in each driver release?

  3. #23
    Join Date
    Nov 2006
    Posts
    7

    Default Problems with ATI 9600

    I firstly installed the drivers from livna through yum with no problems, it was not untill i ran ATI Control that i realized i was still using MESA, i googled my problem and came across your instructions. I followeed them to the letter but no matter what i did it always failed. THe most recent problem was the firecontrol. odly enough without knowing what exactly it was i did that fixed it that is know gone and the ATI control panel works fine detecting my ATI Radeon 9600 without problems but the Vendor for the driver is still Mesa 1.2(1.5 Mesa 6.5.1)

    fglrxinfo give me the following

    Xlib: extension "XFree86-DRI" missing on display ":0.0".
    display: :0.0 screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (1.5 Mesa 6.5.1)

    My Xorg reads as follows

    # Xorg configuration created by system-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Synaptics" "CorePointer"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Synaptics"
    Driver "synaptics"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "auto-dev"
    Option "Emulate3Buttons" "yes"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    ModelName "LCD Panel 1600x1200"
    ### Comment all HorizSync and VertSync values to use DDC:
    HorizSync 31.5 - 90.0
    VertRefresh 59.9 - 60.1
    Option "dpms"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "fglrx"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1400x1050" "1280x1024" "1280x960" "1280x800" "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    EndSection

    Section "Extensions"
    Option "Composite" "Disable"
    EndSection

    Is there a way of completely uninstalling the fglrx drivers from yum and also the onse i installed from your instructions under the hope that a fresh start might work better? Or a way to remove mesa or at least pass over control to ATI instead of MESA?

    I've already looked through the various posts and have found none of the sollutions to suit me.

    Any ideas would be much apreciated.

    philip@gmail.com

  4. #24

    Default

    yum remove <package names> is able to uninstall the RPMs for you. After that try to run the installer manually.

    Does your X log show any relevant information to this problem?

  5. #25
    Join Date
    Nov 2006
    Posts
    7

    Default

    (II) LoadModule: "GLcore"
    (II) Loading /usr/lib/xorg/modules/extensions/libGLcore.so
    (II) Module GLcore: vendor="X.Org Foundation"
    compiled for 7.1.1, module version = 1.0.0
    ABI class: X.Org Server Extension, version 0.3
    (II) GLX: Initialized MESA-PROXY GL provider for screen 0

  6. #26
    Join Date
    Nov 2006
    Posts
    7

    Default

    (II) fglrx(0): driver needs X.org 7.1.x.y with x.y >= 0.0
    (II) fglrx(0): detected X.org 7.1.1.0
    (II) Loading extension ATIFGLRXDRI
    (II) fglrx(0): doing DRIScreenInit
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 7, (OK)
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 7, (OK)
    drmOpenByBusid: Searching for BusID PCI:1:0:0
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 7, (OK)
    drmOpenByBusid: drmOpenMinor returns 7
    drmOpenByBusid: drmGetBusid reports
    drmOpenDevice: node name is /dev/dri/card1
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: open result is -1, (No such device)
    drmOpenDevice: Open failed

  7. #27
    Join Date
    Nov 2006
    Posts
    7

    Default

    hope these help...

  8. #28

    Default

    Were there any errors? (EE)

  9. #29
    Join Date
    Nov 2006
    Posts
    7

    Default

    (EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/fglrx_dri.so: undefined symbol: __driCreateNewScreen_20050727)
    (EE) AIGLX: reverting to software rendering

    also

    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

  10. #30
    Join Date
    Nov 2006
    Posts
    102

    Default

    Quote Originally Posted by presdec View Post
    (EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/fglrx_dri.so: undefined symbol: __driCreateNewScreen_20050727)
    (EE) AIGLX: reverting to software rendering

    also

    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    Add the following in /etc/X11/xorg.conf:

    Code:
    Section "ServerFlags"
    	Option	    "AIGLX" "off"
    EndSection

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •