Results 1 to 5 of 5

Thread: Problems with ATI 8.28.8 driver.

  1. #1
    Join Date
    Nov 2006
    Posts
    8

    Default Problems with ATI 8.28.8 driver.

    I have a ATI 9200 graphics card RV280. I am trying to install to proprietary driver to have Compiz/Beryl to work.
    I have downloaded ati-driver-installer-8.28.8.run; been doing bash ./ati-driver-installer-8.28.8.run --buildpkg Debian/sid. Then i have
    Package /home/helge/ati/fglrx-driver_8.28.8-1_i386.deb has been successfully generated
    Package /home/helge/ati/fglrx-driver-dev_8.28.8-1_i386.deb has been successfully generated
    Package /home/helge/ati/fglrx-kernel-src_8.28.8-1_i386.deb has been successfully generated
    Package /home/helge/ati/fglrx-control_8.28.8-1_i386.deb has been successfully generated
    Package /home/helge/ati/fglrx-sources_8.28.8-1_i386.deb has been successfully generated
    /home/helge/ati/fglrx-install
    When I do dpkg -i fglrx-driver_8.28.8-1_i386.deb it gives:
    fglrx-driver demands xserver-xorg (<< 1:7.0.99). But: Version of xserver-xorg on the system is 1:7.1.0-6.
    But according to the ATI web side: This should be an "Automated installer and Display Drivers for XFree86 4.3 and X.Org 6.7, 6.8, 6.9, 7.0, 7.1".
    What can be the reason for this? Is there any method to fix the installer script? Do I have to downgrade to xserver-xorg 6,9??
    By the way: I have installed the fglrx-driver from Ubuntu. This gives:
    fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: Tungsten Graphics, Inc.
    OpenGL renderer string: Mesa DRI R200 20060602 AGP 1x TCL
    OpenGL version string: 1.2 (1.3 Mesa 6.5.1)
    And:
    glxinfo
    name of display: :0.0
    display: :0 screen: 0
    direct rendering: No
    Can I expect the same good result with Beryl and fglrx-drives as with the proprietary ATI driver?

    Helge

  2. #2

    Default

    Are you using Beryl/Compiz with XGL? That is the only way Beryl/Compiz will work with the fglrx drivers is if you are using XGL. The fglrx drivers do not support AIGLX. For desktop effects you're better off with the open-source drivers,

    I am not much of a Debian user myself, but you could modify the packaging scripts so on package installation it won't complain. Or you could try using the Debian Sid 8.31 packaging scripts with 8.28 (after making some file location changes) to see if that would correct your problem. The 8.28 drivers do support X.Org 7.1.

    Or if your status quo of using the open-source drivers is working, you might as well stick with that.

  3. #3
    Join Date
    Nov 2006
    Posts
    8

    Unhappy

    Yes I managed to install and get the fglrx driver to work, I used the Debian dpkg-reconfigure xserver-xorg. And I can use the ATI control panel. I am using gdm, and in my gdm.conf I have:
    [servers]
    0=Xgl
    and it works. But if I add:
    [server-Xgl]
    name=Xgl
    command=/usr/bin/Xgl -fullscreen -ac -accel glxbuffer -accel xvbuffer
    the X-server crashes/never starts.
    And I am not able to use beryl or Compiz. I dont know if this is the forum, but when I try
    beryl --replace decoration wobbly fade minimize cube
    I get:
    XGL Absent, checking for NVIDIA
    Nvidia Absent, assuming AIGLX
    beryl: No composite extension

    I find this strange, since it seems XGL i working:
    helge@helge:/etc/X11$ Xgl
    Fatal server error:
    Server is already active for display 0
    If this server is no longer running, remove /tmp/.X0-lock
    and start again.

    Does anyone her understand what I am not doing the right way? Compiz and beryl are of course installed.

    Helge

  4. #4
    Join Date
    Nov 2006
    Posts
    8

    Default

    Sorry - it should be:
    command=/usr/bin/Xgl -fullscreen -ac -accel glx:buffer -accel xv:buffer

    Helge

  5. #5
    Join Date
    Nov 2006
    Posts
    8

    Default

    By the way: doing top and ps -A both shows Xorg and not Xgl. I guess this tells Xgl is not running. But what next?

    Helge

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •