Results 1 to 10 of 10

Thread: ATI Tv-out

  1. #1
    Join Date
    Nov 2006
    Posts
    72

    Exclamation ATI Tv-out

    Hi,
    I dont know if this is a very common problem or it's just me but i cant seem to get my laptop video card (Mobility Radeon X1400) to recognize my tv. It's attached with an S-Video cable. This is what I've tried so far:
    -configure xorg.conf with aticonfig --initial=dual-head and then modify xorg.conf adding these options to the second monitor:

    Option "NoTV" "no"
    Option "TVStandard" "PAL-B"
    Option "DesktopSetup" "clone mode"
    Option "TVHSizeAdj" "0"
    Option "TVVSizeAdj" "0"
    Option "TVHPosAdj" "0"
    Option "TVVPosAdj" "0"
    Option "TVHStartAdj" "0"
    Option "TVColorAdj" "0"
    Option "GammaCorrectionI" "0x06419064"
    Option "GammaCorrectionII" "0x06419064"
    Option "DesktopSetup" "0x00000100"
    Option "MonitorLayout" "STV"

    -configure xorg.conf normally (aticonfig --initial) and add the above options to the only monitor.

    -then i tried this:
    aticonfig --enable-monitor=tv

    which gave me this error:
    ati_dm: FGLRX_EnableDisplays failed when try to enable display: 4.
    Using xorg.conf
    Saved back-up to xorg.conf.fglrx-6

    I really dont know what i'm doing wrong. I use 8.30.3 drivers and xorg 6.9 on Slackware 11.
    I'm about to install 8.31.5 and see if it helps.
    Can anyone help me please??
    THANKS!!!

  2. #2

    Default

    Did you try going to a very simple single-head xorg.conf and then using the dynamic display management options (aticonfig --enable-monitor)? How did that work?

  3. #3
    Join Date
    Nov 2006
    Posts
    72

    Default

    Thanks! I think I managed to get my tv recognized. I added the option "ForceMonitors" "tv" to my xorg.conf.
    Problems:

    -the extended desktop on the tv is in black and white. (I have PAL-B option). But this happens on windows too, so i think i should change s-video cable.

    -the background of the tv is always grey, no matter what my dekstop is.

    -on the extended desktop (tv) i can only see the mouse cursor and nothing else.

    -If i try dragging a windows on the extended desktop, I can only see the mouse cursor, not the window.

    Any clue on how i could solve this?

  4. #4

    Default

    Have you tried setting up a Big Desktop configuration instead of dual head? Did that work?

  5. #5
    Join Date
    Nov 2006
    Posts
    72

    Default

    Quote Originally Posted by Michael View Post
    Have you tried setting up a Big Desktop configuration instead of dual head? Did that work?
    Uh, big desktop? How do i do that?

  6. #6

    Default

    aticonfig, below is the basic option.

    2. Setting up big desktop to horizontal and set overlay on secondary display.
    aticonfig --dtop=horizontal --overlay-on=1

  7. #7
    Join Date
    Nov 2006
    Posts
    72

    Default

    Quote Originally Posted by Michael View Post
    aticonfig, below is the basic option.
    So, there's nothing to modify in xorg.conf, right?
    I'll try this one as soon as possible. Thanks for the help!!

  8. #8

    Default

    aticonfig Big Desktop will automatically modify your xorg.conf when you have root access.

  9. #9
    Join Date
    Nov 2006
    Posts
    72

    Default

    OK! I'm almost done! It does work, both in clone mode and big desktop. The problem is the resolution in the tv. I use 1280x800 on my laptop.
    The maximum I got on windows is 1024x768, which is not that bad, it just cuts a little bit the sides. How do I set it in xorg.conf?? Or can i try to set it 1280x800??
    Thanks again for your help!!

  10. #10

    Default

    This might be what you're after:

    Pair mode options:
    Following options are used for query add and remove pair modes.
    These options will be effective immediately. Other options on
    the same command line will be ignored.
    --list-pairmode
    list all the current existing pair modes the driver can use.
    --add-pairmode=width0xheight0+width1xheight1
    Add one pair mode to the list. width0 and height0 are the
    size of primary display and width1 and height1 for the
    secondary display.
    --remove-pairmode=index
    Remove one pair mode from the list. User can get index by
    list-pairmode.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •