Results 1 to 3 of 3

Thread: xf86-video-intel 2.15.0 Is About To Come

  1. #1
    Join Date
    Jan 2007
    Posts
    14,914

    Default xf86-video-intel 2.15.0 Is About To Come

    Phoronix: xf86-video-intel 2.15.0 Is About To Come

    Chris Wilson has just tagged the second release candidate of xf86-video-intel 2.15.0...

    http://www.phoronix.com/vr.php?view=OTI2NQ

  2. #2
    Join Date
    Apr 2007
    Posts
    18

    Default compile error

    Hi!

    While compiling the driver I'm constantly hitting this error:

    Code:
    make[3]: Entering directory `/Linux/kms/xf86-video-intel/src'
      CC     intel_module.lo
    In file included from intel_module.c:36:
    intel.h:481: error: expected specifier-qualifier-list before ‘DRI2SwapEventPtr’
    make[3]: *** [intel_module.lo] Error 1
    make[3]: Leaving directory `/Linux/kms/xf86-video-intel/src'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/Linux/kms/xf86-video-intel/src'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/Linux/kms/xf86-video-intel'
    make: *** [all] Error 2
    I have updated all main components from git (mesa, drm, dri2proto, glproto, macros, libva) and cannot find anything remotely usable when searching google for DRI2SwapEventPtr or at least I cannot connect it with anything usable. What am I missing?

    I'm on Debian stable btw.

  3. #3
    Join Date
    Apr 2007
    Posts
    18

    Default

    Ha ha, this one made me laugh:

    commit: 630d77bf10ba6234bb9c04538636f7d8aa319aea

    Add a DRI2SwapEventPtr typedef for retro xserversmaster
    Because people are still trying to build upon our solid historical foundations.
    Thanks Chris! I will move to a newer xserver eventually.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •