Results 1 to 2 of 2

Thread: nvidia and xrandr modes

Hybrid View

  1. #1
    Join Date
    Nov 2009
    Posts
    106

    Default nvidia and xrandr modes

    I have an issue where xrandr displays a lot of supported modes for my monitor... But most of the modes don't work with my monitor at all. The problem seems related to the proprietary nvidia driver incorrectly reporting what modes my monitor supports. I've tried explicitly defining modes in my xorg.conf before with no luck.

    Anyone have any idea how to fix this? It's an issue when I start to start a game and it switches my monitor to an unsupported mode. It's VERY annoying.

    I'm using the nvidia 270.29 driver.

  2. #2
    Join Date
    Nov 2009
    Posts
    106

    Default Not one response? I'm disappointed.

    I figured it out... Sort of. I'm not 100% sure, but I think this option in the screen section of my xorg.conf did it (or at least it was definitely PART of the fix):

    Option "ModeValidation" "NoVesaModes,NoXServerModes,NoPredefinedModes"

    In any case, things definitely work now and here's the entire screen section in case the ModeValidation option by itself isn't the entire fix:

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "ModeValidation" "NoVesaModes,NoXServerModes,NoPredefinedModes"
    Option "ExactModeTimingsDVI" "True"
    Option "TwinViewOrientation" "Clone"
    Option "UseEdid" "True"
    Option "TwinView" "1"
    Option "metamodes" "DFP-0: 1920x1080_60 +0+0, DFP-2: 1920x1080_60 +0+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •