Page 1 of 10 123 ... LastLast
Results 1 to 10 of 91

Thread: AMD 8.39.4 Driver Released -- 8.35 no longer does it better

  1. #1

    Default AMD 8.39.4 Driver Released -- 8.35 no longer does it better

    The AMD 8.39 driver is now out w/ Fedora 7 support! Other than that, there isn't anything too exciting, but check out the Phoronix article for more information:

    Last month was an interesting time for AMD and their ATI Linux display driver. The Radeon HD 2400 and 2600 series were introduced, but as we have unfortunately come to expect, there was not a supported R600 driver that day or even that month. In fact, there still is no Linux driver to support any graphics card in the R600 series. Though making the month unique were two display drivers being released in the same week. The 8.38.6 driver had introduced Red Hat Enterprise Linux 5 support as well as some minor fixes, but nothing to spark interest in the minds of end-users. The second Linux driver released, 8.38.7, had come down the pipeline as a hot-fix release to correct a bug where aticonfig would crash and remove your xorg.conf. Moving forward to the 8.39.4 driver released today, we still have no AIGLX or R600 support, but we do have Fedora 7 support!
    http://www.phoronix.com/vr.php?view=10569


    Release Notes: https://a248.e.akamai.net/f/674/9206...ux_8.39.4.html


    ( This driver has been dubbed the "8.35 no longer does it better" edition as it corrects TexturedVideo with glesx.so. You can guess the unofficial name for the fglrx 8.40 driver next month in this thread http://www.phoronix.com/forums/showthread.php?t=3511 )

  2. #2
    Join Date
    Nov 2006
    Posts
    13

    Default

    Quote Originally Posted by Michael View Post
    The AMD 8.39 driver is now out w/ Fedora 7 support! Other than that, there isn't anything too exciting, but check out the Phoronix article for more information:



    http://www.phoronix.com/vr.php?view=10569


    Release Notes: https://a248.e.akamai.net/f/674/9206...ux_8.39.4.html


    ( This driver has been dubbed the "8.35 no longer does it better" edition as it corrects TexturedVideo with glesx.so. You can guess the unofficial name for the fglrx 8.40 driver next month in this thread http://www.phoronix.com/forums/showthread.php?t=3511 )
    Where to download this driver??It seems the driver hasn't been released yet.I can't find it in the driver page.

  3. #3
    Join Date
    Jul 2007
    Posts
    1

    Default

    Another masterpiece from AMD, at least now they admit it is for testing only.
    This driver comes with a nice logo that overlays all windows on my system.
    AMD- Testing use only.

    I guess they uploaded the beta version.

    Any ideas how to get rid of that logo, besides downloading the driver again in a couple of days.

  4. #4

    Default

    Quote Originally Posted by swannema View Post
    Another masterpiece from AMD, at least now they admit it is for testing only.
    This driver comes with a nice logo that overlays all windows on my system.
    AMD- Testing use only.

    I guess they uploaded the beta version.

    Any ideas how to get rid of that logo, besides downloading the driver again in a couple of days.
    They accidentally uploaded the build with the watermark then... I am sure they will correct it shortly. It can't be disabled too easily.

  5. #5
    Join Date
    Sep 2006
    Location
    PL
    Posts
    910

    Default

    Any ideas how to get rid of that logo, besides downloading the driver again in a couple of days.
    it goes away when you identify displays via amdcccle. but only for a couple of seconds.

    argh.

    what about those xbm override files in /etc ? i'm actually considering hex-editor rampage on the driver files :]

    so far 8.35 STILL does it better :]

    Video Tearing may be seen during playback in XV using GLESX. Further details can be found in topic number 737-26984
    *sigh*

    i really feel like installing xorg-server-1.2 now :]
    Last edited by yoshi314; 07-19-2007 at 03:13 PM.

  6. #6
    Join Date
    Nov 2006
    Posts
    13

    Default

    I updated xorg to 1.3 and installed 8.39.4 driver on my Fedora 7,however,the Xorg doesn't work.when the Xorg starts,my screen just turned to be black.I checked out the Xorg.log.0,there isn't any error in that log..

    I don't know what happened ...It seems that the fglrx driver is working ,but Xorg can't start up....

  7. #7

    Default

    Quote Originally Posted by yoshi314 View Post
    it goes away when you identify displays via amdcccle. but only for a couple of seconds.

    argh.

    what about those xbm override files in /etc ? i'm actually considering hex-editor rampage on the driver files :]
    Others and I have tried several things to kill the "Testing use only" logo... Replacing logos, etc and so far it has been to no avail. (Been thinking about it on and off for several weeks now).

    There are these strings in the driver:

    atiddxLogoInit
    atiddxPositionLogo
    atiddxEnableLogo
    atiddxLoadLogo
    atiddxDisableLogo
    But trying to use the DisableLogo option in the X configuration hadn't worked. There may be a hot fix release to correct this.

  8. #8
    Join Date
    Jul 2007
    Posts
    444

    Default There's a BUG in this kernel module.

    My dmesg log is slowly filling up with messages like this:

    BUG: sleeping function called from invalid context at include/asm/semaphore.h:99
    in_atomic():1, irqs_disabled():0
    [<f8d01db5>] __ke_down_struct_sem+0x14/0x2b [fglrx]
    [<f8d06b2f>] firegl_remove_all_drawables+0x3f/0x100 [fglrx]
    [<f8d0934f>] firegl_release_helper+0x55f/0x7d0 [fglrx]
    [<f8d0cc9b>] firegl_takedown+0x5b/0xc50 [fglrx]
    [<f8d0c32f>] firegl_release+0x12f/0x190 [fglrx]
    [<f8d008ba>] ip_firegl_release+0xf/0x12 [fglrx]
    [<c015e242>] __fput+0xb5/0x15d
    [<c015be3c>] filp_close+0x51/0x58
    [<c010577f>] do_syscall_trace+0x13d/0x182
    [<c015cd97>] sys_close+0x67/0x9e
    [<c01026da>] syscall_call+0x7/0xb
    [<c0290000>] __xfrm_policy_check+0x187/0x4a3
    =======================

    This isn't a good sign.

    Apart from that, I've had so set UseFastTLS to "2". I've never run fglrx before, so I don't know which are the "good" options to enable.

    And here's another BUG from the kernel log:

    BUG: sleeping function called from invalid context at include/asm/semaphore.h:99
    in_atomic():1, irqs_disabled():0
    [<f8d57db5>] __ke_down_struct_sem+0x14/0x2b [fglrx]
    [<f8d5c424>] drm_getmagic+0x124/0x1c0 [fglrx]
    [<f8d5c300>] drm_getmagic+0x0/0x1c0 [fglrx]
    [<f8d6253e>] firegl_ioctl+0x1ae/0x230 [fglrx]
    [<c015c154>] do_filp_open+0x32/0x39
    [<f8d5688a>] ip_firegl_ioctl+0x0/0x21 [fglrx]
    [<f8d568a6>] ip_firegl_ioctl+0x1c/0x21 [fglrx]
    [<f8d5688a>] ip_firegl_ioctl+0x0/0x21 [fglrx]
    [<c01673e3>] do_ioctl+0x87/0x9f
    [<c013c50d>] audit_syscall_entry+0x10d/0x137
    [<c0167632>] vfs_ioctl+0x237/0x249
    [<c0167677>] sys_ioctl+0x33/0x4c
    [<c01026da>] syscall_call+0x7/0xb
    [<c0290033>] __xfrm_policy_check+0x1ba/0x4a3
    =======================
    Last edited by chrisr; 07-19-2007 at 07:40 PM.

  9. #9
    Join Date
    Jul 2007
    Posts
    2

    Default

    The release notes do not specify Xorg 7.3 ?!~ What gives?

  10. #10
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    2,123

    Default

    Xorg 7.3 = Xorg Server 1.4 not yet released or supported, but Xorg Server 1.3 is supported for some time now.

    This release is not as bad as you could think. Michael, did you test whether there were performance improvements in Doom 3 etc.? I think 8.40 could be VERY interesting...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •