I run debian unstable (x86-64) and have a couple of manually compiled kernels. My question is, can someone explain why 2.6.20-rc1 works with the last couple of versions of ATI drivers, but 2.6.22 (and 21) does not? It crashes on a signal (the stack trace is already in a couple of posts).
Not even this last version (8.39.4) works, even though it claims 2.6.22 support.

The weird thing is, it's not a problem with X, because it works if I run the same system but with 2.6.20-rc1. I've tried the last 3-4 versions of the ATI drivers (fixed the compilation issues for 2.6.21+ kernels, which now seems fixed), and it's the same thing.
I really want 2.6.22 (or at least 21) with KVM, coretemp and a few other things.

And for those of you who can't find the 8.39.4 which the AMD/ATI crap heads silently removed, it's available on:
http://www.computerbase.de/downloads..._linux_driver/
You need to be registered, or use bugmenot. Off course you'll choose the latter.

And btw, does anyone know if the avivo driver has multi-head support yet? I'd happily switch, even if it's slow and bad as hell, with virtually no acceleration, as long as I don't need the crapware AMD/ATI keeps serving me with a smile.

Thanks