Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: FGLRX Problems with ATI Mobile Radeon 1300

  1. #1

    Default FGLRX Problems with ATI Mobile Radeon 1300

    Hello Friends,
    I just installed Fedora Core 6 a few weeks ago. (This is my first install of Linux, so I am a newbie - I appreciate your patience if I say some stupid things). I am finally getting used to getting around in Fedora. But I have a problem, it is similar to threads that I have seen elsewhere, but none of the solutions seemed to apply to me, or I didn't exactly understand what they were talking about.
    Well,
    My problem is this, I have no 3d support as far as I can tell,
    I first tried installed the ATI Proprietary Linux Driver off of the ATI web page, but I was having problems with the fireglxcontrolpanel thing and with it saying it couldn't find that and one other file. So I just went onto yum and installed the KMOD Fglrx kernels off of there and the Xorg Fglrx kernels. They seemed to install fine (I can have my computer at the correct resolution) but I don't seem to have any 3d support.
    if I do a fglrxinfo
    I get

    Xlib: extension "XFree86-DRI" missing on display ":0.0".
    display: :0.0 screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (1.5 Mesa 6.5.1)


    I cannot figure out how to change the OpenGL to change to ATI rather than Mesa. Is there a way that I can fix it, or should I try to reinstall off of the ATI webpage?
    I appreciate any help that you can give me
    Austin

  2. #2

    Default

    Can you post your xorg.conf (found in /etc/X11/) and cat /var/log/Xorg.0.log | grep "EE" That would help in diagnosing the problem.

  3. #3

    Default yeah thanks

    Here is the xorg.conf


    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Synaptics" "CorePointer"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Synaptics"
    Driver "synaptics"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "auto-dev"
    Option "Emulate3Buttons" "yes"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "fglrx"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    39,0-1 Bot


    When I tried to do a ATICONFIG -Initial it gave me this error message

    Warning: Could not find configuration file
    Please copy configuration file template to /etc/X11

    Although xorg.conf was definitely in /etc/X11

  4. #4

    Default

    Quote Originally Posted by cheesewedge85 View Post
    ATICONFIG -Initial
    It should be:

    aticonfig --initial
    If you try the ATI.com drivers again, see here for the fireglcontrolpanel problem.

    Also, what did your Xorg.0.log show?

  5. #5

    Default

    I think that the file is too long to post

  6. #6

    Default

    I still had the same problem with with aticonfig -initial

  7. #7

    Default

    If you do as mentioned in the previous post, it will only display the lines where there are errors (EE means error in the log).

    cat /var/log/Xorg.0.log | grep "EE"

  8. #8

    Default

    ok, I'm sorry

  9. #9

    Default

    Quote Originally Posted by cheesewedge85 View Post
    I still had the same problem with with aticonfig -initial
    Take note that there are two dashes, not just one.

    aticonfig --initial

    [michael@localhost ~]$ aticonfig -initial
    Warning: Could not find configuration file
    Please copy configuration file template to /etc/X11
    [michael@localhost ~]$ aticonfig --initial
    Found fglrx primary device section
    Nothing to do, terminating.

  10. #10

    Default

    k, sorry again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •