This is on a Lenovo Thinkpad W500 with a Hybrid Intel and AMD HD3650. I tried booting various distributions: Fedora 14, Mandriva 2010.2 and 2011 beta1, OpenSuSE 11.4 and none of them work when only the HD3650 is active.

Not working means: Flickering screen where nothing can be seen at all as soon as KMS becomes active. I have read various reports that this card should easily work with KMS on any up to date distribution, but I have had no success whatsoever for the past week. The intel card works fine, but the radeon does not and I am tempted to assume that something is wrong with the hardware.

Without KMS the radeon card works, but 3D performance is abysmal and I am not interested in trying out fglrx at all, I simply want to get the OSS driver to work and maybe even get vga_switcheroo to work.

I believe I tried everything, but nothing really works. Logging in via ssh let's me remove the radeon module, but I am left with a blank console with nothing left to do.

Any of you experts got an idea what to do or should I simply try to return the notebook. I'd rather not do this, since this is a company notebook and I specifically wanted the W500, particularly for it's good success reports on using the OSS driver.