Results 1 to 10 of 10

Thread: ATI X1800 XL on Fedora

  1. #1
    Join Date
    Dec 2006
    Posts
    29

    Default ATI X1800 XL on Fedora

    Okay, now I have stumbled through almost all distros, and I liked SuSE best becaus of XGL and Beryl-support for my graphics card, but I have managed to f''' it up, so I have now returned to my old distro, Fedora Core (last one was FC4). but, I have to ask, and wish, to AIGLX have support for X1800 Series with the proprietary ATi drivers? I wish. If not, where can I find XGL rpm (don't want to compile, I'm a pupil, can't use to much time on my computer ATM)

    Jim Tore, Norway

  2. #2

    Default

    Jim,

    I am sad to report that the ATI proprietary drivers have not adopted AIGLX or GLX_EXT_texutre_from_pixmap support. The open-source Radeon drivers have this support, but they do not support the Radeon X1800XL. For Fedora Core 6 XGL RPMs use: http://fedoraxgl.tuxfamily.org/repos...0-3.noarch.rpm or you can build XGL yourself if you don't want to use an RPM repo.

  3. #3
    Join Date
    Dec 2006
    Posts
    29

    Default

    Quote Originally Posted by Michael View Post
    Jim,

    I am sad to report that the ATI proprietary drivers have not adopted AIGLX or GLX_EXT_texutre_from_pixmap support. The open-source Radeon drivers have this support, but they do not support the Radeon X1800XL. For Fedora Core 6 XGL RPMs use: http://fedoraxgl.tuxfamily.org/repos...0-3.noarch.rpm or you can build XGL yourself if you don't want to use an RPM repo.
    What was the command for adding repos? Used to YaST in SUSE (miss that one)

  4. #4
    Join Date
    Dec 2006
    Posts
    29

    Default

    But, even though, I can remember weakly that the tuxfamily repos for ubuntu (I think) did not work

  5. #5

    Default

    If you simply install the RPM (rpm -ivh) it should install and enable the repo, otherwise edit it in /etc/yum.repos.d/

  6. #6
    Join Date
    Dec 2006
    Posts
    29

    Default

    Know, google it :P But how cna I tell it to download xgl? not in Add and remove ... and what is the rpms called? (Can't wait for ATI to release the next drivers, maybe they spport AIGLX out of the box like NVidia)

  7. #7

    Default

    Quote Originally Posted by krypton View Post
    Know, google it :P But how cna I tell it to download xgl? not in Add and remove ... and what is the rpms called? (Can't wait for ATI to release the next drivers, maybe they spport AIGLX out of the box like NVidia)
    I haven't used that XGL repo myself, so I would suggest looking in its HTTP directory and see the names. I personally build XGL from source on Fedora when needed.

    I will tell you that the next drivers coming out this month do NOT support AIGLX.

  8. #8
    Join Date
    Dec 2006
    Posts
    29

    Default

    DOH! NVidia here i come! At least for my old computer! Does AIGLX support my old but stable and three years old GeForce 3 ti200?

  9. #9
    Join Date
    Dec 2006
    Posts
    29

    Default

    How do I tell Fedora to use XGL? Again, in SuSE it was in YaST (sysconfig file in /etc)

  10. #10

    Default

    The GeForce 3 should still be supported by the mainstream driver branch, so yes, if using a 1.0-9XXX series driver you should be in good shape.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •