Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: ATI 8.31.5 / Fedora FC6 - Kernel-Devel Errors

Hybrid View

  1. #1
    Join Date
    Dec 2006
    Posts
    10

    Default ATI 8.31.5 / Fedora FC6 - Kernel-Devel Errors

    How i got here...

    First off.. hardware

    Code:
     
    MOTHERBOARD
    P4N Diamond
    NVIDIAŽ nForce4 SLI Intel Edition Chipset
    - HyperTransport link to nVidia MCP04 south bridge
    - Supports 2 PCI Express x 16 and 1 PCI Express x 1 interface
    - Supports dual channel, DDR2 533/667
    NVIDIAŽ MCP04 (for nForce4 SLI Intel Edition) Chipset
    - Integrate SATA-II controller, four drives
    - Dual Fast-ATA 133 IDE controller, for four devices
    - IEEE 802.3 nVIDIA MAC for 1000BASE-T
    Creative Sound Blaster Live
    - 24-bit h/w audio controller CA0106
    - PCI 2.3 Spec Compliant
    LAN   
    Supports dual LAN jacks
    - 1st Supports 10/100/1000 Fast Ethernet by Marvell 88E1111 phy 
    - 2nd PCI Express LAN supports 10/100/1000 Fast Ethernet by Marvell 88E8053
    VIDEO CARD
    ATI Radeon x800
    ------------------------------------------

    Now to the process

    Insatalled of USB DVD and a fresh burn of Zod

    After install loged on

    Opened Firefox... downloaded ATI Driver

    Then in terminal did
    yum install kernel-devel
    yum install kernel-headers
    yum install qt-devel
    Then in terminal did
    Code:
     
    cd /root/Desktop
    sh ./ati-driver-installer-8.31.5-x86.x86_64.run --buildpkg Fedora/FC6
    Below is output.

    [root@ss1 Desktop]# sh ./ati-driver-installer-8.31.5-x86.x86_64.run --buildpkg Fedora/FC6
    Creating directory fglrx-install
    Verifying archive integrity... All good.
    Uncompressing ATI Proprietary Linux Driver-8.31.5............................................ .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. ........................................
    ==================================================
    ATI Technologies Linux Driver Installer/Packager
    ==================================================
    Generating package: Fedora/FC6
    Please install an appropriate Linux kernel module build package.
    Probably kernel-devel in this case.
    If you've compiled a custom kernel, make sure /usr/src/linux exists
    and the source tree matches the currently running kernel.
    Removing temporary directory: fglrx-install
    I have ready the Forums over and over and page by page...

    I can't figure out what i been doing wrong.

    I have used Linux Red Hat & RHES for about 7 years now so i know my way around the box but this is really my first time with X ... i have always used SSH / terminal till now.

  2. #2

    Default

    Hmmm... One thought for what the problem is. Had you updated your kernel? You installed kernel-devel and kernel-headers, and so it likely installed the latest kernel version available in the official Core repository, but the kernel itself may still be on the stock version... So basically is your kernel and kernel-devel/kernel-headers the same version? If not, make sure they're all updated on the same version and then give it another try.

  3. #3
    Join Date
    Dec 2006
    Posts
    10

    Default

    Ok.

    Did yum -y update

    Now system info is...

    Current Kernel Version (uname -sr)
    Linux 2.6.8.18-1.2849.fc6
    Current Kernel-Devel Version
    kernel-devel-2.6.8.18-1.2849.fc6
    re-running ati installer and ...

    Same error...

  4. #4
    Join Date
    Dec 2006
    Posts
    10

    Default

    i have nothing on this install...

    I cna re-format box if you think there is a specific sequence of events i should follow to get success on this compile.

  5. #5

    Default

    Hmmm do you have both i686 and x86_64 kernel-devel packages installed?

  6. #6
    Join Date
    Dec 2006
    Posts
    10

    Default

    i have the i686
    not the x86_64

    How would I go about doing that..

    PS i am not on 64 bit processor

  7. #7

    Default

    Oops, I must have looked it over too quick. Sorry about that, since you're running 32-bit Linux you can't install the 64-bit devel package. Is there anything in /lib/modules/2.6.18-1.2849.fc6 ?

  8. #8
    Join Date
    Dec 2006
    Posts
    10

    Default

    Yea... here is the list below.

    /lib/modules/2.6.18-1.2849.fc6/extra
    /lib/modules/2.6.18-1.2849.fc6/kernel
    /lib/modules/2.6.18-1.2849.fc6/updates
    /lib/modules/2.6.18-1.2849.fc6/weak-updates
    /lib/modules/2.6.18-1.2849.fc6/build
    /lib/modules/2.6.18-1.2849.fc6/modules.alias
    /lib/modules/2.6.18-1.2849.fc6/modules.ccwmap
    /lib/modules/2.6.18-1.2849.fc6/modules.dep
    /lib/modules/2.6.18-1.2849.fc6/modules.ieee1394map
    /lib/modules/2.6.18-1.2849.fc6/modules.inputmap
    /lib/modules/2.6.18-1.2849.fc6/modules.isapnpmap
    /lib/modules/2.6.18-1.2849.fc6/modules.ofmap
    /lib/modules/2.6.18-1.2849.fc6/modules.pcimap
    /lib/modules/2.6.18-1.2849.fc6/modules.seriomap
    /lib/modules/2.6.18-1.2849.fc6/modules.symbols
    /lib/modules/2.6.18-1.2849.fc6/modules.usbmap
    /lib/modules/2.6.18-1.2849.fc6/source

  9. #9

    Default

    Hmmm you could try reinstalling and make sure you got all the development tools and libraries. I haven't run into this issue after having all the proper packages installed.

  10. #10
    Join Date
    Dec 2006
    Posts
    10

    Default

    thats what i forgot to mention

    When installed i did default installation and selected "office and productivity"

    I am now installing the development tools

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •