Results 1 to 5 of 5

Thread: PROBLEM: 8.39 with 1440x900LCD

  1. #1
    Join Date
    Jul 2007
    Location
    Canada
    Posts
    4

    Default PROBLEM: 8.39 with 1440x900LCD

    All installed well on my Fedora FC7 system
    X works dandy.
    BUT: No 1440x900 mode, which happens to be my LCDs native resoluition.
    Best I can get is a horizontally stretched 1280x1024
    Tried many things, Modelines, etc but while I can occasionally select 1440x900, it then produces a black screen and the monitor loses synch.
    Generated original config with system-config-display
    ran aticonfig --initial to make it "ATI-style"
    Had to vi the xorg.conf and edit the driver line from "FGLRX" to "radeon" to that the aticonfig had something to do..
    modified the identifiers to the "ati-generated Monitor[0]" style of naming so that aticonfig likes it.
    Tried to adjust res various ways, inc Catalyst control panel, aticonfig --resolution, manually editing xorg.conf, etc.
    No matter what I do, I can get lots of choices for res, but none of those lists include 1440x900
    If I manually edit to include it, then startx, it goes out of monitor sync range.
    Yes, I set the hsync and vsync settings, although system-config-display got pretty close the first time.
    Yes, I ran gtf to get modeline timings and tried a number of those variants.. seemingly ignored.
    Yes, I tried Option DPMS "0" and I tored commenting that line out as well.

    IF I use an nVidia card and ddriver I can make it work if I use the "Ignore EDID" option.

    Anyone have any suggestions, please?

  2. #2
    Join Date
    Jun 2007
    Location
    .ro/.ca
    Posts
    232

    Default

    Read this and this.

    Baseline:
    You need the correct Hync and Vsync in your Monitor Section and the correct Modeline ("Modeline "1440x900" 100.000 1440 1456 1464 1480 900 916 924 940 -hsync -vsync" apparently) in your Modes section.


    Also, you'll have to say what changes you did to you xorg.conf, not just that you tried something (ie post the relevant section)
    Last edited by Xipeos; 08-01-2007 at 06:34 AM.

  3. #3
    Join Date
    Jul 2007
    Location
    Canada
    Posts
    4

    Default

    Quote Originally Posted by Xipeos View Post
    Read this and this.

    Baseline:
    You need the correct Hync and Vsync in your Monitor Section and the correct Modeline ("Modeline "1440x900" 100.000 1440 1456 1464 1480 900 916 924 940 -hsync -vsync" apparently) in your Modes section.


    Also, you'll have to say what changes you did to you xorg.conf, not just that you tried something (ie post the relevant section)
    I generated modelines with gtf and tried them. Several different frequencies ( 55 to 70 in 4 steps) were tried.
    The vsync and hsync values were originally created by system-config-display, but were higher than the manual for the monitor showed, so I manually edited those.

    I have tried just about every option I could think of from reading various docs and forums, and I DO have success in using this with the nVidia binary driver, and the "ignoreEDID" setting.

    The question is WHICH of the xorg.conf files I should post, since there are many, and all work just great, EXCEPT at 1440x900

  4. #4
    Join Date
    May 2007
    Location
    Up North, Where 10 degrees is shorts weather
    Posts
    80

    Default

    This is inherent flaw in 8.39 drivers - use 8.40

  5. #5
    Join Date
    Jul 2007
    Location
    Canada
    Posts
    4

    Default

    Quote Originally Posted by Alistair View Post
    This is inherent flaw in 8.39 drivers - use 8.40
    Some good news and some bad:
    Good news first: 1440x900 is now recognized with 8.40
    Bad news:screen is messed up. In XORG a part from the centre is copied to the lower left, and there are many other assorted artifacts.
    Pretty well unusable.
    Back to VESA driver for now..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •