Results 1 to 6 of 6

Thread: Laggy 2D performance with fglrx

  1. #1
    Join Date
    Jul 2007
    Posts
    16

    Default Laggy 2D performance with fglrx

    Hi all,

    I'm currently running Kubuntu fiesty with fglrx 8.38.7. I noticed that my 2d windows are a little laggy, in that dragging windows leaves a 'ghost', and konqueror / dolphin have a slow refresh rate (I can see 3 refreshes in the span of 2 seconds or so).

    I ran Xgl + beryl a while back and these problems went away. I'm just curious.. is the lag normal for standard Xorg?

    Here is the relevant section from my xorg.conf

    Code:
    Section "Device"
    	Identifier  "Generic Video Card"
    	Driver      "fglrx"
    	Option	    "XaaNoOffscreenPixmaps"
    	Option	    "VideoOverlay" "on"
    	Option	    "OpenGLOverlay" "off"
    	Option	    "DesktopSetup" "horizontal"
    	Option	    "TexturedVideo" "on"
    	Option	    "EnablePrivateBackZ" "yes" #Enable 3d support <= May Not Work
        Option      "UseFastTLS" "0"  #for wine?
        Option      "ForceGenericCPU" "no" 
        Option "mtrr"                       "off" # disable DRI mtrr mapper, driver has its own code for mtrr
    	Option	    "EnableMonitor" "LVDS"
    	Option	    "PairModes" "1920x1200+1280x1024,1680x1050+1920x1200"
    	BusID       "PCI:1:0:0"
    EndSection
    
    Section "Extensions"
    	Option	    "Composite" "0"
    EndSection
    Any help would be appreciated!
    Last edited by mintcoffee; 07-30-2007 at 01:43 PM.

  2. #2
    Join Date
    Sep 2006
    Location
    PL
    Posts
    906

    Default

    maybe disabling composite is different. not by setting it to 0 but to "Disable" or something. don't remember, it was somewhere on forums.

  3. #3
    Join Date
    Jul 2007
    Posts
    16

    Default

    Thanks for the suggestion. I tried that, and it doesn't help. The strange thing is, if I use XGL+Composite Manager, then the 2D refresh is gone. However, using standard X.org, it's present.

    Maybe it's just the fglrx driver.

  4. #4
    Join Date
    Aug 2007
    Posts
    53

    Default

    not maybe, it is fglrx fault

    latest "ok" driver is 8.35.5

    there are howtos on the net how to patch and install this driver for feisty

  5. #5
    Join Date
    Aug 2007
    Posts
    7

    Default

    this might not be the problem, but check if:

    glxinfo | grep "direct"

    gives you a "Yes"

    If not, maybe you need to restore the proper symlinks in /usr/lib(64) for libGL.so

    I didn't have the "ghost effect" you're seeing, but apparently my symlinks would get butchered sometimes (e.g. after hibernating or just restarting), leading to sluggish 2d drawing.

  6. #6
    Join Date
    Apr 2007
    Posts
    99

    Default

    Code:
    Section "Device"
    	Identifier  "Generic Video Card"
    	Driver      "fglrx"
    	Option	    "XAANoOffscreenPixmaps"
    	Option	    "VideoOverlay" "on"
    	Option	    "OpenGLOverlay" "off"
    #	BusID       "PCI:1:0:0" #if you have one card, it will be auto detected
    EndSection
    
    Section "Extensions"
    	Option	    "Composite" "0"
    EndSection
    Use this. You also used the wrong case for XAANoOffscreenPixmaps, the options are case sensitive.

    fglrx actually has no real options to enhance performance.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •