Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 45

Thread: Open-Source ATI Driver Gets TV-Out

  1. #21

    Default still need help

    Thanks for responding so fast.

    Sorry to be so inept at this but can you give me some pointers as how to:
    update to Xserver 1.3 in order to use the driver.
    I looked on synaptic but I couldn't figure out what exactly to get.

    Also when I skip
    "git checkout origin/randr-1.2"
    and type
    "./autogen.sh --prefix=/usr/"
    inside "~/xf86-video-ati$"
    I get

    "Can't exec "aclocal": No such file or directory at /usr/bin/autoreconf2.50 line 182.
    Use of uninitialized value in pattern match (m//) at /usr/bin/autoreconf2.50 line 182.
    Can't exec "automake": No such file or directory at /usr/bin/autoreconf2.50 line 183.
    Use of uninitialized value in pattern match (m//) at /usr/bin/autoreconf2.50 line 183.
    autoreconf2.50: Entering directory `.'
    autoreconf2.50: configure.ac: not using Gettext
    autoreconf2.50: running: aclocal --output=aclocal.m4t
    Can't exec "aclocal": No such file or directory at /usr/share/autoconf/Autom4te/FileUtils.pm line 290.
    autoreconf2.50: failed to run aclocal: No such file or directory"

    Don't really know what means...

  2. #22

    Default

    Quote Originally Posted by captain-murphy View Post
    Can't exec "aclocal": No such file or directory at /usr/share/autoconf/Autom4te/FileUtils.pm line 290.
    You might want to make sure that the following packages are installed:
    * GNU make
    * autoconf 2.58 (or newer)
    * automake 1.8
    * libtool 1.5
    * m4
    You should also check for other versions of automake and install them as well, if supported by Ubuntu. Afterwards, try again.

  3. #23

    Default

    Xserver 1.3 needs to be downloaded from a Gutsy repository or upgrade to a Gutsy testing release.

  4. #24

    Default Sorry for being terrible at this.

    Thanks both of you for helping.
    I got all the packages you recomended and figured out how to get gusty in my respositories and then get x server 1.3, and things got a little bit further...

    however I can't figure out why it doesn't work.
    For example for the first step: after

    "xf86-video-ati: ./autogen.sh --prefix=/usr/"

    The commands:
    "make"
    and
    "make install"
    Don't know what to do so they stop. Thus I don't know if the xf86 video ati is really installed at all.

    I got 'make' and 'make install' to work for xrandr, however when I type the commands

    xrandr --addmode S-video 800x600
    xrandr --output S-video --mode 800x600

    It just accepts them and nothing happens. Nothing is being sent to me tv from my S-video...

  5. #25

    Default

    Did you restart your computer (or X) after the make install of the radeon driver?

  6. #26

    Default

    Yes I turned it off and then started it back up and tried to type the
    "xrandr --addmode S-video 800x600
    xrandr --output S-video --mode 800x600"
    but nothing happened.

    What exactly does "xf86-video-ati" do and how do I know if it's installed/working correctly?

  7. #27

    Default

    Quote Originally Posted by captain-murphy View Post
    What exactly does "xf86-video-ati" do and how do I know if it's installed/working correctly?
    That is the actual driver itself... It sounded like you may have installed it correctly. Can you post your xorg.0.log from /var/log/ ?

  8. #28

    Default

    Yes, it's very long though, so I uploaded it to my old geocities account I had from hs.
    http://www.geocities.com/kofflera/Xorg.0.log
    thats the log.

  9. #29
    Join Date
    Oct 2007
    Posts
    1

    Default

    I seem to be stuck at the same place as captain-murphy

    I have successfully compiled the and installed the xf86-video-ati driver and randr as described in the how-to referred to from the first post of this thread.

    When I try to enable the tv-out manually by executing:
    Code:
    xrandr --addmode S-video 800x600
    xrandr --output S-video --mode 800x600
    ... the following error occurs:
    Code:
    xrandr: cannot find crtc for output S-video
    However, this error seems to be solved by disabling the DVI (My live monitor is connected to the VGA port) by
    Code:
    xrandr --output DVI-0 --off
    But when I again try to enable the tv-out, the command seems to be accepted (no errors in the prompt) but my monitor picture increases the brightness a lot, and still no tv-out

    I cannot understand the clues that might be in my x-server log, except the final lines look promising. Therefore I've posted my Xorg.0.log here, as it looks after a reboot and an attempt of manually enabling the tv-out as described above.

    I will appreciate any comments a lot - Thanks

    Background: I'm running Ubuntu 7.10 on my Asus Pundit-r which has an onboard ATI Radeon 9100 IGP graphics card. I connect to my TV using an s-video cable and the described error occurs no matter if the TV-out is forced from the BIOS or not. Oh, and I'm in a PAL-B/G-land

  10. #30
    Join Date
    Oct 2007
    Posts
    4

    Default

    I have been waiting for this for years. Thanks, guys, keep up the good work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •