Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: X1650 Series Problem WIth OpenSuSE

  1. #1
    Join Date
    Aug 2007
    Posts
    9

    Default X1650 Series Problem WIth OpenSuSE

    Hey all

    I'm having problems after installing the ATI drivers for Linux. I have Opensuse 10.2. My problem is that when I check what drivers were installed I get this:

    Code:
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: Radeon X1600 Series
    OpenGL version string: 1.2 (2.0.6458 (8.36.5))
    But my gfxcard is a X1650 series? I have folowed the article by Opensuse to install my drivers.

    Thanks in advance

  2. #2

    Default

    I recall a similar situation where it ended up being a bug in the fglrx driver.

    I see you are using fglrx v8.36.5. Have you tried upgrading to 8.39.4?

  3. #3
    Join Date
    Aug 2007
    Posts
    9

    Default

    Hey thanks for the fast reply

    No I haven't. i've checked Yast for that right now, but i can't seem to find the update. Could you explain to me how to update it. To be honest i'm just into linux systems and only thing I know is how to use yast .

    Thanks again

  4. #4

    Default

    Follow the manual driver installation @ http://www.suse.de/~sndirsch/ati-installer-HOWTO.html

  5. #5
    Join Date
    Aug 2007
    Posts
    9

    Default

    Now I get this, which I think should not display:

    Code:
    file /etc/ati/control from install of fglrx_7_1_0_SUSE102-8.39.4-1 confl
    icts with file from package x11-video-fglrxG01-8.36.5-7.1
            file /usr/X11R6/lib/libGL.so.1.2 from install of fglrx_7_1_0_SUSE102-8.3
    9.4-1 conflicts with file from package x11-video-fglrxG01-8.36.5-7.1
            file /usr/X11R6/lib/libfglrx_gamma.a from install of fglrx_7_1_0_SUSE102
    -8.39.4-1 conflicts with file from package x11-video-fglrxG01-8.36.5-7.1
            file /usr/X11R6/lib/libfglrx_gamma.so.1.0 from install of fglrx_7_1_0_SU
    SE102-8.39.4-1 conflicts with file from package x11-video-fglrxG01-8.36.5-7.1
            file /usr/X11R6/lib/libfglrx_pp.a from install of fglrx_7_1_0_SUSE102-8.
    39.4-1 conflicts with file from package x11-video-fglrxG01-8.36.5-7.1
            file /usr/X11R6/lib/libfglrx_pp.so.1.0 from install of fglrx_7_1_0_SUSE1
    02-8.39.4-1 conflicts with file from package x11-video-fglrxG01-8.36.5-7.1
            file /usr/X11R6/lib/libfglrx_tvout.a from install of fglrx_7_1_0_SUSE102
    -8.39.4-1 conflicts with file from package x11-video-fglrxG01-8.36.5-7.1
            file /usr/bin/amdcccle from install of fglrx_7_1_0_SUSE102-8.39.4-1 conf
    licts with file from package x11-video-fglrxG01-8.36.5-7.1
            file /usr/bin/aticonfig from install of fglrx_7_1_0_SUSE102-8.39.4-1 con                     flicts with file from package x11-video-fglrxG01-8.36.5-7.1
            file /usr/bin/fgl_glxgears from install of fglrx_7_1_0_SUSE102-8.39.4-1                      conflicts with file from package x11-video-fglrxG01-8.36.5-7.1
            file /usr/bin/fglrx_xgamma from install of fglrx_7_1_0_SUSE102-8.39.4-1                      conflicts with file from package x11-video-fglrxG01-8.36.5-7.1
            file /usr/bin/fglrxinfo from install of fglrx_7_1_0_SUSE102-8.39.4-1 con                     flicts with file from package x11-video-fglrxG01-8.36.5-7.1
            file /usr/lib/dri/fglrx_dri.so from install of fglrx_7_1_0_SUSE102-8.39.                     4-1 conflicts with file from package x11-video-fglrxG01-8.36.5-7.1
            file /usr/lib/xorg/modules/drivers/fglrx_drv.so from install of fglrx_7_                     1_0_SUSE102-8.39.4-1 conflicts with file from package x11-video-fglrxG01-8.36.5-                     7.1
            file /usr/lib/xorg/modules/esut.a from install of fglrx_7_1_0_SUSE102-8.                     39.4-1 conflicts with file from package x11-video-fglrxG01-8.36.5-7.1
            file /usr/lib/xorg/modules/glesx.so from install of fglrx_7_1_0_SUSE102-                     8.39.4-1 conflicts with file from package x11-video-fglrxG01-8.36.5-7.1
            file /usr/lib/xorg/modules/linux/libfglrxdrm.so from install of fglrx_7_                     1_0_SUSE102-8.39.4-1 conflicts with file from package x11-video-fglrxG01-8.36.5-                     7.1
    Even in init 3 mode I have the same issue.

  6. #6

    Default

    Try uninstalling the 8.36 driver from Yast and then install the driver. Or just pass the 8.39 installation a force argument in SuSE so it will just overwrite all of those files.

  7. #7
    Join Date
    Aug 2007
    Posts
    9

    Default

    This doesnt look good. I cant run beryl now and everything is not running good. What now?

  8. #8

    Default

    Quote Originally Posted by kemicza View Post
    This doesnt look good. I cant run beryl now and everything is not running good. What now?
    The current fglrx driver doesn't support AIGLX so you can't use Beryl without XGL.

    What else isn't running good?

  9. #9
    Join Date
    Aug 2007
    Posts
    9

    Default

    Everything. The windows dont seem allright... When I drag icons over my desktop it gets all messy. If I try to open the console opensuse restarts and asks for username and password again. Even while Im typing now I see some messy spots with green blue negative-ish. Without console how can I check if x1650 was actually installed, maybe its still x1600.

  10. #10

    Default

    I just realized you mentioned X1650 you had and not X1950, which I originally misread and thought you mentioned when you had the X1600 string problem. It may still show X1600 series as the X1650 is in the X1600 series.

    If you restart to runlevel 3 and look at /var/log/Xorg.0.log are there any warnings (WW) or errors (EE)?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •