Results 1 to 5 of 5

Thread: RedHat 5 Dependencies

  1. #1
    Join Date
    Jan 2007
    Posts
    13

    Default RedHat 5 Dependencies

    Hello,

    I have successfully generated an RPM package with
    *.bin --buildpkg RedHat/RHEL5

    When I install the package as root I get the following dependencies...

    libstdc++.so.5(CXXABI_1.2)
    compat-libstdc++-33
    libstdc++.so.5
    libstdc++.so.5(GLIBCPP_3.2)

    Can anyone figure out what RPMs I need to install in order to solve the above.

    Thank you,

    Karsten

  2. #2
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    2,117

    Default

    libstdc++5 should do the trick. And for RHEL5, you can safely use the installer directly.

  3. #3
    Join Date
    Jan 2007
    Posts
    13

    Default

    Hello,

    Thanks for the help but do u know where I could find this RPM? Because it is not on any of my RHEL CDs :s

  4. #4
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    2,117

    Default

    Karsten,

    try looking for and installing the "compat-libstdc++" package from your CDs or with yum. That should work. If it doesn't, make sure you have the "libstdc++" package installed.

    If you don't find these, install the following packages directly:

    ftp://ftp.tu-chemnitz.de/pub/linux/c...2.el5.i386.rpm
    ftp://ftp.tu-chemnitz.de/pub/linux/c...6-138.i386.rpm
    ftp://ftp.tu-chemnitz.de/pub/linux/c....3-61.i386.rpm

    I hope that helps you.

    - d2kx

  5. #5
    Join Date
    Jan 2007
    Posts
    13

    Default

    Great,

    Thanks for the help. The RPM successfully installed and its all working.

    Thanks again for your time!

    Karsten

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •