Results 1 to 6 of 6

Thread: NVIDIA Updates Its Legacy Binary Blob

  1. #1
    Join Date
    Jan 2007
    Posts
    14,787

    Default NVIDIA Updates Its Legacy Binary Blob

    Phoronix: NVIDIA Updates Its Legacy Binary Blob

    NVIDIA has updated its legacy binary Linux display driver. The NVIDIA 173.14.30 is this new driver release and it simply adds support for X.Org Server 1.10 and compatibility for the newest Linux kernel releases (up through Linux 2.6.38). That's it...

    http://www.phoronix.com/vr.php?view=OTM1NA

  2. #2
    Join Date
    Jul 2009
    Location
    São Paulo, Brazil
    Posts
    73

    Default

    The article is wrong in the supported hardware part.

    The 173 Driver series support from Geforce 5 FX and Quadro FX up to the Geforce GTX 280

    The older 96 Driver series is for the Geforce 4 MX series and older. The last version is 96.43.19 and only support up to xserver 1.9. (I'm stuck with this shit here. Not even Compiz nor any composited desktop runs on a MX 4000 nowadays)

    And the newer drivers support from Geforce 6 up to the latest. Just saying.

  3. #3
    Join Date
    Jul 2009
    Location
    São Paulo, Brazil
    Posts
    73

    Default

    I think todays was the release of the first stable driver of the 270 series: 270.41.06
    Adding support for xserver 1.10 and the following newer GPUs:

    GeForce GT 520
    GeForce GT 525M
    GeForce GT 520M
    GeForce GT 445M
    GeForce GT 530
    GeForce 405
    GeForce GTX 590
    GeForce GTX 550 Ti
    GeForce GTX 560 Ti
    GeForce GT 420
    GeForce GT 440
    GeForce GTX 470M
    GeForce GTX 485M
    GeForce GT 550M
    GeForce GT 555M
    NVS 4200M
    Quadro 1000M
    Quadro 2000M
    Quadro 2000 D
    Quadro 400

    At least that's what is on their site. And I couldn't find that 173.14.30 release anywhere.

  4. #4
    Join Date
    Aug 2007
    Posts
    6,622

    Default

    @jntesteves

    173.xx series only works up to geforce 7. Show me "glxinfo|grep OpenGL" with that driver if you think it works.

  5. #5
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,584

    Default

    Quote Originally Posted by Kano View Post
    @jntesteves

    173.xx series only works up to geforce 7. Show me "glxinfo|grep OpenGL" with that driver if you think it works.
    Not true Kano, several 8/9 series are covered as well with the 173.xxx series.
    ftp://download1.nvidia.com/XFree86/L...DME/README.txt
    GeForce 8600 GTS 0x0400 GeForce 8600 GT 0x0401 GeForce 8600 GT 0x0402 GeForce 8600 GS 0x0403 GeForce 8400 GS 0x0404 GeForce 9500M GS 0x0405 GeForce 8600M GT 0x0407 GeForce 9650M GS 0x0408 GeForce 8700M GT 0x0409 GeForce 8400 SE 0x0420 GeForce 8500 GT 0x0421 GeForce 8400 GS 0x0422 GeForce 8300 GS 0x0423 GeForce 8400 GS 0x0424 GeForce 8600M GS 0x0425 GeForce 8400M GT 0x0426 GeForce 8400M GS 0x0427 GeForce 8400M G 0x0428 GeForce 9300M G 0x042E GeForce 7150M / nForce 630M 0x0531 GeForce 7000M / nForce 610M 0x0533 GeForce 7050 PV / NVIDIA nForce 630a 0x053A GeForce 7050 PV / NVIDIA nForce 630a 0x053B GeForce 7025 / NVIDIA nForce 630a 0x053E GeForce 8800 GTS 512 0x0600 GeForce 8800 GT 0x0602 GeForce 9800 GX2 0x0604 GeForce 8800 GS 0x0606 GeForce 8800M GTS 0x0609 GeForce 8800M GTX 0x060C GeForce 8800 GS 0x060D GeForce 9600 GSO 0x0610 GeForce 8800 GT 0x0611 GeForce 9800 GTX 0x0612 GeForce 9600 GT 0x0622 GeForce 9600M GT 0x0647 GeForce 9600M GS 0x0648 GeForce 9600M GT 0x0649 GeForce 9500M G 0x064B GeForce 8400 GS 0x06E4 GeForce 9300M GS 0x06E5 GeForce 9200M GS 0x06E8 GeForce 9300M GS 0x06E9 GeForce 7150 / NVIDIA nForce 630i 0x07E0 GeForce 7100 / NVIDIA nForce 630i 0x07E1 GeForce 7050 / NVIDIA nForce 610i 0x07E3 GeForce 9100M G 0x0844 GeForce 8300 0x0848 GeForce 8200 0x0849 nForce 730a 0x084A GeForce 8200 0x084B GeForce 8100 / nForce 720a 0x084F

  6. #6
    Join Date
    Aug 2007
    Posts
    6,622

    Default

    Well ok, my GT220 definitely does not work. Therefore i usually use a 7600gt for older drivers to test.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •