Page 5 of 11 FirstFirst ... 34567 ... LastLast
Results 41 to 50 of 101

Thread: Mobile Users Beware: Linux Has Major Power Regression

  1. #41

    Default

    Quote Originally Posted by evolution View Post
    Whoa!
    After doing a very basic test in my working laptop with powertop, I found I'm having significantly more wakeups-from-idle per second with 2.6.38 (about 230) than with 2.6.35 (about 170). This means my CPU is waking up from idle more 26% than before! It's a significant difference...

    I did my test only with my computer booted in OpenBox (without any programs loaded).

    Btw, my laptop doesn't seem hotter with 2.6.38 than with 2.6.35, but more wakeups-from-idle per second means my CPU is spending more power...

    Cheers

    p.s.: I hope the kernel devs fix this problem in 2.6.39...
    Please post hardware specs...

    And if it's what I think it is, it won't be fixed until the 2.6.40 merge window as the soonest as this is a very invasive, core issue.

  2. #42

    Default NMI

    echo 0 > /proc/sys/kernel/nmi_watchdog

    Or install the latest Jupiter (0.0.50) and it will set it for you when you unplug (and change it back when you apply power). As posted on UF, two systems on battery with WELL UNDER 200 wakeups per second.

    Lenovo T400
    Fuduntu 14.9 (64bit)
    Kernel 2.6.38.4
    Completely idle on battery for ~15 minutes.



    Asus Eee PC 1015PEM
    Fuduntu 14.9 (32bit)
    Kernel 2.6.38.4
    Completely idle on battery (as before)



    I don't know that I would call this a kernel regression, as the kernel doesn't dynamically change parameters based on applied power state. That's what you need something like Jupiter for..

  3. #43
    Join Date
    Oct 2010
    Posts
    257

    Default

    Quote Originally Posted by Michael View Post
    Please post hardware specs...
    Oh, I forgot it!

    Hw Specs:

    Processor: Core2Duo T7300@2.00GHz
    Mem: 2GB DDR2 PC6400
    HD: 200GB 4200RPM sata
    Laptop: Toshiba A200 PSAE-6
    Graphics Card: ATI Radeon HD2600

    Sw Specs:

    Kernel 1: 2.6.38.4-ck, BFS 401, CPUFreq governor 'ondemand' enabled by default
    Kernel 2: 2.6.28.5-lts-ck, BFS 401, CPUFreq governor 'ondemand' enabled by default
    Others: Catalyst 10.7, Xorg Server 1.8.2, OpenBox with Cairo-Compmgr, Dual Boot Arch Linux x86_64 + Windows 7

    And if it's what I think it is, it won't be fixed until the 2.6.40 merge window as the soonest as this is a very invasive, core issue.
    Fortunately, ATM I don't need to care very much about this problem, as I'm using my laptop most of the time in AC mode.

    Furthermore, adding to my last post, it seems both 2.6.35 and 2.6.38 kernel versions make my computer work a bit less hotter than on Windows 7 SP1 (Office/Internet).

    Cheers

  4. #44
    Join Date
    Feb 2011
    Posts
    11

    Default

    interesting.

    does this hold true for desktop (non-mobile) systems as well?

    I want to test it out on my narwhal setup as well (Sandy Bridge setup).

    Also, how do you regress back to the older linux kernel? Do you use apt-get or select it from the grub menu?

    And here I thought it was an issue with the B3 Sandy Bridge.

  5. #45

    Default

    Quote Originally Posted by MoFoQ View Post
    interesting.

    does this hold true for desktop (non-mobile) systems as well?

    I want to test it out on my narwhal setup as well (Sandy Bridge setup).

    Also, how do you regress back to the older linux kernel? Do you use apt-get or select it from the grub menu?

    And here I thought it was an issue with the B3 Sandy Bridge.
    I've heard of desktop users reporting 1. increased power consumption and 2. increased wake-ups per second. Based upon what I think the problem is at this point, it will affect any type of system -- desktops included.

    Just change it from GRUB2. If you don't see the option screen, add a timeout to your boot confoguration.

  6. #46
    Join Date
    Oct 2010
    Posts
    257

    Default

    Quote Originally Posted by evolution View Post

    Sw Specs:

    Kernel 1: 2.6.38.4-ck, BFS 401, CPUFreq governor 'ondemand' enabled by default
    Kernel 2: 2.6.28.5-lts-ck, BFS 401, CPUFreq governor 'ondemand' enabled by default
    Others: Catalyst 10.7, Xorg Server 1.8.2, OpenBox with Cairo-Compmgr, Dual Boot Arch Linux x86_64 + Windows 7
    The (in)famous 1 minute edit feature...

    Kernel 2: 2.6.35.12-lts-ck, BFS 401, CPUFreq governor 'ondemand' enabled by default

    Cheers

  7. #47

    Default

    Quote Originally Posted by evolution View Post
    The (in)famous 1 minute edit feature...

    Kernel 2: 2.6.35.12-lts-ck, BFS 401, CPUFreq governor 'ondemand' enabled by default

    Cheers
    Ah okay, so on Arch. Good to see a non-Ubuntu user having problems (well, sorry for you) due to it being an upstream issue, but unfortunate as you won't be able to test my Debian packages.... If anyone else running Ubuntu that's experiencing this power problem, please email me (Michael at phoronix). I'm nearly done in analyzing this situation and I would like to have some kernels tested by some external people when ready.

  8. #48

    Default

    Quote Originally Posted by airlied View Post
    Thats nearly as good a generalisation as the one about only clueless idiots post on forums...

    Dave.
    Well, Dave, I'd like to hear an actual substantive discussion on the merits of the issues rather than a simple ad hominem attack. Well, all right. I'll give in to the temptation. How's it like getting chewed out of Linus every merge cycle because the drm folks don't properly test their patches before submitting them?

    Here are the links from actual developers confirming the inherent bias towards enterprise usage scenarios.

    Ted Tso on the ext4 crash:
    https://bugs.launchpad.net/ubuntu/+s...1?comments=all

    Patronizing attitude of I know it best and everyone who doesn't use software in the same way I do should learn what I do: "Personally, I test bleeding edge kernels all the time, and I've never had a problem simply because I usually know before I'm about to do something that might be dangerous, and so I just use the "sync" command in a terminal beforehand."

    There are usage scenarios that require high performance OpenGL (again, patronizing and refusing to acknowledge that others have different usage patterns): "The other thing that probably helps is that I also avoid hardware that requires proprietary video drivers like the plague. Why settle for machines that crash all the time? There are enough hardware options out there that don't require proprietary video drivers, I don't understand why folks would even consider buying cards that need binary-only video drivers."

    Indirectly this shows most of the developers are out of touch with the majority of users. Most consumers running Linux do not drive OpenBox or a command shell. They run a desktop environment. If developers are not even using and testing in such a common pattern, that will only lead to gotcha bugs when software is released: "I'll note that I use the GNOME desktop (which means the gnome panel, but I'm not a very major desktop user), and "find .[a-zA-Z]* -mtime 0" doesn't show a large number of files."

    Instead of fixing the software, blame the user: "Another solution is to make sure your system is reliable. :-) If you have your server in a proper data center, with a UPS, and you're not using any unreliable binary-only video drivers or network drivers, then your system shouldn't be randomly locking up or crashing"


    Con Kolivas on how development is increasingly being driven by needs of corporations: http://apcmag.com/interview_with_con..._is_boring.htm

    Now, this is only a natural state of affairs. Few hobbyist developers can afford to scratch their own itch, and the few that do care about the community's needs apparently are unceremoniously pushed aside when their proposed changes will get in the slightest way of the corporate agenda. After all, who's hiring developers of the kernel? Intel, IBM, Oracle, Red Hat. Of course their own needs will be met first. Ulrich Drepper said it best when someone made a request for changes on glibc. He asked "Do you sign my paycheques?"

    Relevant quotes from Con:
    "I even recall one bug report we tried to submit about this and one developer said he couldn't reproduce the problem on his quad-CPU 4GB RAM machine with 4 striped RAID array disks... think about the sort of hardware the average user would have had four years ago. Is it any wonder the desktop sucked so much?

    The developers were all developing for something that wasn't the desktop. They had all been employed by big name manufacturers who couldn't care less about the desktop (and still don't) but want their last 1% on their database benchmark or throughput benchmark or whatever."

    As to the individual on page 5 asking about why enterprise customers should care more about power consumption, the simple answer is that if you follow patches, you'll notice that the ones going in are more about supporting new features without bugs, and then about performance. Lastly are ancillary concerns about power consumption. Look at how slowly work on dynamic pm is going on radeon hardware.

    Linux power usage has been behind Windows and Mac OSX forever. Even if you use the argument of standards, If I install a generic version (unoptimized by the vendor) of Windows 7 and compare to the latest kernel straight out of the box running a very lightweight DM, I still get 30-60 min better idle runtime on the windows machine.

  9. #49
    Join Date
    Feb 2011
    Posts
    11

    Default

    Quote Originally Posted by Michael View Post
    I've heard of desktop users reporting 1. increased power consumption and 2. increased wake-ups per second. Based upon what I think the problem is at this point, it will affect any type of system -- desktops included.

    Just change it from GRUB2. If you don't see the option screen, add a timeout to your boot confoguration.
    Let me give it a try though I don't remember if I ever see that prompt.

    btw, specs:

    i7-2600 (3.4GHz)
    ASRock H67M-GE (B3) BIOS 1.40
    16GB of DDR3
    a Seagate Barracuda ES (SATA) 750GB
    and a Seasonc 400W 80PLUS Gold
    Narwhal (11.04) 64bit server

    Currently it idles at 33-35W (per a kill-a-watt meter) and when I run mprime's torture test (#2 or #3), it maxes out at around 115W.
    I'll check which kernel it is and test it with other versions.

  10. #50

    Default

    Quote Originally Posted by MoFoQ View Post
    Let me give it a try though I don't remember if I ever see that prompt.

    btw, specs:

    i7-2600 (3.4GHz)
    ASRock H67M-GE (B3) BIOS 1.40
    16GB of DDR3
    a Seagate Barracuda ES (SATA) 750GB
    and a Seasonc 400W 80PLUS Gold
    Narwhal (11.04) 64bit server

    Currently it idles at 33-35W (per a kill-a-watt meter) and when I run mprime's torture test (#2 or #3), it maxes out at around 115W.
    I'll check which kernel it is and test it with other versions.

    On a clean install you won't ever see that prompt unless your boot fails. Add a new line of 'set timeout=5' to /boot/grub/grub.cfg as the easiest quick way to get the menu back.

    Okay, another Sandy Bridge system... I've seen reports earlier of the power issue under SNB too.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •