Results 1 to 4 of 4

Thread: X-Video not working in Fedora 7

  1. #1
    Join Date
    Jul 2007
    Posts
    10

    Default X-Video not working in Fedora 7

    just installed 8.40 and i can't get XV to work in Fedora 7.

    xvinfo says...
    Code:
    10 > xvinfo
    X-Video Extension version 2.2
    screen #0
     no adaptors present

    here's my xorg.conf:
    Code:
    # Xorg configuration created by system-config-display
    
    Section "ServerLayout"
            Identifier     "single head configuration"
            Screen      0  "aticonfig-Screen[0]" 0 0
            InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
    EndSection
    
    Section "InputDevice"
            Identifier  "Keyboard0"
            Driver      "kbd"
            Option      "XkbModel" "pc105"
            Option      "XkbLayout" "us"
    EndSection
    
    Section "Monitor"
            Identifier   "aticonfig-Monitor[0]"
            Option      "VendorName" "ATI Proprietary Driver"
            Option      "ModelName" "Generic Autodetecting Monitor"
            Option      "DPMS" "true"
    EndSection
    
    Section "Device"
            Identifier  "aticonfig-Device[0]"
            Driver      "fglrx"
    EndSection
    
    Section "Screen"
            Identifier "aticonfig-Screen[0]"
            Device     "aticonfig-Device[0]"
            Monitor    "aticonfig-Monitor[0]"
            DefaultDepth     24
            SubSection "Display"
                    Viewport   0 0
                    Depth     24
                    Modes   "1600x1200"
            EndSubSection
    EndSection

    tried to make it as simple as possible. but i'm missing something.



    and relevant snippets from Xorg.0.log:
    Code:
    (WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found
    
    ...
    
    (WW) fglrx(0): board is an unknown third party board, chipset is supported
    only errors from there is about AIGLX.



    and lspci output:
    Code:
    01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AP [Radeon 9600]
    01:00.1 Display controller: ATI Technologies Inc RV350 AP [Radeon 9600] (Secondary)
    help!

  2. #2

    Default

    Have you tried adding:

    Option "TexturedVideo" "True"

    to your xorg.conf in the fglrx device section?

  3. #3
    Join Date
    Sep 2006
    Location
    PL
    Posts
    910

    Default

    wasn't it "On" instead of "True" ?

  4. #4
    Join Date
    Jul 2007
    Posts
    10

    Default

    yes! that worked!

    i forgot about that parameter. i've used it a while
    back, but it slipped my mind through numerous upgrades.

    would be nice if it was set by default.


    thanks, Michael.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •