Page 14 of 143 FirstFirst ... 412131415162464114 ... LastLast
Results 131 to 140 of 1423

Thread: Updated and Optimized Ubuntu Free Graphics Drivers

  1. #131
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    139

    Default oniric

    Hi, i am italian my english is bad. :-)
    I have installed oniric 64bit, but the file libg3dvlmesa_7.12~git1110141658.ae272a~gd~o_amd64. deb dont install nothing inside directory /usr/lib/vdpau.
    After install i haved only 2 files.
    libvdpau_trace.so.1
    libvdpau_trace.so.1.0.0

    Thanks.
    I think a bug when make a files deb.
    Last edited by Vincenzov; 10-14-2011 at 03:00 PM.

  2. #132
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    139

    Default oneiric 11.10 kubuntu 64 bit

    Hi

    I have installed

    sudo add-apt-repository ppaibaf/graphics-drivers

    and

    deb http://ppa.launchpad.net/tista/x120e/ubuntu oneiric main
    deb-src http://ppa.launchpad.net/tista/x120e/ubuntu oneiric main

    but pretend to install this files libg3dvlmesa_7.12~git1110141658.ae272a~gd~o_amd64. deb

    I have done something wrong?

    thanks for help.

  3. #133
    Join Date
    Sep 2011
    Posts
    29

    Default

    Quote Originally Posted by oibaf View Post
    libgl1-mesa-dri pacakge "Recommends: libtxc-dxtn0", so it should be automatically installed if you didn't disable installing recommended packages. Can you post the output of dpkg -l | grep libtxc and then again glxinfo ?
    gsedej@seraph:~/Prenosi/Unigine_Heaven$ dpkg -l | grep libtxc
    ii libtxc-dxtn0 1.0.1-0.2 S3 Texture Compression (S3TC) library

    glxinfo:
    http://pastebin.com/96JdRUQp

    I found out that I need to use R600_ENABLE_S3TC=1
    But then I get:

    radeon: The kernel rejected CS, see dmesg for more information.
    radeon: The kernel rejected CS, see dmesg for more information.
    radeon: The kernel rejected CS, see dmesg for more information.
    radeon: The kernel rejected CS, see dmesg for more information.
    ...
    dmesg:
    [577112.943190] radeon 0000:01:05.0: r600_check_texture_resource:1214 texture invalid format 49
    [577112.943196] [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [577112.945640] radeon 0000:01:05.0: r600_check_texture_resource:1214 texture invalid format 49
    [577112.945650] [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [577112.946185] radeon 0000:01:05.0: r600_check_texture_resource:1214 texture invalid format 52
    [577112.946190] [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [577112.946467] radeon 0000:01:05.0: r600_check_texture_resource:1214 texture invalid format 51
    [577112.946469] [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [577112.947521] radeon 0000:01:05.0: r600_check_texture_resource:1214 texture invalid format 51
    ....
    so formats are 49 51 and 52

    Probably some error with kernel?

  4. #134

    Default

    Quote Originally Posted by Vincenzov View Post
    Hi, i am italian my english is bad. :-)
    I have installed oniric 64bit, but the file libg3dvlmesa_7.12~git1110141658.ae272a~gd~o_amd64. deb dont install nothing inside directory /usr/lib/vdpau.
    After install i haved only 2 files.
    libvdpau_trace.so.1
    libvdpau_trace.so.1.0.0

    Thanks.
    I think a bug when make a files deb.
    I updated the package, try in a couple of hour, hopefully it should work (before they were installed in /usr/lib/amd64-linux-gnu/vdpau/).

  5. #135

    Default

    Quote Originally Posted by gsedej View Post
    gsedej@seraph:~/Prenosi/Unigine_Heaven$ dpkg -l | grep libtxc
    ii libtxc-dxtn0 1.0.1-0.2 S3 Texture Compression (S3TC) library

    glxinfo:
    http://pastebin.com/96JdRUQp

    I found out that I need to use R600_ENABLE_S3TC=1
    But then I get:

    radeon: The kernel rejected CS, see dmesg for more information.
    radeon: The kernel rejected CS, see dmesg for more information.
    radeon: The kernel rejected CS, see dmesg for more information.
    radeon: The kernel rejected CS, see dmesg for more information.
    ...
    dmesg:
    [577112.943190] radeon 0000:01:05.0: r600_check_texture_resource:1214 texture invalid format 49
    [577112.943196] [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [577112.945640] radeon 0000:01:05.0: r600_check_texture_resource:1214 texture invalid format 49
    [577112.945650] [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [577112.946185] radeon 0000:01:05.0: r600_check_texture_resource:1214 texture invalid format 52
    [577112.946190] [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [577112.946467] radeon 0000:01:05.0: r600_check_texture_resource:1214 texture invalid format 51
    [577112.946469] [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [577112.947521] radeon 0000:01:05.0: r600_check_texture_resource:1214 texture invalid format 51
    ....
    so formats are 49 51 and 52

    Probably some error with kernel?
    How did you install libtxc-dxtn0? It looks like you downloaded it from an external PPA, that version is not the one in my PPA (you probably installed it over my one with version 1.0.0-0.0~1gd~natty1 thinking it wasn't installed but it already was).

    Anyway, my packages should be fine. You should try a newer kernel, and see if it's fixed with it.

  6. #136
    Join Date
    Jul 2008
    Location
    Germany
    Posts
    711

    Default

    gsedej looks like you using an old kernel. For Ubuntu you can get an newer kernel @ http://kernel.ubuntu.com/~kernel-ppa/mainline/

  7. #137
    Join Date
    Sep 2011
    Posts
    29

    Default

    Oh, thanks. Yes I installed because I am did this on my laptop (RV350) and it works. I will purge it and install your.

    My kernel:
    gsedej@seraph:~$ uname -a
    Linux seraph 2.6.38-11-generic #50-Ubuntu SMP Mon Sep 12 21:17:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

    (offtopic: how to edit posts?)

  8. #138

    Default

    Quote Originally Posted by gsedej View Post
    Oh, thanks. Yes I installed because I am did this on my laptop (RV350) and it works. I will purge it and install your.

    My kernel:
    gsedej@seraph:~$ uname -a
    Linux seraph 2.6.38-11-generic #50-Ubuntu SMP Mon Sep 12 21:17:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

    (offtopic: how to edit posts?)
    That's the latest natty kernel, but that bug may be fixed in a later kernel. Try compiling yourself latest 2.6.39.x (there are no newer kernel on http://kernel.ubuntu.com/~kernel-ppa/mainline/ for natty) or try upgrading to Ubuntu 11.10 (ships a 3.0.x kernel).

  9. #139
    Join Date
    Jul 2008
    Location
    Germany
    Posts
    711

    Default

    Quote Originally Posted by oibaf View Post
    (there are no newer kernel on http://kernel.ubuntu.com/~kernel-ppa/mainline/ for natty) or try upgrading to Ubuntu 11.10 (ships a 3.0.x kernel).
    But the new version work without problems for me. 11.04 with 3.0.

  10. #140
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    139

    Default

    Quote Originally Posted by oibaf View Post
    I updated the package, try in a couple of hour, hopefully it should work (before they were installed in /usr/lib/amd64-linux-gnu/vdpau/).
    Perfect perfect. Thanks.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •