I just wonder what -ati are you using since 6.14.99+git1206080959.588837~gd~o is for 11.10 and also failed to build in the PPA, so you can't be really using that.