Page 72 of 109 FirstFirst ... 2262707172737482 ... LastLast
Results 711 to 720 of 1082

Thread: Updated and Optimized Ubuntu Free Graphics Drivers

  1. #711
    Join Date
    Dec 2011
    Posts
    7

    Default

    Quote Originally Posted by oibaf View Post
    I have the package in this test PPA. If you can confirm it's OK I'll push it in the main PPA.
    did you build it with the default llvm from saucy? I did a test build with llvm-3.4 here, only needs a little configure.ac patch.

  2. #712
    Join Date
    Oct 2013
    Posts
    12

    Default

    Quote Originally Posted by oibaf View Post
    I backported it already in raring (and there is by default in saucy), the package doesn't build on older Ubuntu IIRC, which I'll drop soon anyway.
    Please don't drop support for 12.04. A lot of us are still holding out the upgrade until 14.04 gets released and your PPA is pretty much the only easy and considerably safe access we have to the current graphics stack. So if it's technically feasible, please do wait until the next LTS release to drop 12.04 support.
    Last edited by tiredoffglrx; 10-31-2013 at 11:15 AM.

  3. #713
    Join Date
    Nov 2010
    Posts
    249

    Default

    Quote Originally Posted by Bushido_root View Post
    Works just fine for me; you might need to add:
    Code:
    radeon.audio=1
    to GRUB.
    Edit the /etc/default/grub file and add the parameter to the line:

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash "
    so it would look like this
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"
    Run sudo update-grub then reboot.
    Thanks I tried that and still no sound. I changed it like you said and rebooted, but nothing.

    Code:
    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"
    GRUB_CMDLINE_LINUX=""

  4. #714

    Default

    Hi, i tried to install mesa 10 for saucy from this ppa and it seems that something is wrong with the package. I still only get gl 3.0 support for my ivybridge graphics card, but according to mesa documentation it should have gl 3.3 support enabled.

    glxinfo:
    Code:
    OpenGL vendor string: Intel Open Source Technology Center
    OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
    OpenGL version string: 3.0 Mesa 10.0.0-devel (git-b16b3c8 saucy-oibaf-ppa)
    OpenGL shading language version string: 1.30

  5. #715
    Join Date
    Feb 2012
    Posts
    51

    Question Xorg segfaults with AMD/Ivybridge dual graphics on Saucy

    Hi,

    I just installed the latest packages from the PPA and Xorg segfaults while booting. The error log looks like this:
    Code:
    [    31.705] (II) VESA: driver for VESA chipsets: vesa
    [    31.705] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
    [    31.705] (II) FBDEV: driver for framebuffer: fbdev
    [    31.705] (++) using VT number 7
    
    [    31.705] (II) intel(0): SNA compiled: xserver-xorg-video-intel 2:2.99.905+git1310311033.ed16e3~gd~s (Oibaf <fmrummey@gmail.com>)
    [    31.705] (II) [KMS] Kernel modesetting enabled.
    [    31.705] (WW) Falling back to old probe method for vesa
    [    31.705] (WW) Falling back to old probe method for modesetting
    [    31.705] (WW) Falling back to old probe method for fbdev
    [    31.705] (II) Loading sub module "fbdevhw"
    [    31.705] (II) LoadModule: "fbdevhw"
    [    31.705] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
    [    31.706] (II) Module fbdevhw: vendor="X.Org Foundation"
    [    31.706] 	compiled for 1.14.3, module version = 0.0.2
    [    31.706] 	ABI class: X.Org Video Driver, version 14.1
    [    31.706] (II) intel(0): Creating default Display subsection in Screen section
    	"Default Screen Section" for depth/fbbpp 24/32
    [    31.706] (==) intel(0): Depth 24, (--) framebuffer bpp 32
    [    31.706] (==) intel(0): RGB weight 888
    [    31.706] (==) intel(0): Default visual is TrueColor
    [    31.706] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 4000
    [    31.706] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx
    [    31.706] (**) intel(0): Framebuffer tiled
    [    31.706] (**) intel(0): Pixmaps tiled
    [    31.706] (**) intel(0): "Tear free" disabled
    [    31.706] (**) intel(0): Forcing per-crtc-pixmaps? no
    [    31.706] (II) intel(0): Output eDP1 has no monitor section
    [    31.706] (--) intel(0): found backlight control interface acpi_video1 (type 'firmware')
    [    31.706] (II) intel(0): Output VGA1 has no monitor section
    [    31.706] (II) intel(0): Output HDMI1 has no monitor section
    [    31.706] (II) intel(0): Output DP1 has no monitor section
    [    31.706] (II) intel(0): Output VIRTUAL1 has no monitor section
    [    31.706] (--) intel(0): Output eDP1 using initial mode 1920x1080 on pipe 0
    [    31.706] (==) intel(0): DPI set to (96, 96)
    [    31.706] (II) Loading sub module "dri2"
    [    31.706] (II) LoadModule: "dri2"
    [    31.706] (II) Module "dri2" already built-in
    [    31.706] (==) RADEON(G0): Depth 24, (--) framebuffer bpp 32
    [    31.706] (II) RADEON(G0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
    [    31.706] (==) RADEON(G0): Default visual is TrueColor
    [    31.706] (==) RADEON(G0): RGB weight 888
    [    31.706] (II) RADEON(G0): Using 8 bits per RGB (8 bit DAC)
    [    31.706] (--) RADEON(G0): Chipset: "OLAND" (ChipID = 0x6600)
    [    31.706] (II) Loading sub module "dri2"
    [    31.706] (II) LoadModule: "dri2"
    [    31.706] (II) Module "dri2" already built-in
    [    31.706] (II) Loading sub module "glamoregl"
    [    31.706] (II) LoadModule: "glamoregl"
    [    31.707] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
    [    31.707] (II) Module glamoregl: vendor="X.Org Foundation"
    [    31.707] 	compiled for 1.14.3, module version = 0.5.1
    [    31.707] 	ABI class: X.Org ANSI C Emulation, version 0.4
    [    31.707] (II) glamor: OpenGL accelerated X.org driver based.
    [    33.422] (EE) 
    [    33.422] (EE) Backtrace:
    [    33.422] (EE) 0: /usr/bin/X (xorg_backtrace+0x3d) [0x7f1b5299102d]
    [    33.422] (EE) 1: /usr/bin/X (0x7f1b527ef000+0x1a5d99) [0x7f1b52994d99]
    [    33.422] (EE) 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7f1b518ef000+0xfbb0) [0x7f1b518febb0]
    [    33.422] (EE) 
    [    33.422] (EE) Segmentation fault at address 0x0
    [    33.422] (EE) 
    Fatal server error:
    [    33.422] (EE) Caught signal 11 (Segmentation fault). Server aborting
    [    33.422] (EE) 
    [    33.422] (EE) 
    Please consult the The X.Org Foundation support 
    	 at http://wiki.x.org
     for help. 
    [    33.422] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    [    33.422] (EE) 
    [    33.440] (EE) Server terminated with error (1). Closing log file.
    This error also happens with the stable drivers on Saucy. Any idea why this might be?

  6. #716
    Join Date
    Oct 2012
    Posts
    256

    Default

    Quote Originally Posted by Dzony.Kalafut View Post
    Hi, i tried to install mesa 10 for saucy from this ppa and it seems that something is wrong with the package. I still only get gl 3.0 support for my ivybridge graphics card, but according to mesa documentation it should have gl 3.3 support enabled.

    glxinfo:
    Code:
    OpenGL vendor string: Intel Open Source Technology Center
    OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
    OpenGL version string: 3.0 Mesa 10.0.0-devel (git-b16b3c8 saucy-oibaf-ppa)
    OpenGL shading language version string: 1.30
    same observation here with i3 haswell on h87 board.

    also i've noticed that i cannot run any of the unigine benchmarks because "GL_ARB_geometry_shader4" is not supported. shouldn't this be already in mesa?

  7. #717

    Default

    Quote Originally Posted by wsnipex View Post
    did you build it with the default llvm from saucy? I did a test build with llvm-3.4 here, only needs a little configure.ac patch.
    The problem with building against LLVM 3.4 is that its API changes frequently and I should also update every day LLVM in my PPA. There could be a solution, see what I wrote here.

  8. #718
    Join Date
    Aug 2012
    Posts
    308

    Default

    And that will not be a solution because the maintainer refuses.

  9. #719
    Join Date
    Nov 2013
    Posts
    3

    Default How to revert back to stock RADEON drivers???

    Ok read all 72 pages of this thread, i tried the purge ppa command bit it did not revert my graphics back. I am running Mint 15 with KDE 4.11
    I was getting 60fps before in open gl apps now i get less than 30, what gives? how do i get back hardware open gl support?

    i just want the stock mint 15 radeon drivers back, help!!!

    thanks in advance!


    Code:
    glxinfo | grep renderer
    OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 256 bits)

    Code:
    inxi -Gx
    Graphics:  Card: Advanced Micro Devices [AMD/ATI] RV770 [Radeon HD 4850] bus-ID: 01:00.0                 
               X.Org: 1.13.3 drivers: (unloaded: fbdev) FAILED: vesa Resolution: 1920x1080@60.0hz, 1920x1080@60.0hz                                                                                                   
               GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.3, 256 bits) GLX Version: 2.1 Mesa 10.0.0-devel (git-b16b3c8 raring-oibaf-ppa) Direct Rendering: Yes

    Code:
    dmesg | egrep 'drm|radeon'
    [    0.000000] Command line: BOOT_IMAGE=/vmlinuz-3.11.6-031106-generic root=/dev/mapper/mint--vg-root ro quiet splash radeon.dpm=1 vt.handoff=7
    [    0.000000] Kernel command line: BOOT_IMAGE=/vmlinuz-3.11.6-031106-generic root=/dev/mapper/mint--vg-root ro quiet splash radeon.dpm=1 vt.handoff=7
    [    0.590574] [drm] Initialized drm 1.1.0 20060810
    [    0.603908] [drm] radeon kernel modesetting enabled.
    [    0.611609] [drm] initializing kernel modesetting (RV770 0x1002:0x9442 0x1028:0x0502).
    [    0.611624] [drm] register mmio base: 0xF7E20000
    [    0.611625] [drm] register mmio size: 65536
    [    0.611695] radeon 0000:01:00.0: VRAM: 512M 0x0000000000000000 - 0x000000001FFFFFFF (512M used)
    [    0.611696] radeon 0000:01:00.0: GTT: 512M 0x0000000020000000 - 0x000000003FFFFFFF
    [    0.611697] [drm] Detected VRAM RAM=512M, BAR=256M
    [    0.611698] [drm] RAM width 256bits DDR
    [    0.612337] [drm] radeon: 512M of VRAM memory ready
    [    0.612337] [drm] radeon: 512M of GTT memory ready.
    [    0.612348] [drm] GART: num cpu pages 131072, num gpu pages 131072
    [    0.612553] [drm] enabling PCIE gen 2 link speeds, disable with radeon.pcie_gen2=0
    [    0.634095] [drm] Loading RV770 Microcode
    [    0.634463] [drm] PCIE GART of 512M enabled (table at 0x0000000000040000).
    [    0.634498] radeon 0000:01:00.0: WB enabled
    [    0.634500] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x0000000020000c00 and cpu addr 0xffff88040025ec00
    [    0.634501] radeon 0000:01:00.0: fence driver on ring 3 use gpu addr 0x0000000020000c0c and cpu addr 0xffff88040025ec0c
    [    0.634502] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
    [    0.634502] [drm] Driver supports precise vblank timestamp query.
    [    0.634515] radeon 0000:01:00.0: irq 45 for MSI/MSI-X
    [    0.634520] radeon 0000:01:00.0: radeon: using MSI.
    [    0.634534] [drm] radeon: irq initialized.
    [    0.680559] [drm] ring test on 0 succeeded in 1 usecs
    [    0.680614] [drm] ring test on 3 succeeded in 1 usecs
    [    0.680712] [drm] ib test on ring 0 succeeded in 0 usecs
    [    0.680722] [drm] ib test on ring 3 succeeded in 0 usecs
    [    0.680811] [drm] Radeon Display Connectors
    [    0.680812] [drm] Connector 0:
    [    0.680812] [drm]   DVI-I-1
    [    0.680813] [drm]   HPD1
    [    0.680814] [drm]   DDC: 0x7e60 0x7e60 0x7e64 0x7e64 0x7e68 0x7e68 0x7e6c 0x7e6c
    [    0.680814] [drm]   Encoders:
    [    0.680815] [drm]     DFP1: INTERNAL_UNIPHY
    [    0.680815] [drm]     CRT2: INTERNAL_KLDSCP_DAC2
    [    0.680816] [drm] Connector 1:
    [    0.680817] [drm]   DIN-1
    [    0.680817] [drm]   Encoders:
    [    0.680817] [drm]     TV1: INTERNAL_KLDSCP_DAC2
    [    0.680818] [drm] Connector 2:
    [    0.680818] [drm]   DVI-I-2
    [    0.680819] [drm]   HPD2
    [    0.680820] [drm]   DDC: 0x7e20 0x7e20 0x7e24 0x7e24 0x7e28 0x7e28 0x7e2c 0x7e2c
    [    0.680820] [drm]   Encoders:
    [    0.680820] [drm]     CRT1: INTERNAL_KLDSCP_DAC1
    [    0.680821] [drm]     DFP2: INTERNAL_KLDSCP_LVTMA
    [    0.680839] [drm] Internal thermal controller with fan control
    [    0.684509] [drm] radeon: dpm initialized
    [    0.792885] [drm] fb mappable at 0xE0142000
    [    0.792886] [drm] vram apper at 0xE0000000
    [    0.792887] [drm] size 8294400
    [    0.792887] [drm] fb depth is 24
    [    0.792887] [drm]    pitch is 7680
    [    0.792917] fbcon: radeondrmfb (fb0) is primary device
    [    0.869170] radeon 0000:01:00.0: fb0: radeondrmfb frame buffer device
    [    0.869171] radeon 0000:01:00.0: registered panic notifier
    [    0.869176] [drm] Initialized radeon 2.34.0 20080528 for 0000:01:00.0 on minor 0

  10. #720
    Join Date
    Aug 2012
    Posts
    308

    Default

    Quote Originally Posted by TxHammer View Post
    Ok read all 72 pages of this thread, i tried the purge ppa command bit it did not revert my graphics back. I am running Mint 15 with KDE 4.11
    I was getting 60fps before in open gl apps now i get less than 30, what gives? how do i get back hardware open gl support?

    i just want the stock mint 15 radeon drivers back, help!!!

    thanks in advance!


    Code:
    glxinfo | grep renderer
    OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 256 bits)

    Code:
    inxi -Gx
    Graphics:  Card: Advanced Micro Devices [AMD/ATI] RV770 [Radeon HD 4850] bus-ID: 01:00.0                 
               X.Org: 1.13.3 drivers: (unloaded: fbdev) FAILED: vesa Resolution: 1920x1080@60.0hz, 1920x1080@60.0hz                                                                                                   
               GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.3, 256 bits) GLX Version: 2.1 Mesa 10.0.0-devel (git-b16b3c8 raring-oibaf-ppa) Direct Rendering: Yes

    Code:
    dmesg | egrep 'drm|radeon'
    [    0.000000] Command line: BOOT_IMAGE=/vmlinuz-3.11.6-031106-generic root=/dev/mapper/mint--vg-root ro quiet splash radeon.dpm=1 vt.handoff=7
    [    0.000000] Kernel command line: BOOT_IMAGE=/vmlinuz-3.11.6-031106-generic root=/dev/mapper/mint--vg-root ro quiet splash radeon.dpm=1 vt.handoff=7
    [    0.590574] [drm] Initialized drm 1.1.0 20060810
    [    0.603908] [drm] radeon kernel modesetting enabled.
    [    0.611609] [drm] initializing kernel modesetting (RV770 0x1002:0x9442 0x1028:0x0502).
    [    0.611624] [drm] register mmio base: 0xF7E20000
    [    0.611625] [drm] register mmio size: 65536
    [    0.611695] radeon 0000:01:00.0: VRAM: 512M 0x0000000000000000 - 0x000000001FFFFFFF (512M used)
    [    0.611696] radeon 0000:01:00.0: GTT: 512M 0x0000000020000000 - 0x000000003FFFFFFF
    [    0.611697] [drm] Detected VRAM RAM=512M, BAR=256M
    [    0.611698] [drm] RAM width 256bits DDR
    [    0.612337] [drm] radeon: 512M of VRAM memory ready
    [    0.612337] [drm] radeon: 512M of GTT memory ready.
    [    0.612348] [drm] GART: num cpu pages 131072, num gpu pages 131072
    [    0.612553] [drm] enabling PCIE gen 2 link speeds, disable with radeon.pcie_gen2=0
    [    0.634095] [drm] Loading RV770 Microcode
    [    0.634463] [drm] PCIE GART of 512M enabled (table at 0x0000000000040000).
    [    0.634498] radeon 0000:01:00.0: WB enabled
    [    0.634500] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x0000000020000c00 and cpu addr 0xffff88040025ec00
    [    0.634501] radeon 0000:01:00.0: fence driver on ring 3 use gpu addr 0x0000000020000c0c and cpu addr 0xffff88040025ec0c
    [    0.634502] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
    [    0.634502] [drm] Driver supports precise vblank timestamp query.
    [    0.634515] radeon 0000:01:00.0: irq 45 for MSI/MSI-X
    [    0.634520] radeon 0000:01:00.0: radeon: using MSI.
    [    0.634534] [drm] radeon: irq initialized.
    [    0.680559] [drm] ring test on 0 succeeded in 1 usecs
    [    0.680614] [drm] ring test on 3 succeeded in 1 usecs
    [    0.680712] [drm] ib test on ring 0 succeeded in 0 usecs
    [    0.680722] [drm] ib test on ring 3 succeeded in 0 usecs
    [    0.680811] [drm] Radeon Display Connectors
    [    0.680812] [drm] Connector 0:
    [    0.680812] [drm]   DVI-I-1
    [    0.680813] [drm]   HPD1
    [    0.680814] [drm]   DDC: 0x7e60 0x7e60 0x7e64 0x7e64 0x7e68 0x7e68 0x7e6c 0x7e6c
    [    0.680814] [drm]   Encoders:
    [    0.680815] [drm]     DFP1: INTERNAL_UNIPHY
    [    0.680815] [drm]     CRT2: INTERNAL_KLDSCP_DAC2
    [    0.680816] [drm] Connector 1:
    [    0.680817] [drm]   DIN-1
    [    0.680817] [drm]   Encoders:
    [    0.680817] [drm]     TV1: INTERNAL_KLDSCP_DAC2
    [    0.680818] [drm] Connector 2:
    [    0.680818] [drm]   DVI-I-2
    [    0.680819] [drm]   HPD2
    [    0.680820] [drm]   DDC: 0x7e20 0x7e20 0x7e24 0x7e24 0x7e28 0x7e28 0x7e2c 0x7e2c
    [    0.680820] [drm]   Encoders:
    [    0.680820] [drm]     CRT1: INTERNAL_KLDSCP_DAC1
    [    0.680821] [drm]     DFP2: INTERNAL_KLDSCP_LVTMA
    [    0.680839] [drm] Internal thermal controller with fan control
    [    0.684509] [drm] radeon: dpm initialized
    [    0.792885] [drm] fb mappable at 0xE0142000
    [    0.792886] [drm] vram apper at 0xE0000000
    [    0.792887] [drm] size 8294400
    [    0.792887] [drm] fb depth is 24
    [    0.792887] [drm]    pitch is 7680
    [    0.792917] fbcon: radeondrmfb (fb0) is primary device
    [    0.869170] radeon 0000:01:00.0: fb0: radeondrmfb frame buffer device
    [    0.869171] radeon 0000:01:00.0: registered panic notifier
    [    0.869176] [drm] Initialized radeon 2.34.0 20080528 for 0000:01:00.0 on minor 0
    Does Oibaf even support Mint?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •