Page 15 of 143 FirstFirst ... 513141516172565115 ... LastLast
Results 141 to 150 of 1428

Thread: Updated and Optimized Ubuntu Free Graphics Drivers

  1. #141
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    139

    Default

    /media/sda3$ VDPAU_DRIVER=r600 mplayer -vo xvmc prova.mp2
    mplayer: Symbol `ff_codec_bmp_tags' has different size in shared object, consider re-linking
    MPlayer SVN-r33713-4.6.1 (C) 2000-2011 MPlayer Team
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support. You will not be able to use your remote control.

    Playing prova.mp2.
    AVI file format detected.
    [aviheader] Video stream found, -vid 0
    [aviheader] Audio stream found, -aid 1
    VIDEO: [] 720x480 24bpp 29.970 fps 6995.1 kbps (853.9 kbyte/s)
    Clip info:
    Software: MEncoder SVN-r34173-4.5.2
    Load subtitles in ./
    vo_xvmc: X-Video extension 2.2
    vo_xvmc: X-Video MotionCompensation Extension version 1.1
    ================================================== ========================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffmpeg2] vfm: ffmpeg (FFmpeg MPEG-2)
    ================================================== ========================
    ================================================== ========================
    Opening audio decoder: [pcm] Uncompressed PCM audio decoder
    AUDIO: 48000 Hz, 2 ch, s16le, 1536.0 kbit/100.00% (ratio: 192000->192000)
    Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
    ================================================== ========================
    AO: [pulse] 48000Hz 2ch s16le (2 bytes per sample)
    Starting playback...
    Unsupported PixelFormat 61
    Unsupported PixelFormat 53
    vo_xvmc: Found matching surface with id=32315659 on 63 port at 0 adapter
    Could not find matching colorspace - retrying with -vf scale...
    Opening video filter: [scale]
    The selected video_out device is incompatible with this codec.
    Try appending the scale filter to your filter list,
    e.g. -vf spp,scale instead of -vf spp.
    vo_xvmc: Found matching surface with id=32315659 on 63 port at 0 adapter
    Could not find matching colorspace - retrying with -vf scale...
    Opening video filter: [scale]
    The selected video_out device is incompatible with this codec.
    Try appending the scale filter to your filter list,
    e.g. -vf spp,scale instead of -vf spp.
    vo_xvmc: Found matching surface with id=32315659 on 63 port at 0 adapter
    Could not find matching colorspace - retrying with -vf scale...
    Opening video filter: [scale]
    The selected video_out device is incompatible with this codec.
    Try appending the scale filter to your filter list,
    e.g. -vf spp,scale instead of -vf spp.
    vo_xvmc: Found matching surface with id=32315659 on 63 port at 0 adapter
    Could not find matching colorspace - retrying with -vf scale...
    Opening video filter: [scale]
    The selected video_out device is incompatible with this codec.
    Try appending the scale filter to your filter list,
    e.g. -vf spp,scale instead of -vf spp.
    vo_xvmc: Found matching surface with id=32315659 on 63 port at 0 adapter
    Could not find matching colorspace - retrying with -vf scale...
    Opening video filter: [scale]
    The selected video_out device is incompatible with this codec.
    Try appending the scale filter to your filter list,
    e.g. -vf spp,scale instead of -vf spp.
    vo_xvmc: Found matching surface with id=32315659 on 63 port at 0 adapter
    Could not find matching colorspace - retrying with -vf scale...
    Opening video filter: [scale]
    The selected video_out device is incompatible with this codec.
    Try appending the scale filter to your filter list,
    e.g. -vf spp,scale instead of -vf spp.
    vo_xvmc: Found matching surface with id=32315659 on 63 port at 0 adapter
    Could not find matching colorspace - retrying with -vf scale...
    Opening video filter: [scale]
    The selected video_out device is incompatible with this codec.
    Try appending the scale filter to your filter list,
    e.g. -vf spp,scale instead of -vf spp.
    vo_xvmc: Found matching surface with id=32315659 on 63 port at 0 adapter
    Could not find matching colorspace - retrying with -vf scale...
    Opening video filter: [scale]
    The selected video_out device is incompatible with this codec.
    Try appending the scale filter to your filter list,
    e.g. -vf spp,scale instead of -vf spp.
    vo_xvmc: Found matching surface with id=32315659 on 63 port at 0 adapter
    Could not find matching colorspace - retrying with -vf scale...
    Opening video filter: [scale]
    The selected video_out device is incompatible with this codec.
    Try appending the scale filter to your filter list,
    e.g. -vf spp,scale instead of -vf spp.

    FATAL: Could not initialize video filters (-vf) or video output (-vo).


    Exiting... (End of file)
    vincenzo@AthlonII:/media/sda3$

    HI, how configure VDPAU_DRIVER=r600 default?

    to play i write VDPAU_DRIVER=r600 mplayer -vo vdpau etc.
    can simply mplayer -vo vdpau etc.
    Thanks

  2. #142
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    139

    Default

    Quote Originally Posted by oibaf View Post
    I updated the package, try in a couple of hour, hopefully it should work (before they were installed in /usr/lib/amd64-linux-gnu/vdpau/).

    Same problem /usr/lib/dri /"only 1 files"

    but, i have only this problem?

    i extract deb and copy the files inside /usr/lib/dri

    :-)
    Last edited by Vincenzov; 10-17-2011 at 10:20 AM.

  3. #143
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    139

    Default

    HI
    I am the only one having this problem?
    I am sorry to make you do extra work.
    Thanks

  4. #144

    Default

    Quote Originally Posted by Vincenzov View Post
    /media/sda3$ VDPAU_DRIVER=r600 mplayer -vo xvmc prova.mp2
    You are mixing VDPAU and XvMC here, see the instructions at https://launchpad.net/~oibaf/+archive/graphics-drivers/ for how to use it.

    Anyway I now also moved xvmc libs into /usr/lib/dri/ (new builds in a couple of hours). This means that multiarch will not be supported (probably not needed anyway...) but it should be a bit simpler to configure (i.e. i386 conf == amd64 conf == instructions on PPA page).

  5. #145
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    139

    Default

    Quote Originally Posted by oibaf View Post
    You are mixing VDPAU and XvMC here, see the instructions at https://launchpad.net/~oibaf/+archive/graphics-drivers/ for how to use it.

    Anyway I now also moved xvmc libs into /usr/lib/dri/ (new builds in a couple of hours). This means that multiarch will not be supported (probably not needed anyway...) but it should be a bit simpler to configure (i.e. i386 conf == amd64 conf == instructions on PPA page).
    OK perfect (files).

  6. #146
    Join Date
    Sep 2011
    Posts
    29

    Default

    Quote Originally Posted by oibaf View Post
    That's the latest natty kernel, but that bug may be fixed in a later kernel. Try compiling yourself latest 2.6.39.x (there are no newer kernel on http://kernel.ubuntu.com/~kernel-ppa/mainline/ for natty) or try upgrading to Ubuntu 11.10 (ships a 3.0.x kernel).
    I updated to 3.0 and now textures are fine. Speed is bad (caa 1fps) and there are some problems with shading, but it at least work
    I uploaded screenshots, but i had problems with capturing.
    http://imgur.com/a/HxtlE

    (and output http://pastebin.com/qAcrn2Um)
    Any idea about odd shading in images (ignore tearing, it's only in screenshot)?

    btw I opened bug on https://bugs.freedesktop.org/show_bug.cgi?id=41744

  7. #147
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    139

    Default

    I am only interested in GPU decoding.
    Now i have a problem to compile mplayer from svn.
    I tried to see the files but has problems with ffmpeg12vdpau on the images.
    My pc is ati 785g+ athlon II dualcore 2700 mhz.

  8. #148

    Default

    Some news:
    • I pushed updated libdrm, ati, nouveau and intel drivers for oneiric;
    • finally mesa uses -fno-builtin-memcmp by default, so I no longer need to add it in my PPA;
    • there is no more need to specify the env variable VDPAU_DRIVER to use vdpau, just select vdpau in your player (e.g. with mplayer: mplayer -vo vdpau yourvideofile).

  9. #149
    Join Date
    Aug 2007
    Posts
    6,676

    Default

    Its clear that you need a vc override too or not? For mpeg2 you need:

    -vc ffmpeg12vdpau

    you can add a "," when you put it in .mplayer/config to use the fallback for all other codecs. btw -vo vdpau is the default anyway.

  10. #150

    Default

    -vo vdpau is indeed the default, good to know.

    Anyway the point here was that you no longer need to specify the vdpau driver name (see this commit: http://cgit.freedesktop.org/xorg/dri...b76b60be8bdd8e)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •