Page 24 of 143 FirstFirst ... 1422232425263474124 ... LastLast
Results 231 to 240 of 1427

Thread: Updated and Optimized Ubuntu Free Graphics Drivers

  1. #231
    Join Date
    Jan 2012
    Location
    Italy
    Posts
    52

    Default

    Quote Originally Posted by oibaf View Post
    It's building now
    I updated the driver (now it is git-f9f8ce3), but I have still OpenGL 2.1/GLSL 1.20. Did you use enviromental variables R600_GLSL130=1 and R600_STREAMOUT=1? If you don't, why? I hope it's not a problem of Turks (AMD 6570). Thank you

  2. #232

    Default

    Quote Originally Posted by Nedanfor View Post
    I updated the driver (now it is git-f9f8ce3), but I have still OpenGL 2.1/GLSL 1.20. Did you use enviromental variables R600_GLSL130=1 and R600_STREAMOUT=1? If you don't, why? I hope it's not a problem of Turks (AMD 6570). Thank you
    Uh? The env variables must be set by you before running the OpenGL app...

  3. #233
    Join Date
    Jan 2012
    Location
    Italy
    Posts
    52

    Default

    Quote Originally Posted by oibaf View Post
    Uh? The env variables must be set by you before running the OpenGL app...
    Sorry, I think I misunderstood However...
    Code:
    OpenGL version string: 3.0 Mesa 8.0-devel (git-f9f8ce3 oneiric-oibaf-ppa)
    OpenGL shading language version string: 1.30
    Thank you oibaf

  4. #234
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    i set this options in /etc/default/grub/ R600_GLSL130=1 R600_STREAMOUT=1

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1 radeon.pcie_gen2=1 R600_GLSL130=1 R600_STREAMOUT=1"

    what do i wrong ?

  5. #235

    Default

    Quote Originally Posted by Qaridarium View Post
    i set this options in /etc/default/grub/ R600_GLSL130=1 R600_STREAMOUT=1

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1 radeon.pcie_gen2=1 R600_GLSL130=1 R600_STREAMOUT=1"

    what do i wrong ?
    Those are the kernel options. Try with:
    Code:
    R600_GLSL130=1 R600_STREAMOUT=1 glxinfo

  6. #236
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by oibaf View Post
    Those are the kernel options. Try with:
    Code:
    R600_GLSL130=1 R600_STREAMOUT=1 glxinfo
    now i get:'

    "OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD RV740
    OpenGL version string: 3.0 Mesa 8.0-devel (git-f9f8ce3 oneiric-oibaf-ppa)
    OpenGL shading language version string: 1.30
    "

    do i need set this option for every app i start ?

    or can i turn on this for general ?

  7. #237
    Join Date
    Apr 2010
    Posts
    1,946

    Default

    Quote Originally Posted by Qaridarium View Post
    now i get:'

    "OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD RV740
    OpenGL version string: 3.0 Mesa 8.0-devel (git-f9f8ce3 oneiric-oibaf-ppa)
    OpenGL shading language version string: 1.30
    "

    do i need set this option for every app i start ?

    or can i turn on this for general ?
    https://help.ubuntu.com/community/EnvironmentVariables

    scroll all way down to "persistant environiment variables".

  8. #238
    Join Date
    Jan 2012
    Location
    Vienna, Austria
    Posts
    3

    Default

    Quote Originally Posted by crazycheese View Post
    Use google to find how to:
    - add linux 3.2 kernel to your ppa
    - add xorg-edgers to your ppa

    Install driconf to configure the driver.

    All this are - three commands in terminal.

    Reboot and have fun.
    thanks but it sounds pretty discomforting for a mac-2-ubuntu switcher ;-)

  9. #239
    Join Date
    Apr 2010
    Posts
    1,946

    Default

    Quote Originally Posted by thob View Post
    thanks but it sounds pretty discomforting for a mac-2-ubuntu switcher ;-)
    You do understand that mac and ubuntu are *nix-es, and both have terminal emulators?

    Well, I thank you for reading that far then. Was quite an effort for you, obviously...

  10. #240
    Join Date
    Jan 2012
    Posts
    22

    Default

    In my etc/environment I have added the following lines:

    "export R600_GLSL130=1"
    "export R600_STREAMOUT=1"

    but I'm still seing
    OpenGL version string: 2.1
    OpenGL shading language version string: 1.20

    Have I forgot a step?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •