Page 53 of 121 FirstFirst ... 343515253545563103 ... LastLast
Results 521 to 530 of 1205

Thread: Updated and Optimized Ubuntu Free Graphics Drivers

  1. #521
    Join Date
    Aug 2012
    Posts
    371

    Default

    Quote Originally Posted by oibaf View Post
    RadeonSI is now fully supported (only on Ubuntu 13.04), radeon driver being now compiled with glamor support (glamor packages courtesy from Cybjit PPA). Please test.
    After installing your ppa, my Radeon HD 7950 shows

    OpenGL vendor string: VMware, Inc.
    OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 128 bits)
    OpenGL version string: 2.1 Mesa 9.2.0-devel (git-1681bd7 raring-oibaf-ppa)
    OpenGL shading language version string: 1.30

    So glamor doesn't seem to be loading correctly. Did I do something wrong? I just added the ppa on a fresh install of Ubuntu 13.04 and ran upgrade/dist-upgrade.

  2. #522
    Join Date
    Jul 2013
    Posts
    30

    Default So glamor doesn't seem to be loading correctly....

    did you add somethings like that in /etc/X11/xorg.conf.d/...

    Code:
    Section "Module"
        Load "dri2"
        Load "glamoregl"
    EndSection
    
    Section "Device"
        Identifier "HD7770"
        Driver "radeon"
        Option   "AccelMethod"      "glamor"
        Option   "ColorTiling"      "on" 
        Option     "ColorTiling2D"    "on"
        Option   "EnablePageFlip"   "on"
    EndSection

  3. #523
    Join Date
    Aug 2012
    Posts
    371

    Default

    Quote Originally Posted by frosth View Post
    did you add somethings like that in /etc/X11/xorg.conf.d/...

    Code:
    Section "Module"
        Load "dri2"
        Load "glamoregl"
    EndSection
    
    Section "Device"
        Identifier "HD7770"
        Driver "radeon"
        Option   "AccelMethod"      "glamor"
        Option   "ColorTiling"      "on" 
        Option     "ColorTiling2D"    "on"
        Option   "EnablePageFlip"   "on"
    EndSection
    Elaborate, I don't have such a directory in my X11 directory.

  4. #524
    Join Date
    Jul 2013
    Posts
    30

    Default So glamor doesn't seem to be loading correctly....

    so maybe you have xorg.conf file? if yes, you can add this code to xorg.conf file directly. if no... so i don't idea for this case i don't have *bunty but xorg.conf should be somewhere.


    edit
    sorry dude. for ubuntu 13.04 you better try in "/usr/share/X11/xorg.conf.d/" it's the right place.
    Last edited by frosth; 07-17-2013 at 05:38 AM.

  5. #525
    Join Date
    Aug 2012
    Posts
    371

    Default

    Quote Originally Posted by frosth View Post
    so maybe you have xorg.conf file? if yes, you can add this code to xorg.conf file directly. if no... so i don't idea for this case i don't have *bunty but xorg.conf should be somewhere.


    edit
    sorry dude. for ubuntu 13.04 you better try in "/usr/share/X11/xorg.conf.d/" it's the right place.
    I placed xorg.conf's there, in /usr/share/X11, in etc/X11, created a directory named xorg.conf.d in /etc/X11 and put xorg.conf in there -- nothing; it's intent on using llvmpipe. In Ubuntu we shouldn't need an xorg.conf anyway because it's supposed to be intelligent enough to select all the right parameters at boot.

  6. #526
    Join Date
    Jul 2013
    Posts
    30

    Default

    let me think... ubuntu has nothing to do in this case. As i know, xserver-xorg-video-ati - 1:7.1.0 doesn't set glamor acceleration by default for radeonsi. no glamor no fun
    can you paste X log? in my distro: /var/log/Xorg.0.log
    Last edited by frosth; 07-17-2013 at 01:57 PM. Reason: typo

  7. #527
    Join Date
    Aug 2012
    Posts
    371

  8. #528
    Join Date
    Jul 2013
    Posts
    30

    Default

    HTML Code:
    cat dmesg.mmstick | grep -i glamor
    [     6.279] (II) LoadModule: "glamoregl"
    [     6.280] (WW) Warning, couldn't open module glamoregl
    [     6.280] (II) UnloadModule: "glamoregl"
    [     6.280] (II) Unloading glamoregl
    [     6.280] (EE) Failed to load module "glamoregl" (module does not exist, 0)
    [     6.318] (**) RADEON(0): Option "AccelMethod" "glamor"
    [     6.318] (EE) RADEON(0): glamor requires Load "glamoregl" in Section "Module", disabling.
    Did You install "glamor-0.5-1~git20130313" package?
    Last edited by frosth; 07-17-2013 at 02:17 PM. Reason: typo...

  9. #529
    Join Date
    Aug 2012
    Posts
    371

    Default

    What's the apt-get syntax for that? apt-get install glamor just says unable to locate package.

  10. #530
    Join Date
    Jul 2013
    Posts
    30

    Default

    i don't use ubuntu, but try: "find / | grep -i glamoregl" - it always work.

    or just install it(glamor package) from launchpad

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •