Page 9 of 138 FirstFirst ... 78910111959109 ... LastLast
Results 81 to 90 of 1372

Thread: Updated and Optimized Ubuntu Free Graphics Drivers

  1. #81

    Default

    Quote Originally Posted by curaga View Post
    You might want to add -fno-builtin-memcmp. Supposedly a big boost, but in my tests I saw no measurable difference. Could be more useful in an app swapping shaders more often.
    OK, I eventually added -fno-builtin-memcmp in the packages building now.

  2. #82

    Default Updates

    Mesa:
    • Reverted to using default -O2 gcc optimization flag rather than previous -Os since it's faster on intel (thanks bongmaster2 for the performance tests!).
    • Build with -fno-builtin-memcmp for increased performance (thanks curaga for suggesting it!). Eventually that should be added upstream.
    • More r600g improvements.


    Also included dri2proto 2.6, needed for newer xf86-video-intel.

    There will be no more updates until the 18th, since I am going on vacation .

  3. #83
    Join Date
    Oct 2010
    Posts
    74

    Default

    you are very usefull for the community. will be a hard time self compiling.

  4. #84

    Default Updates

    Mesa
    • pipe-video branch is now officially merged on mesa master. libg3dvl-mesa package with nouveau (XvMC only), r300 and r600 (XvMC + VDPAU) hw drivers is again available (softpipe drivers now also supported). See this post for instructions on using it.
    • Floating-point depth buffers.
    • glsl-to-tgsi branch no longer included (due to merge conflicts).


    Also included x11proto-gl 1.4.14, needed by current mesa.

  5. #85

    Default Updates

    Mesa
    Added PP (Post Processing) branch. It actually includes Jimenez's MLAA and nocolor filters. Currently supported only with software rendering. To test:
    Code:
    LIBGL_ALWAYS_SOFTWARE=1 pp_jimenezmlaa=8 glxgears
    LIBGL_ALWAYS_SOFTWARE=1 pp_nored=1 glxgears
    LIBGL_ALWAYS_SOFTWARE=1 pp_nogreen=1 glxgears
    LIBGL_ALWAYS_SOFTWARE=1 pp_noblue=1 glxgears
    Multiple filters can be combined.

  6. #86
    Join Date
    Jul 2011
    Posts
    4

    Default Ubuntu 11.04 install problems

    I just installed the latest packages from this repo but (for the first time) got the following errors. Could it be related to the latest 280.04 nvidia drivers from the bumblebee PPA, https://launchpad.net/~mj-casalogic/+archive/bumblebee/ ? Any ideas would be greatly appreciated.


    Setting up libgl1-mesa-dri (7.12~git1107260906.b189d1~gd~n) ...
    Setting up libgl1-mesa-dri-experimental (7.12~git1107260906.b189d1~gd~n) ...
    Setting up libglapi-mesa (7.12~git1107260906.b189d1~gd~n) ...
    Setting up libgl1-mesa-glx (7.12~git1107260906.b189d1~gd~n) ...
    update-alternatives: error: alternative link /usr/lib/xorg/extra-modules is already managed by i386-linux-gnu_gl_conf.
    dpkg: error processing libgl1-mesa-glx (--configure):
    subprocess installed post-installation script returned error exit status 2
    dpkg: dependency problems prevent configuration of libglu1-mesa:
    libglu1-mesa depends on libgl1-mesa-glx | libgl1; however:
    Package libgl1-mesa-glx is not configured yet.
    Package libgl1 is not installed.
    Package libgl1-mesa-glx which provides libgl1 is not configured yet.
    dpkg: error processing libglu1-mesa (--configure):
    dependency problems - leaving unconfigured

    Best!

  7. #87
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    hon runs very slow with the lastest dist-upgrade with your driver .. whats up ?

  8. #88
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by Qaridarium View Post
    hon runs very slow with the lastest dist-upgrade with your driver .. whats up ?
    kde also turns of 3d desktop. kwin.

    i think it runs software rendering mode...

    but because why?

    Renderer: Gallium 0.4 on amd rv730
    OpenGL version: 2.1 Mesa 7.12-devel (git-b189d16 natty-oibaf-ppa+pp-branch)

  9. #89

    Default

    Quote Originally Posted by Qaridarium View Post
    kde also turns of 3d desktop. kwin.

    i think it runs software rendering mode...

    but because why?

    Renderer: Gallium 0.4 on amd rv730
    OpenGL version: 2.1 Mesa 7.12-devel (git-b189d16 natty-oibaf-ppa+pp-branch)
    There were some changes to winsys/radeon that may explain it.

  10. #90
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by oibaf View Post
    There were some changes to winsys/radeon that may explain it.
    i install the catalyst because of this... and the catalyst do also have down sides... mouse input lag bug if i wana trop a intem in heroes of newerth.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •