Page 23 of 33 FirstFirst ... 132122232425 ... LastLast
Results 221 to 230 of 327

Thread: AMD 8.41.7 Display Driver Released -- The Holy Crap Edition!

  1. #221
    Join Date
    Apr 2007
    Location
    Bulgaria
    Posts
    269

    Default

    Not my cup of tea for my mobility radeon. I guess I'll wait for next month's.

    And just for the recored, I bought my laptop without Windows installed on it, some barebones have that option

  2. #222
    Join Date
    Jun 2006
    Posts
    24

    Post

    Quote Originally Posted by opera View Post
    Oh, so a game gets a few more FPS, and that makes it great? Wow. Obviously doesn't take much to satisfy some.

    For others, we think that a few more serious bugs needs to be solved, and I predicted them not to have been, and I was right. Unfortunately.
    I'm glad you're happy with ATI's amazing progress though.
    Just one question opera: Have you ever developed a complex program that does a lot of processing (or just any program in C or a C like language)? It needn't be a driver, be a hardware-software interface of any kind but a program which is performance critical and huge.

    If you've worked in a project like these, I think you'll have that sense of appreciation. Especially in the arena of "extremely programmable hardware".

    Since AMD bought ATI, things have changed. They are trying to give a seamless rebirth to a new driver generation without breaking the support. Things would be simpler if they said: "Wait 1 year without any driver and you'll see the miracle" but at least they've "tried" to support new cards and things.

    I'm a computer engineer. I'm a fetishist about processors and hardware. I know what takes to program these (taking notes to papers, converting registry values, sometimes debugging assembly crypts). And I use these guys cards since nVidia was not able to make gauraud shading and smoothing in hardware.

    ATI is a huge company which has some fair share in customized simulator graphics, mutli-head 2D graphics (Their creepy 9000 chip can do 16 heads if required!) and such. So it was their fault not to support linux but with AMD it has changed.

    Yes I have some weird and annoying bugs too. I was using my card with vesa for 8 months but with 8.41 things started to change. I'm not hopeless about ATI. They have opened their spex too. It's equally important as 8.41 drivers.

    OTOH, It's important to say that ATI's creepy driver is far better in hotplugging hardware and screen detection than nVidia.

    So opera, give the guys some respect and credit. Your lovely nVidia guys have an annoying locking-up bug in their latest drivers and they didn't fixed it for 80 days. c'mon!

    Instead pf provocating the board, please shut up. Already nobody listening to you but, I was unable to resist to write this post!.

  3. #223
    Join Date
    Apr 2007
    Location
    Mexico City, Mexico
    Posts
    900

    Default

    Quote Originally Posted by sundown
    And just for the recored, I bought my laptop without Windows installed on it, some barebones have that option
    Where did you get it? I'm currently hunting for a laptop without an OS or preferrably with Linux preloaded. I looked at
    Empreror Linux, but bringing one of those babies down here is as costly as a MacBook... Pro (quite pricey), and that for a Toucan T61 model, but with customs and other taxes, plus shipping and handling it is virtually twice the price.
    Last edited by Thetargos; 09-13-2007 at 04:04 AM.

  4. #224
    Join Date
    Sep 2007
    Posts
    11

    Default

    Okey i hope to stay as objective as possible in this post (going to be hard because i am biased in some way... actually who the hell isn't biased when it comes to linux and amd/ati?)!

    First of all i think almost all of the users do respect your effords Michael. You test every release and well write reviews about it. I don't know if ATI/AMD are so happy about it but probably they weren't with this months review. The only problem you have Michael is to be objective (again i do understand it). In your 8.41 review you said:

    ...
    While the 8.41 release is designed for the R600 series, in our tests with the R300 through R500 series the driver has worked out quite well. There have been some corruption issues and other minor problems but nothing severe.
    ...
    So you did mention that this release is primarily for the r600-series but you said that there were MINOR problems and NOTHING severe on the older cards when you tested the driver. From what i've read in this forums there are BIG problems with this drivers on the older generation cards. Again i do understand that you can't test every single card with an ATI-chip but still when you read the review you get the impression that it the new driver WILL work on older cards and you WILL get the promised huge performance boost. That's why alot of ppl (including myself i have to admit) got so excited about it and that's why we are so disappointed now after we had to remark that it's not as it was promised it would be.

    As the only real deal i need the vid-card for in linux (at the moment... in the future it would be cool to have desktop-effects with aiglx/compiz-fusion too...) is watching movies (for playing games i still use good old windows) and i read that xv is still broken (on some cards and i'm one of the lucky ppl who seems to own such a card...) i probably won't try this release (maybe i get bored and tell myself that i can use some kind of adventure and still try it out who knows... )

    Once again i do understand that you can't test everything but from a reviewer i do expect some kind of unbiased/objective view of things when he or she reviews something (still i do understand that this is almost impossible as everybody has some kind of personal opinion which affects things... when i would write a ati-linux-driver review it would possibly be alot more skeptical as yours are because of the experiences i made with linux and ati-cards...)

  5. #225
    Join Date
    Mar 2007
    Location
    MN, United States
    Posts
    285

    Default

    Quote Originally Posted by spielc View Post
    As the only real deal i need the vid-card for in linux (at the moment... in the future it would be cool to have desktop-effects with aiglx/compiz-fusion too...) is watching movies (for playing games i still use good old windows) and i read that xv is still broken (on some cards and i'm one of the lucky ppl who seems to own such a card...) i probably won't try this release (maybe i get bored and tell myself that i can use some kind of adventure and still try it out who knows... )
    Yeah, and maybe you'll be luckier than me, I didn't even get far enough to try it, it simply doesn't work. I hope AMD/ATI can fix that AGP bus issue too (fglrx detecting my agp card as pcie), because from the looks of the xorg log, it still exists in 8.41:

    Code:
    (II) Loading sub module "fglrxdrm"
    (II) LoadModule: "fglrxdrm"
    (II) Loading /usr/lib/xorg/modules/linux//libfglrxdrm.so
    (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
    	compiled for 7.1.0, module version = 8.41.7
    	ABI class: X.Org Server Extension, version 0.3
    (--) fglrx(0): VideoRAM: 262144 kByte, Type: DDR3
    (II) fglrx(0): PCIE card detected
    It should say something like this instead, but i've never in the history of fglrx using this card, have seen it:

    Code:
    (II) Loading sub module "fglrxdrm"
    (II) LoadModule: "fglrxdrm"
    (II) Loading /usr/lib/xorg/modules/linux//libfglrxdrm.so
    (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
    	compiled for 7.1.0, module version = 8.41.7
    	ABI class: X.Org Server Extension, version 0.3
    (--) fglrx(0): VideoRAM: 262144 kByte, Type: DDR3
    (II) fglrx(0): AGP card detected
    Last edited by Malikith; 09-13-2007 at 06:20 AM.

  6. #226
    Join Date
    Sep 2007
    Location
    Michigan, USA
    Posts
    10

    Default

    Quote Originally Posted by Malikith View Post
    Yeah, and maybe you'll be luckier than me, I didn't even get far enough to try it, it simply doesn't work. I hope AMD/ATI can fix that AGP bus issue too (fglrx detecting my agp card as pcie), because from the looks of the xorg log, it still exists in 8.41:

    Code:
    (II) Loading sub module "fglrxdrm"
    (II) LoadModule: "fglrxdrm"
    (II) Loading /usr/lib/xorg/modules/linux//libfglrxdrm.so
    (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
    	compiled for 7.1.0, module version = 8.41.7
    	ABI class: X.Org Server Extension, version 0.3
    (--) fglrx(0): VideoRAM: 262144 kByte, Type: DDR3
    (II) fglrx(0): PCIE card detected
    It should say something like this instead, but i've never in the history of fglrx using this card, have seen it:

    Code:
    (II) Loading sub module "fglrxdrm"
    (II) LoadModule: "fglrxdrm"
    (II) Loading /usr/lib/xorg/modules/linux//libfglrxdrm.so
    (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
    	compiled for 7.1.0, module version = 8.41.7
    	ABI class: X.Org Server Extension, version 0.3
    (--) fglrx(0): VideoRAM: 262144 kByte, Type: DDR3
    (II) fglrx(0): AGP card detected
    I'm having the same problem... incorrectly detects my AGP card as PCIE. This seems to have the cascade effect of also causing 0x AGP speed (base PCI) and having the driver fail to see my 512mb ram and instead see only 256.

    I also have the glesx.so crash on X start, so 3d acceleration etc is completely absent from this release for me.

    The AGP/PCIE problem cascade was in the 8.40 drivers as well, but the glesx.so crash is new to 8.41.

  7. #227
    Join Date
    Mar 2007
    Location
    MN, United States
    Posts
    285

    Default

    Quote Originally Posted by phreadom View Post
    I'm having the same problem... incorrectly detects my AGP card as PCIE. This seems to have the cascade effect of also causing 0x AGP speed (base PCI) and having the driver fail to see my 512mb ram and instead see only 256.

    I also have the glesx.so crash on X start, so 3d acceleration etc is completely absent from this release for me.

    The AGP/PCIE problem cascade was in the 8.40 drivers as well, but the glesx.so crash is new to 8.41.
    Yeah, my video ram amount is actually detected properly (256), just the AGP problem remains, problem with 0x agp, is well, things that already are slow, get alot slower . I'm guessing you've got a X1600 pro? I got a x1600xt. I've tried the card in Windows and well, it flies in Windows. Luckily I have a Geforce FX 5500 to hold me off, until a good driver comes, funny thing is, its faster than the x1600xt right now, and its alot more reliable for me. But I would much rather run the x1600xt when the time is right.

  8. #228
    Join Date
    Apr 2007
    Posts
    9

    Default

    WOOT!
    _64 ??

    Does this mean what I think it does?

  9. #229
    Join Date
    Sep 2007
    Location
    Michigan, USA
    Posts
    10

    Default

    Quote Originally Posted by Malikith View Post
    Yeah, my video ram amount is actually detected properly (256), just the AGP problem remains, problem with 0x agp, is well, things that already are slow, get alot slower . I'm guessing you've got a X1600 pro? I got a x1600xt. I've tried the card in Windows and well, it flies in Windows. Luckily I have a Geforce FX 5500 to hold me off, until a good driver comes, funny thing is, its faster than the x1600xt right now, and its alot more reliable for me. But I would much rather run the x1600xt when the time is right.
    Yep, x1600Pro 512mb. Unfortunately I don't have a GeForce to fall back on... so I'll just wait it out. I'm having enough fun in Linux aside from that to keep me from going back into Windows unless it's an "emergency".

    For all the bitching I've done, I really do appreciate the direction AMD/ATI is going... I'm just a little put out after high expectations for the current driver release.

  10. #230
    Join Date
    Mar 2007
    Location
    MN, United States
    Posts
    285

    Default

    Quote Originally Posted by phreadom View Post
    Yep, x1600Pro 512mb. Unfortunately I don't have a GeForce to fall back on... so I'll just wait it out. I'm having enough fun in Linux aside from that to keep me from going back into Windows unless it's an "emergency".

    For all the bitching I've done, I really do appreciate the direction AMD/ATI is going... I'm just a little put out after high expectations for the current driver release.
    Yeah, hopefully things will go right on the 8.42 driver. I hope the hype that was done on this one, was actually mean't for that one. We're getting AIGLX on that release, which is interesting considering the amount of bugs that still remain.

    But hopefully things will go right, AMD knows of the AGP bus issue, just hasn't been fixed yet, perhaps they have the rest of their new codebase going in? I couldn't imagine that being all, theres still alot that needs to be replaced/fixed from what I can see. But this is a start. This is the most they've attempted to do with their linux driver since, well, ever.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •