Page 13 of 33 FirstFirst ... 3111213141523 ... LastLast
Results 121 to 130 of 327

Thread: AMD 8.41.7 Display Driver Released -- The Holy Crap Edition!

  1. #121

    Default

    Quote Originally Posted by jackkerouac View Post
    Perhaps next time, less hype and more facts.
    Our tests are all facts. I used all of the hardware that was accessible to run these benchmarks and as the graphs show, there are clear performance improvements. I never told you that this would be a bug-free release or anything to that extent. I was reporting on the performance and everything I and others had reported. This remains truly a phenomenal release when it comes to the performance improvements. It's now possible to play Quake 4 or Quake Wars with hardware on previous drivers that would previously choke.

  2. #122
    Join Date
    Jun 2007
    Location
    .ro/.ca
    Posts
    232

    Default

    Quote Originally Posted by jackkerouac View Post
    I think next time, I am going to go somewhere else for my reviews on ATI releases, as this site obviously has some "fan-boy" issues. And instead of just saying "Okay, maybe we hyped this up a little too much," we get a lot of excuses and complaints about people complaining.
    A bold accusation for an user that just pops out of the aether.

    Quote Originally Posted by jackkerouac
    This driver doesn't work for the majority of people, it seems.
    Say what?

    Quote Originally Posted by jackkerouac
    The impression most people seemed to have gotten from this site's hype is that it would. There is no way to sugar coat that.

    Perhaps next time, less hype and more facts.
    The reason Michael gave us is at least plausible ("the driver is geared towards r600"), and I choose to believe him.

    The driver does show performance improvement, even though at the moment is not spectacular (NOTE: again, my benchmarks were done on Maximum Visual Quality at 1280x1024, it's only normal the improvement is not titanic).

  3. #123
    Join Date
    Aug 2007
    Posts
    15

    Default

    Quote Originally Posted by jackkerouac View Post
    Well, it doesn't work for me. I'm running in Ubuntu Feisty a X1650 Pro and my X won't start.
    Error messages, debuging info? Anything. How do you expect to get help if you don't include any of this?

  4. #124
    Join Date
    Sep 2007
    Posts
    18

    Default

    Quote Originally Posted by adamk View Post
    Except that, unless you've polled everyone who's installed 8.41, you can't honestly say that it doesn't work for the majority of people. Based on the complaints here, you may get that impression, but most people don't pop on-line to say something works... They pop on-line to bitch and moan when something doesn't work.
    Read this:

    And instead of just saying "Okay, maybe we hyped this up a little too much," we get a lot of excuses and complaints about people complaining.
    Our tests are all facts. I used all of the hardware that was accessible to run these benchmarks and as the graphs show, there are clear performance improvements. I never told you that this would be a bug-free release or anything to that extent. I was reporting on the performance and everything I and others had reported. This remains truly a phenomenal release when it comes to the performance improvements. It's now possible to play Quake 4 or Quake Wars with hardware on previous drivers that would previously choke.
    Reply With Quote
    A truly phenomenal relase? You've got to be kidding.
    Last edited by jackkerouac; 09-12-2007 at 03:01 PM.

  5. #125
    Join Date
    May 2007
    Posts
    352

    Default

    Quote Originally Posted by adamk View Post
    A quick doom3 comparison with my X850XT...

    8.40.4, demo1, 45.7
    8.41.7, demo1, 55.6

    I'll try with my X1300 next.

    The driver does seem to install and run fine here.

    Adam
    With my X1300:

    8.40.4, demo1, 35.7
    8.41.7, demo1, 50.4

    These are all on medium settings, at 1024x768. No AA or AF.

    Adam

  6. #126
    Join Date
    May 2007
    Posts
    352

    Default

    Quote Originally Posted by jackkerouac View Post
    Read this:





    A truly phenomenal relase? You've got to be kidding.
    It is for the majority of users (see, I can pull statistics right out my ass like you).

    Adam

  7. #127
    Join Date
    Jun 2007
    Location
    .ro/.ca
    Posts
    232

    Default

    Quote Originally Posted by Michael View Post
    It's now possible to play Quake 4 or Quake Wars with hardware on previous drivers that would previously choke.
    Am I the only one getting Ultra-Crappy visual quality* with Quake 4?

    * = almost as good as MDK's

    EDIT: am I the only one playing quake4?
    Last edited by Xipeos; 09-12-2007 at 03:20 PM.

  8. #128
    Join Date
    Sep 2007
    Location
    Belgium
    Posts
    8

    Exclamation Download the correct driver !!!

    All you whiners, please download the correct driver @ http://ati.amd.com/support/driver.html.
    and choose youre correct graphics card.

    You will see that if you don't own an ATI HD 2x00 series that you wont get 8.41 but 8.40 that works fine for the most of us. When, and only when we see 8.41 for the other cards can can start to complain.

    It is completely normal that when using an incorrect driver you get unpredictable results.

    I'm using a Mobility X700 with the AMD 8.37 (on kUbuntu), and everything that should work, works fine.
    Nonetheless i'm looking out for the new driver esp. 8.42 for Compiz.

    'BE the difference that makes a difference' - JEWEL
    Last edited by zittergie; 09-12-2007 at 03:06 PM. Reason: Url editing

  9. #129
    Join Date
    Aug 2007
    Posts
    15

    Default

    A truly phenomenal relase? You've got to be kidding.
    Read this:

    With my X1300:

    8.40.4, demo1, 35.7
    8.41.7, demo1, 50.4

    These are all on medium settings, at 1024x768. No AA or AF.
    15fps from a driver, yes, thats phenomenal.

  10. #130
    Join Date
    Dec 2006
    Posts
    112

    Default

    Quote Originally Posted by zittergie View Post
    8.40 that works fine for the most of us.
    No it doesn't. You just got used to it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •